how to setup freephone line in obi202

Started by tany2002, January 20, 2014, 01:22:14 PM

Previous topic - Next topic

tany2002

I set up freephoneline on SP2 by following obitalk.com. The status shows "registered". It can receive call, but cannot make a call, and report an error "400". GOOGLE VOICE on SP1 works fine. Don't know what's wrong with OBITALK setting.

Farfone

I am having the same issue but with Obi voice .  Were you able to remedy the situation?  If so how ? 

Thanks !

Faisi

Hello All, I am also facing the same exact issue.

SP1 = Google Voice (inbound and outbound is perfectly working fine)---Status = Connected
SP2 = Fongo (inbound working and outbound is not working) ----Status = Registered.

SP2 outgoing does not work, i don't know what needs to enabled.
Can you please help, by the way I am using OpenDNS with Rogers Modem, if this has to do something ?

Just as an FYI, I have downloaded freephoneline on my laptop, outgoing and incoming works perfectly fine.
from OBI device, hooked up to SP2 phone, outgoing is not working. Google Voice outgoing/incomming works so it might not be router issue.

I have also added / router ports but still no luck:

Allow Outgoing:
TCP Ports: 6800, 5222, 5223
UDP Ports: 5060, 5061, 10000 to 11000, 16600 to 16998, 19305
Allow Incoming on UDP Port: 10000


Any help in this regards is highly appreciated.



SteveInWA

Quote from: Faisi on February 21, 2016, 05:40:49 PM
Hello All, I am also facing the same exact issue.

SP1 = Google Voice (inbound and outbound is perfectly working fine)---Status = Connected
SP2 = Fongo (inbound working and outbound is not working) ----Status = Registered.

SP2 outgoing does not work, i don't know what needs to enabled.
Can you please help, by the way I am using OpenDNS with Rogers Modem, if this has to do something ?

Just as an FYI, I have downloaded freephoneline on my laptop, outgoing and incoming works perfectly fine.
from OBI device, hooked up to SP2 phone, outgoing is not working. Google Voice outgoing/incomming works so it might not be router issue.

I have also added / router ports but still no luck:

Allow Outgoing:
TCP Ports: 6800, 5222, 5223
UDP Ports: 5060, 5061, 10000 to 11000, 16600 to 16998, 19305
Allow Incoming on UDP Port: 10000


Any help in this regards is highly appreciated.




You shouldn't need to open any firewall ports.

Read:  http://forum.fongo.com/viewtopic.php?f=15&t=16090

Faisi

Hello Steve, Strange thing is that I have used freephoneline (my ported number) from laptop through FONGO app and it works flawless, when using OBI I am receiving calls but not outgoing(only Fongo). Here is the theory:

Configuration on OBI202.
SP1 = Google Voice (inbound and outbound is perfectly working fine)---Status = Connected
SP2 = Fongo (inbound working and outbound is not working) ----Status = Registered.

SP2 outgoing does not work, i don't know what needs to enabled--- I have followed "Updated OBi100 Guide.pdf" but still it fails.
Can you please help, by the way I am using OpenDNS with Rogers Modem, if this has to do something ?

SteveInWA

Forum member Mango is the Freephoneline/Fongo expert; maybe he's lurking and will respond.

I do know that OpenDNS can cause problems with OBis.  Try using Google's high-performance DNS servers instead:

8.8.8.8 primary
8.8.4.4 secondary

Faisi

Hello everyone, I made a little progress.

Help me out of this situation please, Now I am again blocked from another problem.

Outgoing calls works from SP1 = Google Voice = without adding 1 (I can reply using the Phone1 Handset)
Outgoing calls are working from SP2 - FPL with the following restrictions( I cannot reply using Phone 2 Handset)
If replied to the same number when a call is received, call ended with error with reason 484.
If added 1 in front(of the received call), call ended with reason 480
If not added 1 in front(of the received call), call ended with reason 484
If called with **21<then number> it works, I don't want to write down the received call and then press **21 then number every time.

Question is how can I hide pressing **21 ? and If I am able to reply directly from Phone2 Handset, same as Phone1 handset ?
I don't want to redirect through SP1 google voice number either, I want a home phone which is a custom number(FPL) to be able to make and receive calls same as used to be before porting ?
Can you help me out here, i believe digimaps or outgoing rule sets have to be updated, I am very very new to this and don't know how to fix this...

here are the further setting:
Inline image 1

Brisk

#7
Quote from: Faisi on February 23, 2016, 08:41:59 AM

Question is how can I hide pressing **21 ?

It may have saved you some headaches had you provisioned Freephoneline on SP1 and GV on SP2 instead of the reverse.

You need to enter the Obitalk Expert Configuration menu.

Go to Physical Interfaces>>PHONE2 Port>>PHONE Port>>PrimaryLine

Then select SP2 Service for PrimaryLine. Save your settings.

It's doubtful that dialing 1 matters. If it does, you should post your ITSP Profile B's Digitmap, Phone2 Port's Digitmap, and Phone2 Port's Outboundcallroute for others to examine.

That's not Fongo, by the way. It's Freephoneline. Fongo is not a BYOD service. They're both divisions of Fibernetics, which is a Canadian CLEC.

Definitely do not port forward, unless you like to invite skiddies into your LAN.

For future reference, voip4.freephoneline.ca:6060 is intended for Rogers' integrated modem and router devices with SIP ALG settings hidden. To make matter worse, those Hitron devices have SIP ALG enabled with no way of disabling that setting without Rogers disabling it for the customer. I doubt having SIP ALG enabled and hidden from the user is a problem that is isolated to these Hitron products that Rogers distributes. If a user has his or her own router, it's advisable to put Rogers' modem in bridge mode. From there, should one way audio issues still arise after testing, the user should attempt to disable SIP ALG or SPI in his or her own router. If those options aren't available, switching ProxyServer to voip4.freephoneline.ca:6060 from voip.freephoneline.ca or from voip2.freephoneline.ca should be the next test. Additionally, changing X_UserAgentPort in an Obihai ATA to a value higher than 20000 may help circumvent a SIP ALG issue, depending on the router being used.

Perhaps even more perplexing, Freephoneline doesn't force proxy RTP at the switch. Without X_DiscoverPublicAddress and X_UsePublicAddressInVia enabled in an Obihai ATA, it's possible to get RTP packets sent pointlessly to LAN IPs, 192.168.x.x perhaps, instead of WAN IPs with Freephoneline.

Webslinger

#8
A lot of useful information can be found over in these threads:
http://forums.redflagdeals.com/newegg-obihai-obi200-ata-49-99-1-50-ehf-5-99-shipping-tax-2046832/

http://forums.redflagdeals.com/freephoneline-ca-free-local-soft-phone-line-lifetime-voip-821229/

Freephoneline's recommended settings can be found here: http://support.freephoneline.ca/hc/en-us/articles/212430746-VoIP-Unlock-Key-Credentials

#1 was written by Pianoguy on redflagdeals forums.

For anyone using Obihai ATAs, the .pdf guides and Obitalk.com do not configure the Obihai ATAs to conform to the recommended guidelines provided by Freephoneline.

These changes should be made:

1. Under Voice Services-->SP(FPL) Service

X_KeepAliveEnable: enabled

X_KeepAliveExpires: 20 (Obitalk.com uses 15, which differs from what Freephoneline recommends)

X_KeepAliveMsgType: notify

If notify, is not, as a X_KeepAliveMsgType available for you, try what Pianoguy wrote here:

Quote from: Pianoguy
   X_KeepAliveEnable: Checked
   X_KeepAliveExpires: 20
   X_KeepAliveMsgType: custom
   X_CustomKeepAliveMsg: mtd=NOTIFY

For OBi20x, with firmware 3.1.0 (Build: 5285), "X_KeepAliveMsgType: notify" is selectable: http://fw.obihai.com/OBi202-3-1-0-5285.fw


Again, refer to Freephoneline's published recommended settings: http://support.freephoneline.ca/hc/en-us/articles/212430746-VoIP-Unlock-Key-Credentials

2. Under Service Providers-->ITSP Profile (FPL)-->RTP

KeepAliveInterval: 20


3. Service Providers-->ITSP Profile (FPL)-->SIP

X_UsePublicAddressInVia: enabled

Freephoneline (FPL) configures its switches oddly. To help avoid one-way audio issues, enable this setting.


4. Service Providers-->ITSP Profile (FPL)-->SIP

Uncheck the box under the Value column to disable X_Use302ToCallForward

Freephoneline requires calls to be bridged if you want your ATA to forward calls.
If X_Use302ToCallForward is enabled, calls that are forwarded by the ATA (as opposed to using Freephoneline's Follow Me feature) will be dropped to voicemail


5.  Voice Services-->SP(FPL) Service

X_UserAgentPort would be better as a random port number between 30000 and 65535. Just pick a port number in that range.

By using a high random port you help to thwart SIP scanners and may also circumvent a faulty SIP ALG feature in your router.

6. Unless I'm not seeing something, the configuration .pdf guides miss
RegisterRetryInterval needing to be 120

That's found under Service Providers-->ITSP Profile (FPL)-->SIP

If you make more than 5 registration attempts within a 5 minute period, you will be temporarily IP banned by the FPL server you were attempting to register with.

7. Service Providers–>ITSP Profile (FPL)–>General

DigitMap: (1xxxxxxxxxx|011XX.S3|[2-9]xxxxxxxxx|*98|911)

Here's an alternative example:
(1xxxxxxxxxx|011XX.S3|[2-9]xxxxxxxxx|<211:4163974636>|<311:4163922489>|<511:4162354686>|<611:4164772010>|<811:8667970000>|*98|911)

The digitmap is appropriate for Toronto. For 211, 311, 511, 611, 811 you will need to look up the corresponding phone numbers for your area and replace the phone number after the colon.


Mipd is for IP dialing
[^*#]@@. is for sip uri
Neither is needed with Freephoneline. They should be removed.

[6-7]x*xxxxxxxxxxx. in the .pdf guide is complete nonsense and should never be used since it can't logically apply to anything.

XX. is usually not needed (and actually, inadvisable, since it can apply to anything and, due to it being an indefinite variable creates a 10 second timeout in the ATA while it waits for the user to finish entering a phone number).

*98 is for voicemail, which works with Freephoneline, by default.

8. Navigate to Codecs–>Codec Profile (A or whatever the VoIP service you're using is assigned to. You can determine this under Voice services-->SP[freephoneline] Service-->X_CodecProfile)

i. Uncheck the default boxes for Enable (Fax Event) and T38ECM

ii. Check or enable the boxes under the Value column for Enable (Fax Event) and TC8ECM.

T.38 Fax protocol works with an OBi200 or OBi202 and Freephoneline.


9. Star Code Profiles (A & B)

Code28: *99, Blind Transfer, coll($Bxrn)

Blind Transfer can't be *98 with Freephoneline. *98 is meant for Voice mail. Change Blind transfer to *99 or something other than *98. Obitalk's preset configuration doesn't have this set properly for FPL.


10. If FPL is your primary service, then
Under Voice Services-->SP(FPL), the following should be enabled (and they're not in the .pdf guides for some unknown reason) if you want Voicemail notification to work:

MWIEnable
MWIEnable2 (OBi202)
X_VMWIEnable
X_VMWIEnable2 (OBi202)


11. If you were issued a modem/router combo by your ISP that has SIP ALG forced on with no way to disable it (Rogers Hitron router/modem combos, for example), try using voip4.freephoneline.ca:6060 for the ProxyServer, which is intended to help avoid SIP ALG issues.

No one should be port forwarding.