Some bug fixes are needed

Started by OZOi, April 26, 2011, 03:06:48 PM

Previous topic - Next topic

OZOi

Frame based design can easily bring more problems, then benefits for its users and designers. It's always better to avoid it at all... Some of the problems are not so obvious (like, there is no way to keep a link on a particular configuration page - address bar always contains the frame page link instead), others are not. But nevertheless, they create a lot of inconvenience or lead to obvious bugs.

Here are some examples:

1. Frame in frame problem.
There is a lot of ways to get into it. One of them - submit a change and then click on Return button offered.
See the picture below:


2. Here is yet another example - if you click on menu in the left frame System Management | Auto Provisioning (as well as any other 3 bottom items in the menu) the page is opened not in the right frame (as it's supposed to be), but in the left frame instead, replacing the menu itself...
See the picture here:


3. Some pages have broken layout. The picture below shows how Call History page looks like in IE7 browser. As you can see, the table is far on the right side of the browser. I have to use horizontal scroll bar just to be able to see anything there...


All the pictures above were taken with Internet Explorer 7 running on Windows XP. OBi100 device has v.1.2.0 installed.

jimates

Other than an occasional glitch with the call history page like you show, I have not had any other problems with the web.

ShermanObi

We have been looking into this since the day it was originally posted on another forum.  Other than the issue with call history (that jimates mentions here as well), which is fixed and will be available in an upcoming maintenance release, we have been unable to reproduce (using a virtual machine running XP).  We will keep trying.

OZOi

@jimates and @ShermanObi:

Thank you for checking and posting feedback. I've re-tested it again and again and it appears that the problems #1 and #2 are related to Proxomitron (web proxy service). After moving OBi100 host into Proxomitron's bypass list (and removing files from web cache many times) those problems are gone now. I still see the problem #3 though. And it's good to know that it will be fixed in a new release.

Sorry that I have not noticed the relation between problems #1, #2 and local proxy server. The weird thing was that the very similar menu item "System Management | Network Settings" was working well, while the next menu items "Auto Provisioning" and others below, were not with 100% repeatability. It was my fault and there is no need to further investigate those issues.

Thank you again and I'll be waiting for a new release...