Set up IdeaSIP as SP2

Started by Brian, May 14, 2011, 02:18:23 PM

Previous topic - Next topic

Brian

I am trying to set up IdeaSIP as SP2 (Google voice is SP1).  I used the following settings in ObiTalk:
Generic Service Provider Settings:
Configuration Name: Ideasip
Service Provider Proxy Server: proxy.ideasip.com
Service Provider Proxy Server port: 5060
Outbound Proxy Server: proxy.ideasip.com
Outbound Proxy Server port: 5060
Username: 1101xxxxxxx
Password: xxxxxxxx

In addition, I set the following using OBI Expert:
ITSP Profile B General:
STUNEnable: checked
STUNServer: stun.ideasip.com
X_STUNServerPort: 3478
X_ICEENable: checked

However, I see the following error for SP2 when I do that:
Register Failed: 479 (server=208.97.25.11:5060; retrying)

I contacted Obi support, but they did not know what 479 error code means.


RonR

IdeaSIP works fine here.

Leave ITSPB -> General -> X_ICEEnable unchecked.

Leave ITSPB -> SIP -> OutboundProxy blank.

Make sure SP2 -> X_ServProvProfile is set to B.

Brian

Still doesn't work.  I believe it is due to STUN settings.  I got this to work in softphone.  I disabled STUN server in softphone, then I was able to see the same error (479: private IP address not allowed).

RonR

#3
I'm using stun.ideasip.com on the OBi (SP2/ITSPB) and it registers and makes calls with no errors.

If your router has SIP ALG support, turn it off.

QBZappy

Brian,

I googled "479 error" and found a DDWRT and an Asterisk post making references to External and inernal IP address in the SIP header. DDWRT was a firmware issue, and a configuration issue in Asterisk. Both posts making references to error 479. You would need to do a sip trace to have a better understanding of this issue in your setup. This might be a good starting point.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

Brian

I am running syslogd with following options to trace:
syslogd.exe -nl -s all

I set the following options to do tracing:
Device Admin:
Server: IP of Obi device
Port: 514
Level: 7

SP2 Service:
X_SipDebugOption: Log All Messages

I do not see any messages in the logfile, other than "Syslogd is listening to port# 514:".  Is there anything else I need to set to enable trace?

RonR

Quote from: Brian on May 15, 2011, 10:07:51 AMDevice Admin:
Server: IP of Obi device

This needs to be the IP address of the PC where the Syslog Daemon is running.

Brian

It is working now.  Not sure what fixed it.  Thanks for your help.

Brian

Obihai sent a firmware patch to my device to deal with the 479 issue.  It looks like that is what fixed the problem.

RonR

Quote from: Brian on May 15, 2011, 01:56:30 PM
Obihai sent a firmware patch to my device to deal with the 479 issue.  It looks like that is what fixed the problem.

Are you talking about 1.2.1 (Build 2286)?

I verified yestereday that IdeaSIP was working fine with build 2283 and it had previously been working with 2103.

All's well that end's well, I guess.