January 27, 2020, 03:02:27 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Two PhonePower Problems: Latency & Call Setup Delay (solved)  (Read 20131 times)
johnmeyer
Newbie
*
Posts: 8


« on: May 05, 2014, 12:48:23 pm »

[/edit] For those who don't want to read all the way to the end, I solved the problems described in my OP below, and I now like the PhonePower call quality, and think their tech support is good.[/end edit]

I completely ditched Google Voice (I wasn't using it for anything other than a free VoiP provider for my Obi), and signed up for PhonePower. The signup was incredibly easy, but I have two issues with their service.

Latency

I had the caller say "one," and then I said "two," etc. The round-trip latency was somewhere around 1.5 seconds. This is much more than what I was experiencing with Google Voice.

Can this be reduced via ObiTalk settings?

Call Setup

There are actually two parts to this problem. The first is that it takes a long time before I hear ringtone when placing an outbound call. I have read responses to this problem that says that the ringtone isn't generated until the receiving phone actually starts ringing. To test this, I called my own (landline) number, and sure enough, the ringtone started when my landline phone started ringing.

However ...

It took THIRTEEN SECONDS from the time I pressed the last digit on the phone connected to my ObiTalk device until the landline started ringing. I have never seen anything like this with any system.

How can I fix this?

Thanks!
« Last Edit: May 06, 2014, 04:49:26 pm by johnmeyer » Logged
johnmeyer
Newbie
*
Posts: 8


« Reply #1 on: May 05, 2014, 02:18:57 pm »

Made some progress on the call setup issue. If I dial the full ten-digit number, the call setup is relatively normal. The problem only happens when I dial a local (same area code) number.

So, I need to change something in the way the call is routed, depending on the digits. Any idea what I need to change?
Logged
giqcass
Hero Member & Beta Tester
*****
Posts: 1436


« Reply #2 on: May 05, 2014, 02:44:57 pm »

You need to set up local dialing on the Obi to speed things up.
I'm just going to quote myself and a couple others from another thread.

Here is a couple examples with a brief explanation.  aaa = your local area code.
<1aaa>[2-9]xxxxxx|

If i see a number that starts with any number 2 through 9 "[2-9]" that is followed by any sequence of 6 numbers "xxxxxx" then add 1aaa to the beginning before dialing the call "<1aaa>".  The "|" means or.  We like to use "[2-9]" instead of another "x" because no US area codes starts with 1 with the exception of a fake area code used by certain cell phone companies for the purpose of SMS to email.  Those fake area codes can not be dialed.  The extra specificity of "[2-9]" allows seven digit numbers starting with 1 to be used for other purposes without conflict with 7 digit dialing.

You will notice a similar entry for 10 digit dialing
<1>[2-9]xxxxxxxxx|

And this is for international dialing. 011xx.   "xx." means we don't know how long the number will be.


The OBi has no control over what other people have to dial on their telephones to reach your number.  If you actually meant you can't dial out using 7 digits to make local calls, make this change:

Voice Services -> ITSP Profile A -> General -> DigitMap:

(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1aaa>[2-9]xxxxxx|011xx.|(Mipd)|[^*#]@@.'@'@@.)

where aaa is your local area code.


As explained in my review at http://michigantelephone.wordpress.com/2011/01/22/review-of-the-obihai-obi110-voip-device-part-1-use-your-phone-with-google-voice-for-free-incoming-and-outgoing-calls/ :

Quote
You might want to make one other tweak if you are used to dialing local numbers using just seven digits. By default, you will be able to dial U.S.A. and Canada numbers using 11 digits (1 + area code + number) or 10 digits.  If you’d prefer to be able to use 11 or 7 digits, in the left-side menu click on the + next to “Service Providers”, then when the menu expands click on “ITSP Profile A” (or “ITSP Profile B” if that’s where your Google Voice account is). Find the setting “DigitMap”, and uncheck the “Default” box next to it.  Somewhere near the front of the string, you will see this: |<1>[2-9]xxxxxxxxx| — change the part between the vertical bar characters to <1313>xxxxxxx (but substitute your area code for 313). Be careful not to remove or change either of the vertical bar characters that “bookend” the part you just changed.  Then click “Submit”, wait for the page to reload, and “Reboot”, and (after it reconnects with Google Voice) you should have the 7/11 digit dialing you are used to.

Hope that helps!

Perhaps someone can satisfy my curiosity here on why "1xxxxxxxxxx" is used instead of "1[2-9]xxxxxxxxx" which is more precise.
« Last Edit: May 05, 2014, 02:51:23 pm by giqcass » Logged

Long live our new ObiLords!
PeteMoss
Jr. Member
**
Posts: 29


« Reply #3 on: May 05, 2014, 02:51:57 pm »

I had the same problem and changed the dialing plan. Go to Set Up Wizard and select your ITSP (probably A) and change ITSP digitmap to:
(*xx|1xxxxxxxxxx|<1NPA>[2-9]xxxxxx|<1>[2-9]xxxxxxxxx|011xx.S3|(Mipd)|[^*]@@.)  
Note that NPA needs to be changed to your area code.

I do not know what your can do about latency. Phonepower has their main server in LA but there is suppose to be another one on the East Coast. You will have to go to PP support if you think you are not on the nearest server.
Logged
johnmeyer
Newbie
*
Posts: 8


« Reply #4 on: May 05, 2014, 05:56:36 pm »

Well, this looked promising, but it didn't work (edit: see my next post -- I got it to work). Here's a screen capture of the configuration page:



This is the complete, exact string entered on the DigitMap line (which is the only thing I changed):

(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1831>[2-9]xxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

831 is my area code. After I made the change, I "submitted" the change and re-booted the Obi. I verified that this string was still there after I returned to this page. However, I still got much, much shorter setup delays when I manually dialed all ten digits.

As for the latency delay when talking to someone, I spent about an hour on two different chats with PhonePower tech support, and did various tests, most of which I'd alread done, to determine my VOIP quality parameters using my AT&T Uverse Internet connection. I got pretty good numbers, all of which were in the "green" area. The PhonePower tech support guy was helpful, to a point, but he really didn't have any ideas about how to reduce the problem.

So, I guess I'll just have to dial eleven digits (including the "1") for local calls. I wish I didn't have to do this, but it doesn't look like the ObiTalk device parses those strings the way it is supposed to.
« Last Edit: May 05, 2014, 06:10:00 pm by johnmeyer » Logged
johnmeyer
Newbie
*
Posts: 8


« Reply #5 on: May 05, 2014, 06:05:27 pm »

OK, I got it to work. I put the area code append logic before the logic which appends "1" if the person dials a USA number without that prefix. The order appears to be important.
Logged
giqcass
Hero Member & Beta Tester
*****
Posts: 1436


« Reply #6 on: May 05, 2014, 06:12:43 pm »

I wish I had something useful for the Latency issue but I don't.  AFAIK: There is no setting on the Obi that can remedy that.  That is a Phonepower issue.
Logged

Long live our new ObiLords!
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5872



« Reply #7 on: May 05, 2014, 08:38:56 pm »

RE:  latency, I suggest running the VoIP quality test on this website.  It uses a Java applet, running on your computer, to accurately simulate a VoIP "conversation" between your computer (and hence, your own ISP) and some far-end server.  It's the only meaningful test of VoIP; the typical "speedtest" sites are useless for VoIP traffic testing.

http://myspeed.visualware.com/index.php

You need to score a 4.0 or better MOS (Mean Opinion Score, dating back to the days when actual human judges listened to and rated telephone call quaity) for reliable VoIP.  After running the test, you can examine the factors that go into the score, such as latency, dropped packets, etc.  If your MOS is >=4.0, then it's a PhonePower issue.  Frankly, there are so many ITSPs available, that if I were you, I'd dump them and find a better one.

If your score is bad, it's your ISP's issue.  It's very common for cable internet service to have high speed, while having high packet loss or latency, both of which will wreak havoc on VoIP.  It's like driving really fast down a dirt road.  You wouldn't notice it when watching streaming video, for example, because of buffering (or really good suspension on your vehicle).  You may need to get very agro with your cable company if this is happening, and demand that they come out and test it at your premises.
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
johnmeyer
Newbie
*
Posts: 8


« Reply #8 on: May 06, 2014, 04:44:50 pm »

Quote
I suggest running the VoIP quality test on this website ... http://myspeed.visualware.com/index.php

I ran the test at that site yesterday, and the PhonePower tech support (who were actually quite good) are still running additional tests and sending me the results. Bottom line is that my AT&T Uverse Internet service is producing very good test scores, with an MOS of 4.1, and very low latency.

One interesting thing is that today, perhaps because of phase of the moon or sunspots, the PhonePower latency is absolutely fine, and the call quality is outstanding. I'll have to use it for a few weeks to see if this good quality continues. I just got off a long support call with AT&T on an unrelated issue, and that call involved first talking to the rep on my landline, and then having him call me back on the VOIP PhonePower line. The PhonePower call quality was clearer, louder, and crisper than my landline, using the same handset (my calls go through my Panasonic 6x16 home PBX, so I use the same handset for everything). The latency was low enough that I did not notice it.

So, with fingers crossed, it looks like everything is now working, and at the moment, I am very happy with PhonePower, and their call quality is better than anything I ever experienced in two years of using Google Voice (GV) with my ObiTalk.
Logged
jlynnwatts
Newbie
*
Posts: 7


« Reply #9 on: May 06, 2014, 07:15:20 pm »

A question to johnmeyer:

Is this the final string that you used to get the numbers in your area code to dial quicker?
I put in my area code -  "530".

(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1530>[2-9]xxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

Thanks.

JWatts
Logged
zorlac
Full Member
***
Posts: 241



« Reply #10 on: May 06, 2014, 07:48:27 pm »

OK, I got it to work. I put the area code append logic before the logic which appends "1" if the person dials a USA number without that prefix. The order appears to be important.
From
(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1831>[2-9]xxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

To ? ? ?
Thanks
Logged
johnmeyer
Newbie
*
Posts: 8


« Reply #11 on: May 07, 2014, 11:16:27 am »

A question to johnmeyer:

Is this the final string that you used to get the numbers in your area code to dial quicker?
I put in my area code -  "530".

(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1530>[2-9]xxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

No, that is not the string. Instead, this is the string I am using. I just now copied/pasted it directly from the ObiTalk "Expert" dashboard:

(1xxxxxxxxxx|<1831>[2-9]xxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

As I noted above, it didn't seem to work correctly until I moved the seven digit rule prior to the "append 1 if only ten digits are used" rule. Replace "831" in my string above with your "530" area code.

John Meyer
Logged
Shale
Hero Member
*****
Posts: 1061


« Reply #12 on: May 07, 2014, 11:44:52 am »

If you are looking for speed, I suggest you get rid of the xx. item.
Logged
PeteMoss
Jr. Member
**
Posts: 29


« Reply #13 on: June 11, 2014, 12:47:21 pm »

A question to johnmeyer:

Is this the final string that you used to get the numbers in your area code to dial quicker?
I put in my area code -  "530".

(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1530>[2-9]xxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

No, that is not the string. Instead, this is the string I am using. I just now copied/pasted it directly from the ObiTalk "Expert" dashboard:

(1xxxxxxxxxx|<1831>[2-9]xxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

As I noted above, it didn't seem to work correctly until I moved the seven digit rule prior to the "append 1 if only ten digits are used" rule. Replace "831" in my string above with your "530" area code.

John Meyer

Without the *xx rule, how do you check your voice mail using *21?
Logged
GH-UpNorth
Newbie
*
Posts: 10


« Reply #14 on: July 07, 2014, 10:01:08 am »

I was going to modify my PhonePower DigitMap entry as described in the johnmeyer posting, but found that my entry was much like it with two exceptions ( which I don't understand ).  I thought someone might have some explanation of the difference between the recommended digitmap setting and mine ...

johnmeyer recommended :
(1xxxxxxxxxx|<1831>[2-9]xxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

Mine :
(*xx|1xxxxxxxxxx|<1231>[2-9]xxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*]@@.)

Note that mine has and extra  *xx| at the beginning, and johnmeyer's recommended one has the hashtag symbol  #  which is not present in mine.  Can anyone give me some explanation or tips about these two differences ? 

Thanks
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC