December 18, 2017, 02:29:41 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 2 [3] 4
  Print  
Author Topic: Google Voice back as Approved Service Provider!?  (Read 135372 times)
Ostracus
Hero Member
*****
Posts: 581


« Reply #40 on: September 11, 2014, 07:51:15 pm »

For your own security, and to ensure uninterrupted operation of GV on your OBi, if you haven't already done so, delete the old GV SP configuration(s), log into the associated GV account on your computer's web browser, open another tab, go to the OBiTALK portal, and re-configure GV using OAUTH authentication.  It will download the necessary firmware as needed.  There is no benefit to maintaining the old setup.

Actually Obihai's made the process even smoother than that.
Logged
mo832
Full Member
***
Posts: 217


« Reply #41 on: September 11, 2014, 09:59:21 pm »



For your own security, and to ensure uninterrupted operation of GV on your OBi, if you haven't already done so, delete the old GV SP configuration(s), log into the associated GV account on your computer's web browser, open another tab, go to the OBiTALK portal, and re-configure GV using OAUTH authentication.  It will download the necessary firmware as needed.  There is no benefit to maintaining the old setup.

Steve-

Please see my post #26 on P. 2 of this thread.

And thanks for all your help and insight going back to the beginning of the XMPP cutoff announcement, up to and including right now...
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3977



« Reply #42 on: September 11, 2014, 10:02:47 pm »

RE:  http://www.obitalk.com/forum/index.php?topic=8443.msg56361#msg56361

Yes, the "application password" you are using is still just the same old "give Obihai my user name and password" method that Google told everyone to stop doing.  You should follow the instructions to delete and re-add your GV service provider slot, which will upgrade it to the new access token exchange technology.
Logged

lezleeann
Newbie
*
Posts: 3


« Reply #43 on: September 12, 2014, 08:06:52 am »

I am having trouble getting Google Voice working on SP2.  I have Vestalink setup and working fine on SP1.  My Google Voice on SP2 keeps saying configuring after going through the setup as directed.  I do have 2-step verification turned on for the Google account I am using for this.  Would that cause it not to work?  
Obihai's old instructions for this scenario say to do the following:
If you have enabled Google 2-step verification for Gmail, please follow the following instructions so that you will be able to use your OBi and Google Voice.
Sign in to your Google account settings.
Select the, Authorizing applications & sites link.
Create an application specific password for Google Voice.
Use this password when you configure Google Voice as a service on your OBi device.
However, Obi has now changed the process and I have no way to use an application specific password once I generate one in my Google account.  
Any ideas?
Logged
gderf
Sr. Member
****
Posts: 490



« Reply #44 on: September 12, 2014, 08:56:08 am »

Disable 2 step verification at Google and try again.
Logged

Help me OBiHai PhoneOBi. You’re my only hope.
lezleeann
Newbie
*
Posts: 3


« Reply #45 on: September 12, 2014, 09:11:26 am »

I am not disabling 2-step. That's what keeps my Google account secure. Have you confirmed that Obi will no longer work with Google Voice for people using 2-step security?  If so, I won't be using it.  They previously supported it so I am hoping there is way now also.
Logged
BigJim_McD
Full Member
***
Posts: 190



« Reply #46 on: September 12, 2014, 09:35:57 am »

I have two Google Voice accounts each with it's own phone number.  Both of the accounts are setup to use 2-Step security.  I did not have to make any changes in how I use 2-Step security on my gmail accounts associated with my Google Voice phone numbers.

After the changes in the way OBi devices configure, we no longer have to use a password during the procedure when adding or reconfiguring a Google Voice account onto a Service Provider port {sp1, sp2, sp3 or sp4}.  If you have more than one Google (email) account, logout of your google account, then log back in with the Google account associated with the Google Voice phone number that you want to add or update.  Then access OBiTalk, select or add your OBi device.  Select the "SP" port that you want to configure.  Select the options you want, then "Save" the configuration and you will be prompted to select your Google account.

SteveInWA has posted some of the best information on how to configure (or recondigure) Google Voice on OBi devices after the recent changes on OBiTalk to improve security. 

See:  SteveInWA  -  OBi Phone Beta Tester
*****  Re: Google Voice Manual Config
« Reply #9 on: August 20, 2014, 05:15:02 pm »


http://www.obitalk.com/forum/index.php?topic=8456.0
Logged

BigJimMcD
Wilbour
Jr. Member
**
Posts: 53


« Reply #47 on: September 12, 2014, 09:42:23 am »

am I the only one whose device shows offline

it works with my Voip.ms but I cannot reconfigure now
Logged
Mark937
Newbie
*
Posts: 2


« Reply #48 on: September 12, 2014, 09:58:27 am »

I have an OBi100 that was configured for use with Google Voice back in January, and continued to work even after May 15th.

After reading the announcement regarding Google Voice, I found this very informative thread regarding the change in authentication protocols.

I decided to take the advice of those who suggested deleting the "old" GV setup, and then adding it back again to use the new, more secure GV authentication method.

I logged into GV, then opened another browser tab and logged into OBiTalk. From the dashboard for my device, I deleted GV from SP1, then clicked the button "Google Voice Setup". That brought up a dialog box saying that "This device needs to be upgraded to continue. Click OK to upgrade device, or CANCEL to go back". I clicked OK, which brought me to another page "Update in progress...". After about 90 seconds, I was returned to the dashboard with an error message at the top, "Failed to update device 123456789. Please try again later.", and no GV in SP1.

I've checked the OBi100 directly through it's web admin page, and it shows the software version as 1.3.0, Build 2824, which is the most current version I see listed on the website.

Dose anyone know what's going on, and how I can get GV back?  Thanks.
Logged
Taoman
Hero Member
*****
Posts: 945


« Reply #49 on: September 12, 2014, 10:43:26 am »


Dose anyone know what's going on, and how I can get GV back?  Thanks.

It sounds like the automatic firmware upgrade did not complete on your OBi. Seems to be happening for a lot of people with 1xx series OBi devices.
Here is one thing you could try although you do so at your own risk.

Download the update to your computer from here:
http://fw.obihai.com/OBi110-1-3-0-2872.fw
Install the firmware manually from the web interface directly on your OBi under System Management>Device Update
If that is successful, log into the Google account associated with the GV number you wish to use
In another browser tab, login to Obitalk and try adding Google Voice back to SP1

Note: I just downloaded version 2872 and upgraded my OBi110 manually without any issues. However, I don't have Google Voice configured on that device and have no plans to so I can't say if that part would be successful but it was a breeze on my OBi200.
Logged
Mark937
Newbie
*
Posts: 2


« Reply #50 on: September 12, 2014, 11:21:14 am »

Thank you, Taoman, that did the trick.

After repeatedly removing and re-adding the device, doing factory resets, reconfiguring for GV, etc., it was manually updating the firmware that finally got it working.

Thanks!
Logged
Taoman
Hero Member
*****
Posts: 945


« Reply #51 on: September 12, 2014, 11:51:03 am »


After repeatedly removing and re-adding the device, doing factory resets, reconfiguring for GV, etc., it was manually updating the firmware that finally got it working.

Let's just call it all a great "learning experience," shall we?   Courtesy of your friend and mine, Obihai. Wink
Logged
cluckercreek
Full Member
***
Posts: 153


« Reply #52 on: September 12, 2014, 01:56:35 pm »

I can't update my Obi 110 beyond 2868. I have deleted GV on SP1 and factory reset several times. It will not take the 2872 update. It is working so I guess I'll just leave it be.
Logged
Crow550
Full Member
***
Posts: 111


« Reply #53 on: September 12, 2014, 03:09:21 pm »

Do you still need the Google Talk option under Phones in the Google Voice settings or can you remove it now?

Anyone test this?
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3977



« Reply #54 on: September 12, 2014, 05:17:49 pm »

I have two Google Voice accounts each with it's own phone number.  Both of the accounts are setup to use 2-Step security.  I did not have to make any changes in how I use 2-Step security on my gmail accounts associated with my Google Voice phone numbers.

After the changes in the way OBi devices configure, we no longer have to use a password during the procedure when adding or reconfiguring a Google Voice account onto a Service Provider port {sp1, sp2, sp3 or sp4}.  If you have more than one Google (email) account, logout of your google account, then log back in with the Google account associated with the Google Voice phone number that you want to add or update.  Then access OBiTalk, select or add your OBi device.  Select the "SP" port that you want to configure.  Select the options you want, then "Save" the configuration and you will be prompted to select your Google account.

SteveInWA has posted some of the best information on how to configure (or recondigure) Google Voice on OBi devices after the recent changes on OBiTalk to improve security. 

See:  SteveInWA  -  OBi Phone Beta Tester
*****  Re: Google Voice Manual Config
« Reply #9 on: August 20, 2014, 05:15:02 pm »


http://www.obitalk.com/forum/index.php?topic=8456.0


I've written several reply posts that are unfortunately peanut-buttered around the forum, and I'm too lazy to keep track of them   Roll Eyes

So, here is a link to what I'd consider the most thorough set of instructions.  If anyone has a question or finds an error, please let me know.

http://www.obitalk.com/forum/index.php?topic=8560.msg56460#msg56460
Logged

SteveInWA
Hero Member & Beta Tester
*****
Posts: 3977



« Reply #55 on: September 12, 2014, 07:00:41 pm »

I am having trouble getting Google Voice working on SP2.  I have Vestalink setup and working fine on SP1.  My Google Voice on SP2 keeps saying configuring after going through the setup as directed.  I do have 2-step verification turned on for the Google account I am using for this.  Would that cause it not to work?  
Obihai's old instructions for this scenario say to do the following:
If you have enabled Google 2-step verification for Gmail, please follow the following instructions so that you will be able to use your OBi and Google Voice.
Sign in to your Google account settings.
Select the, Authorizing applications & sites link.
Create an application specific password for Google Voice.
Use this password when you configure Google Voice as a service on your OBi device.
However, Obi has now changed the process and I have no way to use an application specific password once I generate one in my Google account.  
Any ideas?

This is the one scenario that nobody has yet gone through in detail.  I believe that the "approved service provider" method of setting up Vestalink (or Anveo or PhonePower) locks down some aspects of the OBi's configuration.  I suggest opening a ticket with Obihai to get the "official" answer and help from them in understanding their recommended way of "peacefully coexisting" with a managed configuration of Vestalink.  The alternative is to configure Vestalink manually, but I suggest starting with Obihai support.

RE:  two-step verification, you do NOT need to disable it, and whether or not you are using it is unrelated to any issue with the OBi GV setup.  Under the new GV setup process, you independently log onto your GV account by yourself, in one open tab on your web browser, using your GV user name, password, and if applicable, your two-step verification method.  You then log into the OBiTALK portal in another browser tab of the same browser, and configure your OBi for GV.  The configuration process will "see" your logged on Google session, and ask it permission to access your Google account in the future.  You'll see a pop-up window on your Google account asking for you to permit this.  Once you do so, Obihai and Google exchange secure "access tokens", and there will be no future need for the OBi to know your password at all.
« Last Edit: September 15, 2014, 06:51:27 pm by SteveInWA » Logged

Spidey
Newbie
*
Posts: 9


« Reply #56 on: September 13, 2014, 07:52:04 am »

@SteveinWA, thanks for all of the information and an honest 3rd party prospective on GoogleVoice, XMPP and Obihai. I had boxed up my Obihai-202 some time ago until I received an e-mail this week from Obihai indicating that GoogleVoice was supported again in Obihai products. So I fired up the device and configured it for my GV account. It's working great! For now anyway! Smiley
Logged
Crow550
Full Member
***
Posts: 111


« Reply #57 on: September 14, 2014, 01:53:02 am »

Do you still need the Google Talk option under Phones in the Google Voice settings or can you remove it now?

Anyone test this?

Appears this is still needed:

So now that Google has officially supported the Obi Devices and Voice is slowly merging to Hangouts....

In order to use G-Voice with an Obi you need to have Google Chat under your Forwarding Phones. (If you removed it you have to go into Gmail and select old chat if you're using Hangouts and click the Phone icon and it will re-appear in your Forwarding Phones. No plugins needed, just open the Google Chat Dialer to have it re-added.)

So I think they should rename it Google Hangouts and not Google Talk under Forwarding Phones and remove the option to remove it. Or name it Hangouts for Calling Devices....

Also on a another yet similar topic using the Google Voice Chrome extension when clicking a number to dial there is no Hangouts option (even though you can pick a number at the Google Voice site and select it to dial through Hangouts) and Google Talk does nothing.... (Well it will ring your Obi Device.)

I assume the Google Voice Chrome Extension will be phased out and that functionally be added to Hangouts too. Needs an option to select one of the Forwarding Numbers or VOIP line (Hangouts/ Obi Device).

Course instead of merging and removing the Google Voice extension and site. I hope they keep them and just copy the functionally to Hangouts and have the Google Voice and Hangouts site and extensions sync with each other.

So those who enjoy Google Voice and not Hangouts can still enjoy it and those who love Hangouts can use all the Google Voice stuff within it. Wink

Like some businesses that are using Google Voice may not need what Hangouts offers.

Just some kinks that need to be worked out....
Logged
lezleeann
Newbie
*
Posts: 3


« Reply #58 on: September 15, 2014, 08:12:53 am »

I am having trouble getting Google Voice working on SP2.  I have Vestalink setup and working fine on SP1.  My Google Voice on SP2 keeps saying configuring after going through the setup as directed.  I do have 2-step verification turned on for the Google account I am using for this.  Would that cause it not to work?  
Obihai's old instructions for this scenario say to do the following:
If you have enabled Google 2-step verification for Gmail, please follow the following instructions so that you will be able to use your OBi and Google Voice.
Sign in to your Google account settings.
Select the, Authorizing applications & sites link.
Create an application specific password for Google Voice.
Use this password when you configure Google Voice as a service on your OBi device.
However, Obi has now changed the process and I have no way to use an application specific password once I generate one in my Google account.  
Any ideas?

This is the one scenario that nobody has yet gone through in detail.  I believe that the "approved service provider" method of setting up Vestalink (or Anveo or PhonePower) locks down some aspects of the OBi's configuration.  I suggest opening a ticket with Obihai to get the "official" answer and help from them in understanding their recommended way of "peacefully coexisting" with a managed configuration of Vestalink.  The alternative is to configure Vestalink manually, but I suggest starting with Obihai support.

RE:  two-step verification, you do NOT need to disable it, and whether or not you are using it is unrelated to any issue with the OBi GV setup.  Under the new GV setup process, you independently log onto your GV account by yourself, in one open tab on your web browser, using your GV user name, password, and if applicable, your two-step verification method.  You then log into the OBiTALK portal in another browser tab of the same browser, and configure your OBi for GV.  The configuration process will "see" your logged on Google session, and ask it permission to access your Google account in the future.  You'll see a pop-up window on your Google account asking for you to permit this.  Once you do so, Obihai and Google exchange secure "access tokens", and there will be no future need for the OBi to know your user name or password at all.

I got it working by deleting my Obi100 from my dashboard, doing a reset on the Obi, then re-adding it to my dashboard and then going through Obi's process of adding Google Voice to SP1.  Then for Vestalink, I added it to SP2 manually.  Even though Vestalink doesn't recommend this method, I won't be renewing with them anyway now that Google Voice is officially back.  Thanks for all the help detailing how to get it working! These forums are a fantastic.
Logged
dfresh
Newbie
*
Posts: 4


« Reply #59 on: September 15, 2014, 09:20:41 am »

I updated to the new Google Voice authorization and setup, failed to update over wifi on my 202 several times but finally  went through. Setup was way easier and smooth.
HOWEVER! Since about March or April, any direct Google Voice incoming call to my Obi202 rings about three short double rings  and the rings sound weak and  interrupted each time. Goes to voicemail too fast.
The very best way to stop this was to forward GV to free IPComms DID which rings iIMMEDIATELY and strong long ring 4 or  5  times before voicemail.
I thought the update and new "approved GV" would let me eliminate the IPComms but it is the same. I also have free DID's from  Callcentric,  ipKall and Anveo but IPComms gives quickest and longest rings and time to get to phone before voicemail.
I have Anveo setup for 911.
OH!!! I have GV at this time on sp2. It did same  feeble rings and quick voicemail on sp1. The IpComms DID is Detroit and I am in Oklahoma City
Google Voice was perfect the whole year or so of the original setup  on its own. It is a good setup now but I have heard IPComms free DID comes and goes so I was a litte concerned to get GV standalone wih my 202 again?Huh?!!!!
« Last Edit: September 15, 2014, 09:24:27 am by dfresh » Logged
Pages: 1 2 [3] 4
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC