September 18, 2020, 09:19:48 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Set up IdeaSIP as SP2  (Read 4773 times)
Brian
Newbie
*
Posts: 5


« on: May 14, 2011, 02:18:23 pm »

I am trying to set up IdeaSIP as SP2 (Google voice is SP1).  I used the following settings in ObiTalk:
Generic Service Provider Settings:
Configuration Name: Ideasip
Service Provider Proxy Server: proxy.ideasip.com
Service Provider Proxy Server port: 5060
Outbound Proxy Server: proxy.ideasip.com
Outbound Proxy Server port: 5060
Username: 1101xxxxxxx
Password: xxxxxxxx

In addition, I set the following using OBI Expert:
ITSP Profile B General:
STUNEnable: checked
STUNServer: stun.ideasip.com
X_STUNServerPort: 3478
X_ICEENable: checked

However, I see the following error for SP2 when I do that:
Register Failed: 479 (server=208.97.25.11:5060; retrying)

I contacted Obi support, but they did not know what 479 error code means.

Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #1 on: May 14, 2011, 02:41:27 pm »

IdeaSIP works fine here.

Leave ITSPB -> General -> X_ICEEnable unchecked.

Leave ITSPB -> SIP -> OutboundProxy blank.

Make sure SP2 -> X_ServProvProfile is set to B.
Logged
Brian
Newbie
*
Posts: 5


« Reply #2 on: May 14, 2011, 07:44:25 pm »

Still doesn't work.  I believe it is due to STUN settings.  I got this to work in softphone.  I disabled STUN server in softphone, then I was able to see the same error (479: private IP address not allowed).
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #3 on: May 14, 2011, 07:56:46 pm »

I'm using stun.ideasip.com on the OBi (SP2/ITSPB) and it registers and makes calls with no errors.

If your router has SIP ALG support, turn it off.
« Last Edit: May 14, 2011, 08:27:02 pm by RonR » Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2317



« Reply #4 on: May 14, 2011, 09:23:54 pm »

Brian,

I googled "479 error" and found a DDWRT and an Asterisk post making references to External and inernal IP address in the SIP header. DDWRT was a firmware issue, and a configuration issue in Asterisk. Both posts making references to error 479. You would need to do a sip trace to have a better understanding of this issue in your setup. This might be a good starting point.
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
Brian
Newbie
*
Posts: 5


« Reply #5 on: May 15, 2011, 10:07:51 am »

I am running syslogd with following options to trace:
syslogd.exe -nl -s all

I set the following options to do tracing:
Device Admin:
Server: IP of Obi device
Port: 514
Level: 7

SP2 Service:
X_SipDebugOption: Log All Messages

I do not see any messages in the logfile, other than "Syslogd is listening to port# 514:".  Is there anything else I need to set to enable trace?
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #6 on: May 15, 2011, 10:17:52 am »

Device Admin:
Server: IP of Obi device

This needs to be the IP address of the PC where the Syslog Daemon is running.
Logged
Brian
Newbie
*
Posts: 5


« Reply #7 on: May 15, 2011, 12:15:51 pm »

It is working now.  Not sure what fixed it.  Thanks for your help.
Logged
Brian
Newbie
*
Posts: 5


« Reply #8 on: May 15, 2011, 01:56:30 pm »

Obihai sent a firmware patch to my device to deal with the 479 issue.  It looks like that is what fixed the problem.
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #9 on: May 15, 2011, 01:59:55 pm »

Obihai sent a firmware patch to my device to deal with the 479 issue.  It looks like that is what fixed the problem.

Are you talking about 1.2.1 (Build 2286)?

I verified yestereday that IdeaSIP was working fine with build 2283 and it had previously been working with 2103.

All's well that end's well, I guess.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement