OBI 100 -> OBI 200, now caller ID displays "Out of Area"

Started by dhobi, October 27, 2014, 02:08:18 PM

Previous topic - Next topic

dhobi

I recently upgraded my old an trusted OBI100 to an OBI200 because I needed one more SP. Everything else is the same, same GV service, same Panasonic phone. With the OBI100 I've never seen "Out of Area" on its caller ID, but now with the OBI200 that's what I see all the time for the name. Unfortunately I don't recall whether the name field before was blank on the phone CID display or it was just the incoming phone number.

Any ideas what happened? Is the firmware in the OBI200 behaving differently than the OBI100 in what it sends to the phone for caller ID?

Rather than sending a blank field or "Out of Area" for the name, could the OBI instead just copy the phone number and put it in the name field of CID? On my phone the name displays in a large font while the phone number is in a small font, see Out of Area in a large font is not useful and distracting when you try to see the actual phone number.

SteveInWA

You didn't mention if you are using Google Voice directly on your OBi (forwarding calls to the OBi via Google Chat) or if you are forwarding the calls from Google Voice to some SIP ITSP (like Anveo, Callcentric, PhonePower, voip.ms, Vestalink, etc.)?  Note that, when everything is working properly, GV will send only the caller ID number, and nothing in the caller ID name (CNAM) field.  Your Panasonic phone should display the calling number.

All bets are off for SIP ITSPs -- each one may handle the forwarded CID and CNAM differently.

Press ***1 on your Panasonic phone's keypad to hear your OBi's IP address.  Access that address from a web browser, to view the OBi's local web page.  Look under Status, for Call History.  It will show you what the OBi is receiving as caller ID from your various service providers.  That should then give you an idea as to where the problem is located.

dhobi

GV straight to the OBI200, on SP1. Sorry for leaving out the detail.
I looked at the history and I see something like this:
From GT1(191...)
(I put the ... but the digits are correct for the incoming number)

It was the same on the OBI100 but I think it used to say SP1 instead of GT1 -- is this a change in the OBI200 or did I configure something wrong that I ended up with GT1? What does it stand for anyway?

I guess my question is whether something has changed between the OBI100 and the OBI200 with respect to the CNAM, maybe the OBI100 used to send a blank CNAM to my Panasonic phone but the OBI200 is sending something else or literally "Out of area" if the CNAM is blank?

SteveInWA

No, the two devices handle GV the same way.  You've hosed up your configuration somehow.  GV doesn't send "Out of Area".  Forget about the Panasonic phone for the moment.  Do you see those words on the OBi's call history page?  Again, what you see there, is what the OBi gets from Google Voice, unless you are otherwise manipulating the settings.

I am going to guess that you fiddled around with some settings on the local interface, or otherwise changed settings from default to something incorrect.

If you want to troubleshoot this, the best way to start off is with a clean slate.  I'd log on to the OBiTALK portal, delete your 200, factory reset the device, and add it back in.  Then, use the portal to add GV service pack to SP1, don't change anything else, and run some tests.

dhobi

I don't use the portal, I've always configured it directly in the local interface. Maybe my fear is not justified, but I don't like "the cloud" to have access to my LAN devices.
But as a temporary test, I could reset it to the defaults and let the portal configure it and try it. Then write down the changes it made.

No, the history does not show those words, I guess that's what my Panasonic phone displays if it doesn't get a CNAM.

SteveInWA

You now need to use the OBiTALK portal to properly configure OBi devices to work with GV, using the secure access token method for authenticating to your Google account.  You can revert back to the local interface after you do that.

http://www.obitalk.com/forum/index.php?topic=8560.msg56460#msg56460


dhobi

Quote from: SteveInWA on October 27, 2014, 07:58:02 PM
You now need to use the OBiTALK portal to properly configure OBi devices to work with GV, using the secure access token method for authenticating to your Google account.  You can revert back to the local interface after you do that.

http://www.obitalk.com/forum/index.php?topic=8560.msg56460#msg56460


Really? I didn't do anything special, I was able to configure GV just fine via the local interface using my GV account username/password. Everything works, I can make and receive calls via GV just like before using my OBI100. It's just this little quirk, a slightly different behavior in CID than with the OBI100.

dhobi

What exactly is GT1? I've never seen it in the OBI100 and I've seen some mentions that it is an undocumented trunk name? Is my OBI200 configured correctly as it shows incoming GV calls coming to GT1, I'm pretty sure it used to say SP1 with the OBI100. Thanks.

azrobert

I'm getting the same results.
My OBi200 is at Build 4420.
My OBi110 is at Build 2824.
I have a Panasonic phone.

Inbound calls from GV on the OBi200 shows "Out of area".
Inbound calls from GV on the OBi110 shows "1-800-555-1212".

I used the same Panasonic phone with both calls.
---------------------------------------------------------------------

GT1 signifies GoogleVoice.
The "T" might mean "Trunk".

The OBi110 shows "GoogleVoice1".

dhobi

Quote from: azrobert on October 28, 2014, 04:59:36 PM
I'm getting the same results.
My OBi200 is at Build 4420.
My OBi110 is at Build 2824.
I have a Panasonic phone.

Inbound calls from GV on the OBi200 shows "Out of area".
Inbound calls from GV on the OBi110 shows "1-800-555-1212".

I used the same Panasonic phone with both calls.
---------------------------------------------------------------------

GT1 signifies GoogleVoice.
The "T" might mean "Trunk".

The OBi110 shows "GoogleVoice1".


Bummer. I may have to go back to the OBI100, this CID change is annoying, showing everything as "Out of area" is not useful at all.

There's a build 4350 for the OBI200 but it won't fix anything wrt CID.

I hope someone at Obihai is reading this thread.

SteveInWA

Call some other number, not GV, directly using a telephone service provide that has caller ID, from the same calling phone number.  Is the called number's caller ID displayed correctly?

If so, you've probably got some issue caused by your locally-made configuration changes.  It does work as expected when you factory-reset the OBi device and properly set it up via the OBiTALK portal.

To prove this, I just reset a OBi 200 and then I added it from scratch as a new device onto my OBiTALK portal account.  I then configured Google Voice as the only service provider, using the new OAUTH authentication procedure.  It correctly makes and receives calls, and they all show the correct caller ID as sent by the carrier.

"GT1" = the old name for Google Talk/Chat.  It's simply the old terminology, as OBi's still use the Chat/Talk XMPP protocol for call signaling.

See the attached screenshot for evidence (well, I did black out my phone numbers, but their caller IDs were valid):


SteveInWA

Note that you must also be using a properly-configured and fully-working GV account, that shows the exact two words "Your number" as shown in my screenshot below, and not "Access number" or "Get a Voice number".

dhobi

Well, that's exactly what I see too on mine, GT1 followed by correct digits. They also show up on my phone, but for CNAM I get "Out of area". It didn't use to be the case before with the OBI100. It's not an issue with the configuration, I think I'd have bigger problems such as not being able to make or receive calls.

Also, see azrobert's post above, he's seeing the same thing, so I'm not alone.

azrobert

Steve,

My call history looks exactly like yours in my OBi200.

The following is the behavior of the phone when looking at the received calls in the phone's memory:
The entry from the GV inbound call on the OBi200
It alternately displays "Out of area" and the CallerID

The entry from the GV inbound call on the OBi110
It's a constant display of the CallerID

When the call originally came in on the OBi200 I don't think the CallerID was displayed, but I'm not sure. I will test it again tomorrow.

The OBI200 call history looks like this when the cname is included:
From 'Caller Name' SP3(480314xxxx)


dhobi

Quote from: azrobert on October 28, 2014, 08:59:45 PM
Steve,

My call history looks exactly like yours in my OBi200.

The following is the behavior of the phone when looking at the received calls in the phone's memory:
The entry from the GV inbound call on the OBi200
It alternately displays "Out of area" and the CallerID

The entry from the GV inbound call on the OBi110
It's a constant display of the CallerID

When the call originally came in on the OBi200 I don't think the CallerID was displayed, but I'm not sure. I will test it again tomorrow.

The OBI200 call history looks like this when the cname is included:
From 'Caller Name' SP3(480314xxxx)



Exactly the same behavior here too. Not sure whether it's a regression or an enhancement, but I'd much rather have the behavior from the OBI100, much more useful given that GV never sends CNAM.

SteveInWA

Dhobi:  the behavior you are seeing is generated by the Panasonic phone.  There's no way to change it.

Robert, I believe my tests agree with yours, if I understand your posts correctly.  I was fooled by your first post using the bogus number 555-1212; I thought you meant it literally displayed THAT number!  :-*

I Configured a 110 with GV via the portal.  The 110 was connected to a Panasonic DECT 6.0 cordless phone.

Called the GV number from a cell phone, unknown to the Panasonic phone's internal phone book.  Phone displayed the caller ID number in large characters, which it does when there is no CNAM to display (so, Working As Designed).

Configured a Callcentric DID on SP2.  Called that number from the cell phone.  Panny displayed "Cell Phone WA" CNAM (as sent by Callcentric) and the numeric CID (so, again, WAD).

Deleted the 110 off my portal, and added a OBi 200 fresh.  Configured GV on SP1 and CC on SP2, and plugged in the Panny phone.  Made the same two calls.

Called the GV number from the cell phone, again, unknown to the Panny's internal phone book.  The Panny's LCD shows a CNAM of "Out of Area", and the correct numeric CID.  But, see my screenshot below.  Note that the OBi is not receiving "Out of Area" CNAM from GV; it is receiving nothing.

Called the CC number, and it displayed CNAM and CID as expected.

In any case, my particular Panny phone didn't have a problem displaying the numeric CID, even when the CNAM was either blank or "Out of Area".

As a final test, I replaced the Panny phone with a Uniden phone.  When calling the GV number, the Uniden phone displays "Unknown Name".

These are canned response phrases generated by the telephone's caller ID circuitry; they're not being sent by GV or by the OBi.

Other brands of CID units or phones with CID/CNAM may display some other arbitrary canned phrase,or display nothing...it's not consistent.  There's no standard for this.

Remember, the ATA (the 110 or 200) receives whatever CNAM string is sent (or, in the case of GV, not sent) digitally from the service provider.  It then locally generates the CNAM and CID, and then sends it out over the analog telephone line (Phone port) between ring 1 and 2 using Bell 202 FSK modulation, based on how it interprets and translates that digital data from the service provider.  Apparently, the 110 is sending some different indication of no CNAM to the phone, vs the 200, but this is entirely due to the OBi's firmware.  Perhaps the 110 was programmed to send a blank space or some other undisplayable character for GV CNAM, to suppress the canned messages, and the 200 conforms to the standard instead.

dhobi

Steve - thank you very much for your thorough tests. So we agree on the behavior. I have no problem with the CID digits making it to the Panasonic phone, they make it OK. The problem is how OBI200 changed from what OBI100 used to do when the CNAM is not available (which is the case all the time with GV). I wish OBI had an option to say "Copy CID digits to CNAM when CNAM is not available". This way phones would always display something for the name rather than the useless Out of Area or Unknown Caller. They usually display CNAM in a big font and the CID digits below it in a small font. Looking at that Out of Area all the time is not useful at all, you have to train your eyes and brain to ignore it and look at the small digits below it.

azrobert

Steve said:
QuoteApparently, the 110 is sending some different indication of no CNAM to the phone, vs the 200, but this is entirely due to the OBi's firmware.  Perhaps the 110 was programmed to send a blank space or some other undisplayable character for GV CNAM, to suppress the canned messages, and the 200 conforms to the standard instead.

I think you are exactly correct. This has nothing to do with GV. I tested with the Phonerlite softphone and an old corded phone. I can set the cname to blank in Phonerlite and I think the corded phone displays exactly what is sent as cname. When the corded phone is connected to the OBi200 the phone displays "No Name" indicating a blank cname. When connected to the OBi110 it displays 14 dashes. Apparently the Panasonic will display "Out of area" when the cname is blank. Maybe the corded phone displays dashes when the cname is not displayable and the Panasonic displays CallerId.

Tomorrow I will try to duplicate the OBi110 behavior on the OBi200 by sending a cname containing 14 dashes.

SteveInWA

The 110 is probably substituting either ASCII blanks or some ASCII character that isn't visible.  It's a moot point, since it can't be altered by the OBi user.  IMO, the 200 is actually behaving technically correctly, though not as you wish.  Whether the CID client (telephone, standalone CID unit, or some software client) displays a canned message, dashes, "Out of Area", "Area 51", or plays the Elvis tune "Return to Sender; Address unknown" is entirely up to that client, when it receives no CNAM.  Obhai would have to make a firmware change to alter this minor inconvenience.

Incidentally, the now-defunct-in-the-USA SIP ITSP Sipgate used to do what you wish, and send the numeric CID as the CNAM for EVERY call, since they didn't pay for CNAM service.  I found it annoying, but to each his/her own.  I'm glad GV doesn't do that.

If it's really bothering you, then submit a feature request post.  Hell, ask them to send CNAM "Call from GV".   :P

dhobi

Quote from: SteveInWA on October 28, 2014, 11:25:59 PM
If it's really bothering you, then submit a feature request post.  Hell, ask them to send CNAM "Call from GV".   :P

That would not really help. I don't care what the text is, if it's some static string, it's useless. The only reasonable thing to do would be to copy the CID digits to CNAM for GV, perhaps add an option for it in the UI. Then I can at least see a number that I may recognize or an area code that I don't know and would want to ignore, without squinting my eyes to dechiper the digits below the useless "Out of Area" big text.