November 29, 2020, 12:18:27 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: using OBI200 with Goggle Voice in ITALY  (Read 40008 times)
andreabix
Newbie
*
Posts: 4


« on: November 08, 2014, 06:57:23 am »

Hi,
I have successfully configured my OBI200 with my italian Goggle Account. I can only make outgoing calls with google voice because it's a non-US account (cannot get an US number).

I would like to use my OBI200 with Google Voice to call italian phone numbers (google rates are lower than local VoIP rates...), BUT the point is that with OBI200 I must dial the full number, INCLUDING ITALY's COUNTRY CODE. For example, if I want to call the italian number 0650542977 I have to dial 00390650542977 (0039 is for ITALY).
That is very annoying!!...

Please note that, instead, if I use Google Voice from Hangout on my Android mobile, I do not need to add the Italian prefix 0039 (so, it assumes that phone numbers not starting with 00 or + are for Italy).

Can I do the same with OBI200?
Can OBI200 add automatically 0039 to all outgoing (SP1) calls not starting with 00 or +?
I think this is a feature needed for all Goggle Voice OBI users outside US!...

Can anyone help me?
Thanks a lot.
Andrea
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4044


« Reply #1 on: November 08, 2014, 07:41:00 am »

Physical Interfaces -> Phone Port -> OutboundCallRoute
Add to the beginning:
{(<0039>(x[1-9]xx.|[1-9]xx.)):sp1},

Edit:
x[1-9]xx. includes all numbers with 2nd digit of 1 thru 9
[1-9]xx. includes all numbers starting with 1st digit of 1 thru 9
I think that covers everything.

« Last Edit: November 08, 2014, 07:56:06 am by azrobert » Logged
andreabix
Newbie
*
Posts: 4


« Reply #2 on: November 08, 2014, 08:39:31 am »

Thanks a lot, that looks perfect!...
But I still have to figure out how to change the setting: if I try with the cloud panel (enter OBI expert) the field is "read only". If I try through the local web interface, default setting is restored after reboot.
How can a change the setting?

Thanks for your help
Andrea
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4044


« Reply #3 on: November 08, 2014, 08:41:04 am »

I forgot the + in my last post.
The following should cover it.
Physical Interfaces -> Phone Port -> OutboundCallRoute
Add to the beginning:
{(+xx.|00xx.):sp1},{(<0039>xx.):sp1},
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4044


« Reply #4 on: November 08, 2014, 08:42:16 am »

From the OBiTalk dashboard click Edit Profile on the left column.
At the bottom of the page check "Enable Obi Expert..."
Click Submit Query.
Now you can go directly to OBi Expert from the dashboard.

Click Obi Dashboard.
On the right of your OBixxx is an icon with a red E.
Click on it to enter OBi Expert.

To navigate click on the titles with the +
Then click on a sub-title
An example click on Service Providers
Then click ITSP Profile A General
There are 2 boxes to the right of each setting
To change a setting uncheck the box under ObiTalk Setting
Then uncheck the box under Device Default
Now change the setting
After you have made all the necessary changes for that page, click Submit at the bottom of the page.
OBiTalk will download the configuration changes to the OBi and reboot it.
Wait until this process is complete before continuing to the next page.
« Last Edit: November 08, 2014, 08:50:47 am by azrobert » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4044


« Reply #5 on: November 08, 2014, 08:56:04 am »

I'm not thinking clearly his morning. My 1st post will work with a + sign.
Logged
andreabix
Newbie
*
Posts: 4


« Reply #6 on: November 08, 2014, 04:53:53 pm »

Thanks very much for your detailed description.
Unfortunately I can't make it work.
Even if I just add the simple rule {(<0039>xx.):sp1} in the first place, which is supposed to pre-pend 0039 to all outgoing calls, it doesn't happen...
I read the documentation but could not find an explanation...
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 6195



« Reply #7 on: November 08, 2014, 07:13:36 pm »


Hangouts calling works differently than GV/OBi/Chat calling.

Try 01139 instead of +39

Does that work?
Logged

andreabix
Newbie
*
Posts: 4


« Reply #8 on: November 08, 2014, 11:09:07 pm »

Ok, I found the solution...
The problem was that BEFORE processing the OutboundCallRoute in the phone port, the digitMap of the Service provider is applied. That is stated in the manual:
Quote
Note that every endpoint also has a digit map defined. The user dialed number is completely processed with the endpointís
digit map first before it is passed to the OutboundCallRoute for routing decision. Therefore the number used for matching
call routing rules has already incurred the transformations, if any, implied by the digit map. Remember this fact when
crafting your own OutboundCallRoute.
The point is that the default digitMap for Google Voice (ITSP Profile A - general) is the following:
Code:
(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)
So, when dialing an Italian cell phone number, i.e. 3295788900, it is prepended with "1" BEFORE being processed by OutboundCallRoute, which results in an "invalid" (003913295788900) dialed number.

I removed <1>[2-9]xxxxxxxxx from the digitMap of ITSP Profile A and it worked.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement