One way audio with Obi202, Panasonic KX-TGP550T04 and double NAT

Started by Zopa, March 07, 2015, 08:34:27 PM

Previous topic - Next topic

azrobert

Quote from: Zopa on March 09, 2015, 08:12:30 PM
This part worked fine:

QuoteVoice Services -> Gateways and Trunk Groups -> Trunk Group 1
TrunkList: sp1,sp2,sp3
DigitMap: (Msp1)

X_InboundCallRoute: {123456789>(Mtg1):tg1}

And so did this:

QuoteI have GV defined on SP1 and set MaxSessions=1

Was this working then stopped?


You didn't say, so I assume you are using OBiTalk to configure your OBi202.

Have you successfully used GV2 and GV3 to make a call?

Use the following inbound route:
{123456789>(xx.):sp2}
Then:
{123456789>(xx.):sp3}

Are using the default DigitMaps for ITSP Profile B and C?

I repeated my Trunk group test.
The 2nd call failed over to SP2 with Maxsessios=1
Both calls were routed to SP1 with Maxsessios=2

Zopa

Thank you guys! I was able to configure outbound calls. While doing it learned that apparently my KX-TGP550T04 only supports 3 calls at the same time, which essentially means if I am to use this phone, I really only need 1 GV account, as the other ones will never get used, and then I can actually downgrade to Obi100 from Obi202. Nonetheless it was an interesting exercise and introduction to Obi setup for me.

Now I'm trying to configure Google Voice to ring on my Panasonic phone, which seems to be a challenge as well. I configured SP1 ->X_InboundCallRoute as {SP4(123456789@local_client),ph,ph2}, but my VoIP phone on SP4 doesn't ring. Analog phones ring just fine.

Zopa

On my assumption that I can use Obi100 instead of Obi202. Can I really? It seem that Obi100 is missing "X_Proxy" option. Isn't the key for the ATA type setup?

azrobert

Use the following:
{sp4(anything@xx.xx.xx.xx:pppp;ui=$1),ph,ph2}

xx.xx.xx.xx:pppp is the IP address and port of the IP phone.
;ui=$1 will pass the callerid

You can check the OBi System Status to see the IP address and port of the IP phone. It is listed under SP4 Service Status. If you are registering more than 1 IP phone to the SP trunk, only the IP address and port of the last phone to register will be displayed.

X_Proxy allows the IP Phone to register to the OBi2xx.
If your IP Phone can call out without registration, it will work with an OBi100.
You would still need a dummy SIP trunk defined on SP2.

Edit:
You can test this with your OBi202.
Uncheck X_Proxy
Change the Proxy on the IP phone to: xx.xx.xx.xx:5063
(IP address of the OBi202 and SP4 port#)
Change Register=NO on the phone

Zopa

Thank you Robert!

Adjusted setting for Voice Services -> SP1 -> X_InboundCallRoute worked like a charm. As for trying to connect my IP Phone to Obi device without registration, it didn't work. These Panasonic IP phones are very finicky. And there is no equivalent of "Change Register=NO" on this phone I could find. It's ok though. I can live with Obi202.

Thank you for the ui=$1 suggestion. On the CID question, is it possible for Obi to do a CNAM lookup before passing it along?

azrobert

If you want to downgrade, the OBi200 will work. The OBi200 has been on sale several times in the past for $30. It's been awhile since the last time.

The OBi won't do cnam.
Some people use Callcentric for cnam.
http://www.obitalk.com/forum/index.php?topic=3640.0

lrosenman

I've set up my OBI202 to talk to a RaspberryPI running PBX in a Flash, and a bulkvs account to do CNAM lookup, with my Google Contacts picked up by a script every night so that "known" numbers don't get looked up on the $0.009 / lookup Bulkvs.com account.

I'm going write up a HowTo if people are interested.


Zopa

I've setup SP2 to via Callcentric. It was a breeze to setup. Calls route from GV --> CC --> Obi --> IP Phone. However CNAM doesn't seem to work. I have it enabled in CC settings, but somehow the name just doesn't make it to my IP Phone.

Side note, why would CC allow free CNAM lookups?

azrobert

The method I suggested doesn't pass cnam to the IP phone.
The phone port should get cnam.

Use the following on the X_InboundCallRoute for the Callcentric trunk:
{sp4(anything@xx.xx.xx.xx:pppp),ph,ph2}

Then change the following:
Service Providers -> ITSP Profile D SIP -> X_SpoofCallerID: Checked

Now you should get callerid and cnam on the IP phone.

Zopa

Perfect! Works like a charm. First call took seconds to complete for some reason though, went to GV voice mail mid ring on the IP Phone, but subsequent calls worked just fine.

Btw, question on reliability of this whole setup. I get intermittent issues where I try to place a call and it times out and get a busy signal. Nothing would register in Call Status during or Call History later. It may persist for minutes and then clear up. If may happen just after a successful call. Any idea on how to even begin to troubleshoot this?

azrobert

This setup shouldn't affect GV outbound calls.
Did this start when you added Callcentric?

I can't help you on this one.
You should open a new topic.
The GV experts might not be following this thread.

Zopa

Oh, it has nothing to do with CC. It was happening from the get go. I will open another thread.

Thank you for all your help!

Zopa

Quote from: azrobert on March 15, 2015, 08:20:05 PM
The method I suggested doesn't pass cnam to the IP phone.
The phone port should get cnam.

Use the following on the X_InboundCallRoute for the Callcentric trunk:
{sp4(anything@xx.xx.xx.xx:pppp),ph,ph2}

Then change the following:
Service Providers -> ITSP Profile D SIP -> X_SpoofCallerID: Checked

Now you should get callerid and cnam on the IP phone.



Sorry to bother you on an old thread, but I had to re-do my config and Caller ID Name stopped working for some reason, and I don't know why. I have it setup exactly as I did before, but I only get the number passed through, not the name. Are there other settings somewhere that affect this?