December 18, 2017, 06:52:30 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: local config with asterisk  (Read 28455 times)
Alex01
Newbie
*
Posts: 4


« on: May 14, 2015, 11:27:53 pm »

Hi,

I have an asterisk setup which I currently use with sipura 2102, I'm no asterisk expert but I mostly have it working.

I recently purchased an OBi100-UK to use in place of above device. I can configure OBi100 without problem via dashboard directly using my voip provider settings, but am unable to configure in the same way as I currently have my sipura currently set as below:

ip address of asterisk server for proxy/registrar/ i.e. 192.168.0.100
entension number for auth/username i.e. 1001
user password for password i.e. 1001abcd

this setup is currently working on my sipura without problems but I cannot get the OBi100 configured in the same way (I think as basic ata).

my question is should I be looking to configure it through dashboard or locally? I have tried both ways but am unable to get registration.

thanks in advance.


Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2738


« Reply #1 on: May 16, 2015, 05:28:57 am »

You should be able to do it any of 3 ways - local,  dashboard or dashboard expert. That 2 ways have failed for you suggests something else is not correct.

If you have already configured SP1 with a different provider and are now configuring SP2, ensure that Voice services/SP2/X_ServProvProfile is set to B.

Log in locally. What do you see under Status/System Status/SPx Service Status? (x = 1 or 2 as appropriate).
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3204


« Reply #2 on: May 16, 2015, 08:43:34 am »

my question is should I be looking to configure it through dashboard or locally? I have tried both ways but am unable to get registration.

If you use the local interface to configure your OBi you must disable OBiTalk auto provisioning, otherwise OBiTalk will overlay any changes you make.

System Management -> Auto Provisioning
Under OBiTalk Provisioning
Method: Disabled
Logged
Alex01
Newbie
*
Posts: 4


« Reply #3 on: May 18, 2015, 03:57:14 am »

You should be able to do it any of 3 ways - local,  dashboard or dashboard expert. That 2 ways have failed for you suggests something else is not correct.

If you have already configured SP1 with a different provider and are now configuring SP2, ensure that Voice services/SP2/X_ServProvProfile is set to B.

Log in locally. What do you see under Status/System Status/SPx Service Status? (x = 1 or 2 as appropriate).

Sp1 is not configured, I have reset to factory settings and am trying to configure my asterisk extension on SP1.

The status is showing as 'Service Not Configured'. I am not sure how to set locally or dashboard. I need instructions for one way or other.

my question is should I be looking to configure it through dashboard or locally? I have tried both ways but am unable to get registration.

If you use the local interface to configure your OBi you must disable OBiTalk auto provisioning, otherwise OBiTalk will overlay any changes you make.

System Management -> Auto Provisioning
Under OBiTalk Provisioning
Method: Disabled


auto provisioning is disabled already.

---------------------------------------------------------------------------------------------------------------------------

I would be grateful if someone could give me instructions on either dashboard or locally.

My extension is               1001
my username is              1001abcd
my server asterisk ip is:  192.168.0.100

I will reset my device again.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3204


« Reply #4 on: May 18, 2015, 04:49:35 am »

I believe when you manually configure (not using a wizard) a trunk, it will show as Not Configured on the dashboard. Log into the OBI using the local interface. You will be presented a Status Page. Scroll down to SP1 Status. What is the status? If it shows Registered, it is defined correctly.
Logged
OzarkEdge
Full Member
***
Posts: 183


« Reply #5 on: May 18, 2015, 05:37:30 am »

I would be grateful if someone could give me instructions on either dashboard or locally.

My extension is               1001
my username is              1001abcd
my server asterisk ip is:  192.168.0.100

I will reset my device again.

Maybe this will help using the OBi local web interface:

ITSP Profile A
SIP - SIP::ProxyServer = Asterisk server IP address
Submit

SP1 Service - SIP Credentials::AuthUserName = extension ID/number
SP1 Service - SIP Credentials::AuthPassword = extension password
Submit

OE
Logged

Alex01
Newbie
*
Posts: 4


« Reply #6 on: May 18, 2015, 06:00:05 am »

I believe when you manually configure (not using a wizard) a trunk, it will show as Not Configured on the dashboard. Log into the OBI using the local interface. You will be presented a Status Page. Scroll down to SP1 Status. What is the status? If it shows Registered, it is defined correctly.

Local login:  There is a question mark on to the right of 'Service Not Configured'.

Dashboard shows:
SP1    Asterisk      Retrying Register (server=0.0.0.0:5060)

I would be grateful if someone could give me instructions on either dashboard or locally.

My extension is               1001
my username is              1001abcd
my server asterisk ip is:  192.168.0.100

I will reset my device again.

Maybe this will help using the OBi local web interface:

ITSP Profile A
SIP - SIP::ProxyServer = Asterisk server IP address
Submit

SP1 Service - SIP Credentials::AuthUserName = extension ID/number
SP1 Service - SIP Credentials::AuthPassword = extension password
Submit

OE

After carrying out your instructions the status shows:

Status Register Failed: No Response From Server (server=192.168.0.100:5060; retrying)
PrimaryProxyServer   
SecondaryProxyServer   
CallState 0 Active Calls help

Logged
OzarkEdge
Full Member
***
Posts: 183


« Reply #7 on: May 18, 2015, 06:13:24 am »

>>Status Register Failed: No Response From Server (server=192.168.0.100:5060; retrying)

Sounds like it's not finding the server at 192.168.0.100:5060?

OE
Logged

Alex01
Newbie
*
Posts: 4


« Reply #8 on: May 18, 2015, 06:37:53 am »

>>Status Register Failed: No Response From Server (server=192.168.0.100:5060; retrying)

Sounds like it's not finding the server at 192.168.0.100:5060?

OE

Correct OzarkEdge! I didn't have network set correctly, totally my fault; I just plugged cable into switch instead directly into router. I feel like a bit of a donkey (insult to donkey intelligence) but it's working fine.

Thanks to all you for your help.

Logged
OzarkEdge
Full Member
***
Posts: 183


« Reply #9 on: May 18, 2015, 07:04:53 am »

You're welcome!  Now you can move on to the really hard stuff!   Grin

OE
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC