December 10, 2017, 07:52:08 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: SIP configuration problem Obi110  (Read 21014 times)
Arek
Newbie
*
Posts: 3


« on: May 24, 2015, 02:38:53 pm »

Hi all. I'm very new in this forum as I just started using my Obi110.
Thanks to WelshPaul posts I was able to configure my PSTN correctly for the UK settings.

The problem I have is I'm not using UK SIP provider.
Main reason for purchasing this device was using BT land line as usual for all calls in the UK, and have SIP in Poland with polish local number for family and friends.
PSTN works very well. All cals are correct in and out.

I choose provider, received login and phone number. After some research I finally was able to register my device in provider. System and provider webpage indicate my username as connected.
I can receive calls from SIP. No problems, all work well.
I can't made any successful outgoing call :-( I choosed to set my default phone to stay with PSTN line. For calls via SIP I'm using **1<call number>
Call history show me this:
Terminal ID   PHONE1   SP1
Peer Name      
Peer Number   **1122118099   122118099
Direction   Outbound   Outbound
22:15:53   New Call   
22:16:18   End Call   
For me looks OK. But no any traffic in the current call (trx and rx remind on 0). No connection codec, etc.
Can anyone will be able to help me with this problem?

Thanks
Arek
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #1 on: May 25, 2015, 06:27:08 am »

Hi Arek - welcome to the forum.

There’s a few possible problems here:

Check the format that your VOIP service provider requires you to dial. Some require the number in full international format.

Your router may be blocking the ports required for speech (RTP). Recommended ports to open for the OBi110 are:
TCP Ports: 6800, 5222, 5223
UDP Ports: 5060 to 5063, 10000 to 11000, 16600 to 16998, 19305
An easy way to test for this problem is to temporarily put the local ip address of the OBi110 in your router’s DMZ. This will open all ports just for testing.

If SIP calls incoming to you are working ok, then there should be no issue regarding compatibility of CODECs.

Your digit maps will not prevent the call being correctly routed, but may be making it very slow to connect – more than ten seconds. If international format is required then something like this may be good for you:

Service Providers -> ITSP Profile A -> General -> DigitMap:
(0048xxxxxxxxx|xx.)

If the nine-digit format is correct, then something like this may work well for you:

Service Providers -> ITSP Profile A -> General -> DigitMap:
(xxxxxxxxxS3|xx.)

We can fine tune the digit maps if you let us know exactly what digits you need to dial.
Logged
Arek
Newbie
*
Posts: 3


« Reply #2 on: May 25, 2015, 08:59:33 am »

Thanks ianobi for response.
I did all you suggested. Put my Obi to DMZ (it's not necessary. I've checked WAN configuration and my router have SIP profile enabled)
I've made changes in DigiMap (there is no requirements on my provider site about use international format for calls) so I'm using just 9 digit numbers. Land line and cell numbers in Poland are 9 numbers. All range from 1 to 7 is used. 800 are free phones (don't need them). 9xx alarm numbers except 901 which is my provider check number.

Unfortunately still can't make proper call. All using SIP number can call me and they did it few time today.
I'm not able to make any outgoing call :-(

This is what I see during call attempt:
Call 1             

Terminal 1   Terminal 2
Terminal ID   PHONE1   SP1
State   trying   calling
Peer Name      
Peer Number   **1122118099   122118099
Start Time   16:48:01   16:48:01
Duration   00:00:16   00:00:16
Direction   Outbound   Outbound
Peer RTP Address      0.0.0.0:0
Local RTP Address      192.168.1.87:16600
RTP Transport      UDP
Audio Codec      tx=; rx=
RTP Packetization (ms)      tx=0; rx=0
RTP Packet Count      tx=0; rx=0
RTP Byte Count      tx=0; rx=0
Peer Clock Differential Rate      
Packets In Jitter Buffer      
Packets Out-Of-Order      
Packets (10ms) Interpolated      
Packets Late (Dropped)      
Packets Lost      
Packet Loss Rate      
Packet Drop Rate      
Jitter Buffer Length      
Received Interarrival Jitter      
DTMF Digits Received      
Jitter Buffer Underruns      
Jitter Buffer Overruns      
Sequence number discontinuities      
skew compensation      
send silence   

Any other ideas? If you need any part of my config, just let me know which one.
I'm very impressed about Obi device and it suit me the best but I can't use all 100% yet.

Thanks a lot
Arek
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #3 on: May 25, 2015, 09:17:28 am »

Quote
I've checked WAN configuration and my router have SIP profile enabled)

If this is anything like the "SIP ALG" function that many routers have, then disable it. It often causes more problems than it solves.

If your modem is separate from your router, then test by connecting the OBi110 directly to the modem, wait a few minutes for the OBi110 to register with the VOIP provider, then try making a call. This will show if the problem is the router or not.

Is it possible to view any call logs on your SIP provider's web site? This may show that the signalling (SIP) part of the call is working even though the speech (RTP) is not working.
Logged
Arek
Newbie
*
Posts: 3


« Reply #4 on: May 25, 2015, 09:27:42 am »

Finally I solved it myself :-)
It was one place I missed.
Service Providers -> ITSP Profile A -> SIP -> UserAgentDomain
Where should be FQDN address of my provider.
Auth and incoming calls works without this line, but outgoing don't.

Thanks for all your tips :-)
Unfortunately all providers in Poland using standard Cisco or Dlink stuff. I wasn't able to find any information about Obi config.

Have a great day. I have one. All working :-)
Yet another happy customer

Arek
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #5 on: May 25, 2015, 09:56:11 am »

Quote
Service Providers -> ITSP Profile A -> SIP -> UserAgentDomain

I would never had thought to check that setting!

Good to see it's all working   Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC