July 16, 2019, 09:37:24 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 ... 9 10 [11] 12 13 ... 18
  Print  
Author Topic: Firmware update for 20x series  (Read 372670 times)
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #200 on: May 01, 2018, 07:55:00 pm »

Last sentence first, the warranty period starts the day that the device is added to OBiTALK via the **5 procedure, regardless of when it was purchased.

There are a couple other users having the no-audio-on-inbound-calls bug.  At this point, it looks like a case of "do not attempt to adjust your set"... there is some sort of bug on the new interconnection between the two companies.

I suggest ignoring it at least until tomorrow, if not for a few more days.  Polycom and Google are both working on squashing some bugs this week. 

All newly-added devices are being added with the new firmware and the new VoIP calling platform, so that would explain why your unit got that firmware.

If you can wait, that is my strong recommendation.  I would not recommend trying to downgrade the firmware, as that will make a mess out of that account, which has now been converted to the new platform.
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
dircom
Sr. Member
****
Posts: 461


« Reply #201 on: May 03, 2018, 02:33:07 pm »

As per my post, 3.2.2 (Build: 5829EX) is the new Google Voice VoIP firmware.
Try this:

On OBiTALK, click on the OBi with the problem, and delete the SPx that has the Google account linked that doesn't work properly.

Press Ctrl-T to open another browser tab.  On that tab, sign into the correct Google / Gmail account that holds the Google Voice phone number that you want to use on that OBi, that is not working correctly, and go here:
https://myaccount.google.com/
Click the section that says "Apps with account access", then click "MANAGE APPS".  On the next page, find and delete the entry for OBiTALK Google Voice, and also delete any entries for third party services like Simonics GVGW.

Go back to the OBiTALK tab, and click the SPx again, and go through the Google Voice setup again.

Does that fix it?


Did that, no change
Weird thing is I can call from my cell (connected to wi-fi or not) or Vestalink or GV and he can hear me.
but when he calls from his cell to GV # on his OBi the audio is one way.
or when his kids school calls his house, one way audio
I do have my cell phone and one of my GV #'s as trusted callers but another GV that is not a trusted caller can call him with no problems.

I do see that instead of fwd calls to Google Chat, it says OBiTALK Device, and some sip info
« Last Edit: May 03, 2018, 02:41:47 pm by dircom » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #202 on: May 03, 2018, 02:49:48 pm »

OK, so your web settings correspond to a Google Voice account that has been migrated to the new platform.  Inbound calls should work, if you toggle ON the "OBiTALK" device entry/entries in settings, here:

https://voice.google.com/settings

Make sure that, if you were using the Simonics GVGW or Asterisk, that you have completely disconnected those things from your Google account.

See the screenshot below.  The section below the section in my screenshot shows any regular PSTN forwarding numbers you have linked to your account.  If the forwarding number is on an Android phone, and you've set that phone's Google Voice app to use WiFi calling, then it will no longer appear in the forwarding number section.  Instead, it will show as an "Android device" in the section above.


* screenshot-voice.google.com-2018.05.03-14-44-56.png (147.54 KB, 968x891 - viewed 668 times.)
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
dircom
Sr. Member
****
Posts: 461


« Reply #203 on: May 03, 2018, 03:47:04 pm »

screenshot from https://www.google.com/voice/b/0#phones


* AKA Screen Shot google-com-settings.jpg (37.96 KB, 782x602 - viewed 630 times.)
« Last Edit: May 03, 2018, 04:30:49 pm by dircom » Logged
dircom
Sr. Member
****
Posts: 461


« Reply #204 on: May 03, 2018, 03:54:37 pm »

https://voice.google.com/settings


* AKA Screen Shot voice-google-com-settings.jpg (40.8 KB, 996x820 - viewed 629 times.)
« Last Edit: May 03, 2018, 04:29:31 pm by dircom » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #205 on: May 03, 2018, 05:03:46 pm »

Two possibilities:

You are looking at the wrong Google/Gmail/GV account in your screenshot of the new GV UI, or your browser has some stale cache, history or cookie data.

Try signing off of ALL Googly things in your browser, including Gmail.  Clear the browser's cache, cookies and history.  Close and reopen the browser.

Now, open an "Incognito" browsing session in Google Chrome Browser by pressing Ctrl-Shft-N, or open a "Private" browsing window in Firefox by pressing Ctrl-Shift-P.

In that incognito or private window, try signing into the same Google account that holds the GV inbound phone number you are trying to use, and go here:  https://voice.google.com/settings

Look at the Google Voice number displayed at the top of the page, and make sure it is the same GV number you are trying to use with your OBi.  If not, sign out and sign in with your other account(s) until you find it.

Once on the correct page, you should see the new settings.
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #206 on: May 03, 2018, 06:58:37 pm »

Ok, thanks.  The reason I wanted you to go through that is:  it is actually possible to be logged into several different Google accounts at the same time, on the same browser.  Google keeps track of it with cookies.  The problem is, some Googly things are compatible with this, and some are not.  The chronic offender is the page used to unlock GV numbers for porting out.  If the user is logged into more than one Google account, it may only "see" one of the two accounts and thus, there will be no number to unlock.

Since you are/were working on your own account and on somebody else's, that was a potential issue.

The URL you posted,  https://www.google.com/voice/b/0#phones proves that this browser is signed into more than one account.  The "/b/0" portion shows that it is the first of the multiple accounts signed in.  If it was the second account, it would say "/b/1", and so on.

I don't know why that account isn't working.   In theory, when a new device is added, it downloads the new firmware, which is what you are seeing.  It should also convert that Google Voice number over to the new platform upon adding it to the OBiTALK portal.  Perhaps this one just got stuck in some sort of "early adopter" limbo.
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
dircom
Sr. Member
****
Posts: 461


« Reply #207 on: May 03, 2018, 07:07:18 pm »

Here are the urls the second time around
https://www.google.com/voice/b/0?gsessionid=9vLCxcPMQtfNU2-4ERyjjOEk0wnj7mXJ&pli=1#phones
and
https://voice.google.com/settings

The main difference I see is, forward to chat on the older devices
vs fwd to OBITALK Device using https://www.google.com/voice  on the newly connected OBi

I guess I could try a separate account and dashboard and see what that does
also I don't know why my choice is fwd to phone 3, there never was a phone one or two
« Last Edit: May 03, 2018, 07:13:52 pm by dircom » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #208 on: May 03, 2018, 07:16:23 pm »

If the old, "Legacy" UI shows Google Chat, then the account has not yet been converted to use VoIP.  If an account has been converted, then the Legacy settings page will no longer display Chat, but instead, it will have an entry for each VoIP connection (one for each OBiTALK device, one for the web client, and one for each Android client).
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #209 on: May 03, 2018, 07:27:32 pm »

Pardon my laziness to re-read the thread, but I think you mentioned that calls using other ITSPs work?

In other words, if both your device and his device take turns calling each other via OBiTALK (**9 nnn nnn nnn), do you each hear the other party?  What if you provision his device with a SIP ITSP; do you get two-way audio on calls?

Also, is this user in the USA?
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
dircom
Sr. Member
****
Posts: 461


« Reply #210 on: May 04, 2018, 02:31:13 pm »

Yes, Obi to Obi works
I live on the East Coast, he is 15 miles away
I finally sent his calls to CallCentric as a work around for now

It still seems odd that he can hear me when I call him from my cell and various numbers connect to my home OBi
« Last Edit: May 04, 2018, 02:33:09 pm by dircom » Logged
CosmoEPTX
Newbie
*
Posts: 2


« Reply #211 on: May 06, 2018, 08:04:11 pm »

First!

Looks like my obi200 was automatically updated to firmware 3.2.2 (Build: 5853EX)  Cheesy

Now google contacts show in caller id, which is neato. Also, looking at the settings, seems like google has set up a couple of proxies for our obihai devices, obihai.sip.google.com and obihai.telephony.goog.

Discuss.
« Last Edit: May 06, 2018, 08:29:17 pm by CosmoEPTX » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #212 on: May 06, 2018, 09:20:00 pm »

First!

Looks like my obi200 was automatically updated to firmware 3.2.2 (Build: 5853EX)  Cheesy

Now google contacts show in caller id, which is neato. Also, looking at the settings, seems like google has set up a couple of proxies for our obihai devices, obihai.sip.google.com and obihai.telephony.goog.

Discuss.

"First"?  Hunh?  I'm happy you are delighted with the new platform.  This has been discussed at length on this forum already.  No need to start a separate discussion.

http://www.obitalk.com/forum/index.php?topic=13824.0

http://www.obitalk.com/forum/index.php?topic=13825.0
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
LTN1
Hero Member
*****
Posts: 530


« Reply #213 on: May 06, 2018, 09:26:22 pm »

Steve...he seems giddy...he probably meant the first to report build 5853EX.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5612



« Reply #214 on: May 06, 2018, 09:37:48 pm »

It's to be expected, that, as the conversion rolls out, some unforeseen, and typically-minor "edge case" bugs will pop up and get fixed ASAP.  So, there are likely to be frequent firmware revisions.

Rather than try to figure out which version to download manually, or to try to guess what the non-existent change logs would say, I recommend just letting the system do the work.  If, at some point, a bug is serious enough to warrant a subsequent update, they'll push it out (again).


* screenshot-www.obitalk.com-2018.05.06-21-33-13.png (172.11 KB, 1242x558 - viewed 582 times.)
Logged

--Steve

Google Voice Forum Product Expert

https://support.google.com/voice/community
LTN1
Hero Member
*****
Posts: 530


« Reply #215 on: May 07, 2018, 05:38:12 am »

I can confirm that these updates are silently continuing to be pushed out automatically. In my case, and I am assuming in most cases that has automatic updates, there isn't a choice...the OBi just updates very quickly. Before going to bed last night I was at 3.2.2 (Build: 5845EX) and a few minutes prior to typing this, the OBi updated to Build 5853EX in front of me. It took around 30 seconds--very quick--would have not noticed it if I wasn't right in front of the OBi with a single red LED flashing before everything completed in about 30 seconds.
« Last Edit: May 07, 2018, 06:26:43 am by LTN1 » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3851


« Reply #216 on: May 07, 2018, 07:17:13 am »

I can confirm that these updates are silently continuing to be pushed out automatically.

Are you using GV? Was the config changed to SIP? Proxy settings changed?
Logged
RFC3261
Sr. Member
****
Posts: 263


« Reply #217 on: May 07, 2018, 08:50:41 am »

It's to be expected, that, as the conversion rolls out, some unforeseen, and typically-minor "edge case" bugs will pop up.
With the great OBi power (and some of the people here have "interesting" configurations and tweaks) comes great responsibility.  I fully expect that for some the only answer will be a full factory reset and reconfiguration to support the specialness that is them.
Logged
Taoman
Hero Member
*****
Posts: 1205


« Reply #218 on: May 07, 2018, 08:57:47 am »

Yes, am currently using GV. Since you are the expert in these things, I've taken some screenshots for you to confirm if I am actually using SIP via GV yet.

Did you sign up for the GV app beta?

Interesting they're using a STUN server. Hopefully, that will take care of most NAT/router problems.

And I see they're using TLS which is to be expected since SSL is deprecated.

Quote
30 June 2018 is the deadline for disabling SSL/early TLS and implementing a more secure encryption protocol TLS 1.1 or higher (TLS v1.2 is strongly encouraged) in order to meet the PCI Data Security Standard (PCI DSS) for safeguarding payment data.
Logged
LTN1
Hero Member
*****
Posts: 530


« Reply #219 on: May 07, 2018, 09:34:49 am »

I'm not in any GV beta program.
Logged
Pages: 1 ... 9 10 [11] 12 13 ... 18
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC