Question about Google Voice

Started by dj62, February 02, 2011, 07:18:52 AM

Previous topic - Next topic


I have Google voice up and working, however when I receive a call from Google voice to my Obi It says press 1 to accept the call. I do not have call screening turned on in Google voice, so I am assuming this is something on the OBI? Is there a way to turn this off so when you answer it just picks up?



If you get to the AA right away, it sounds like you have setup the Google voice as a number in your InboundCallRoute of your Voice Services SP1 or SP2 or Line port settings.

I think what you are hearing the AA saying is "Press 1 to continue this call", press 2, 3.

These are the only voice prompts you will get from the Obi when you call in this way.

Anything else would be Google voice I think???

Listen in again and confirm what IVR message you are getting.let us know.

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.


The announcement is coming from GV.

Please see Step 8, in this How To article for a tip on how to deal with this.


Yes that was the trick.

Thank you for the quick response.

Very Cool


Since this was brought up, I will just ask if any efforts are being made to shorten the time it takes for the OBi to send the "1" and connect the call through.  Once the phone is picked up, the Obi should be able to answer the call, send the "1", and connect the audio path through to the phone in well under one second.  In experiments with Asterisk, I was able to have it answer the call, immediately send the "1" (in other words, no programmed waits at all), and then bridge the audio, so the entire process took under half a second (in fact it seemed almost instantaneous).  Contrast this with the OBi, where when you use that setting and pick up the phone, you have to count off a couple seconds before saying "Hello" or it's likely the caller won't hear your answer.

My thought is that maybe you could have a configurable time (in ms) before sending the "1" tone, that would either default to 0, or something relatively low (like 200 ms).  The touch tone itself doesn't need to be long (100 ms would be serious overkill) but I suppose that could me made configurable as well.  Once the tone is sent, there's no good reason whatsoever to delay connecting the audio path though - that can happen immediately.  So I would hope that this excessive delay is being fixed in an upcoming firmware update.
Inactive, no longer posting or responding to messages.  Goodbye and good luck.  Some of my old Obihai-related blog posts have been moved to - note this in NOT my blog; I have simply given the owner permission to repost some of my old stuff.