[SOLVED]setup rules for forwarding incoming calls on GV no to another Obi device

Started by tintin11, June 10, 2011, 09:53:53 PM

Previous topic - Next topic

Shammi

Hello RonR,

I found my mistake. I should have used :

2 **9 201xxxxxx ->  (Remote OBi in India OBiTALK Service)

I was missing the beginning 2.

Now the problem is that the call drops as soon as it connects.

Now that I am dialling in a proper way, I get the following readings:

Canada Obi >
Terminal ID        PHONE1                  OBiTALK1
Peer Name
Peer Number       2**9201xxxxxx        2**9201xxxxxx
Direction             Outbound                Outbound
00:00:32             New Call             
00:00:35                                          End Call (486  Busy Here)

Remote Obi (India)>
Terminal ID        OBiTalk1                  OBiTALK1
Peer Name          home
Peer Number       201yyyyyy               201xxxxxx
Direction             Inbound                  Outbound
00:00:34             Ringing       

Where 201xxxxxx is Remote Obi (India)
201yyyyyy  is Canada Obi

I have the following setting already placed in.

Please help,
Shammi


Quote from: RonR on April 03, 2012, 11:45:44 PM
Shammi,

The configuration I previously proposed was based on your only needing to use one trunk (the LINE Port) on the remote OBi in India.  Now that you want to use more than one trunk (the LINE Port and SP2) on the remote OBi in India, I think the best approach is to implement Single-Stage Dialing Through Any OBi Trunk.  In your case, it's only a matter of making the following changes to the remote OBi in India:

Voice Services -> OBiTALK Service -> InboundCallRoute:

{(Mcot)>(Mpli):pli},{(Mcot)>(<*1:>(Msp1)),(Mcot)>(<**1:>(Msp1)):sp1},{(Mcot)>(<*2:>(Msp2)),
(Mcot)>(<**2:>(Msp2)):sp2},{(Mcot)>(<*8:>(Mli)),(Mcot)>(<**8:>(Mli)):li},{(Mcot)>(<*9:>(Mpp)),
(Mcot)>(<**9:>(Mpp)):pp},{(Mcot):aa},{ph}

Note: Replace pli above (2 places) with the trunk name (sp1,sp2,li,pp,tg1) that you wish to be the PrimaryLine when dialing from Canada.

User Settings -> User Defined Digit Maps -> User Defined Digit MapX:

Label : cot
DigitMap : (200123456)

To have incoming calls to SP2 of the remote OBi in India ring the PHONE Port of the OBi in Canada (only):

Voice Services -> SP2 Service -> X_InboundCallRoute : {pp(ob200123456)}

where 200123456 is the OBiTALK number of the OBi-1 (Canada).

To place calls from the OBi in Canada using the remote OBi in India:

     2*18005551212  ->  Remote OBi in India using the trunk designated as the PrimaryLine above
2 **1 18005551212  ->  Remote OBi in India SP1 Service
2 **2 18005551212  ->  Remote OBi in India SP2 Service
2 **8 18005551212  ->  Remote OBi in India LINE Port
2 **9 200123456      ->  Remote OBi in India OBiTALK Service


Shammi

Quote from: RonR on April 28, 2012, 11:56:00 AM

Try changing it to:

{(Mcot)>(<*1:>(Msp1)),(Mcot)>(<**1:>(Msp1)):sp1},{(Mcot)>(<*2:>(Msp2)), (Mcot)>(<**2:>(Msp2)):sp2},{(Mcot)>(<*8:>(Mli)),(Mcot)>(<**8:>(Mli)):li},{(Mcot)>(<*9:>(Mpp)), (Mcot)>(<**9:>(Mpp)):pp},{(Mcot)>(Msp2):sp2},{(Mcot):aa},{ph}


I tried this, didn't make any difference, Thanks!

RonR

Shammi,

Let's rewind a little.  I think some things got lost along the way.

If you're still wanting the calling card logic, this should be the proper InboundCallRoute for the OBi in India:


Voice Services -> OBiTALK Service -> InboundCallRoute (India):

{(Mcot)>(<*1:>(Msp1)),(Mcot)>(<**1:>(Msp1)):sp1},{(Mcot)>(<*2:>(Msp2)),(Mcot)>(<**2:>(Msp2)):sp2},
{(Mcot)>(<1234567,,,,,,,,,,,,,,,,,,,,*9987654321,,,,,><*8010:>xx.),
(Mcot)>(<1234567,,,,,,,,,,,,,,,,,,,,*9987654321,,,,,><**8010:>xx.):li},
{(Mcot)>(<*8:>(Mli)),(Mcot)>(<**8:>(Mli)):li},{(Mcot)>(<*9:>(Mpp)),(Mcot)>(<**9:>(Mpp)):pp},
{(Mcot)>(Msp2):sp2},{(Mcot):aa},{ph}


To make calls from Canada using trunks on the OBi in India, use the following formats:

             2* + number  ->  SP2
         2 **1 + number  -> SP1
         2 **2 + number  -> SP2
         2 **8 + number  ->  LINE
2 **8 + 010 + number  ->  LINE (using calling card)
         2 **9 + number  -> OBiTALK


To call the OBi in India from Canada using the OBiTALK Service, you would dial **9 200123456.  The Auto Attendant of the OBi in India should answer the call.  If you want the OBi PHONE Port to ring instead, remove the {(Mcot):aa} rule.

Dialing 2 **9 200123456 would be trying to dial **9 200123456 using the OBi in India.

skpv

Hello RonR,

This works perfectly. Thanks!

However, with the setting, I am still not able to call Indian obi from the Canadian obi dialling **9xxxxxxxxx. If click on default on obitalk services>InboundcallRoute, calling to Indian obi is fine!





RonR

Shammi/skpv,

I just configured a new OBi (200654321) using:


Voice Services -> OBiTALK Service -> InboundCallRoute:

{(Mcot)>(<*1:>(Msp1)),(Mcot)>(<**1:>(Msp1)):sp1},{(Mcot)>(<*2:>(Msp2)),(Mcot)>(<**2:>(Msp2)):sp2},
{(Mcot)>(<1234567,,,,,,,,,,,,,,,,,,,,*9987654321,,,,,><*8010:>xx.),
(Mcot)>(<1234567,,,,,,,,,,,,,,,,,,,,*9987654321,,,,,><**8010:>xx.):li},
{(Mcot)>(<*8:>(Mli)),(Mcot)>(<**8:>(Mli)):li},{(Mcot)>(<*9:>(Mpp)),(Mcot)>(<**9:>(Mpp)):pp},
{(Mcot)>(Msp2):sp2},{(Mcot):aa},{ph}

User Settings -> User Defined Digit Maps -> User Defined Digit MapX:

Label : cot
DigitMap : (200123456)


Calls originating from 200123456 to this OBi by dialing **9200654321 go to the Auto Attendant unless the {(Mcot):aa} rule is removed in which case they go to the PHONE Port.  Calls from any other OBiTALK number go the PHONE Port.  Everything appears to work exactly as expected.  I even configured it a second time using the OBiTALK Web Portal to make sure there wasn't a problem there and the results were the same.

If all else fails, you might try resetting the OBi to factory defaults and then reconfiguring it.  A user named Riyas had problems on multiple occasions where a correct DigitMap did not behave properly, but did after reverting the OBi to factory defaults and reloading the very same configuration back.

Shammi

Thanks RonR, for all your support, patience and expertise. I would try this too.
Shammi