[Obi100]: StatusBacking Off (3s):TCP connection to 74.125.71.125 failed

Started by MorganF, August 24, 2015, 05:18:09 PM

Previous topic - Next topic

MorganF

Hello,
I have tried to set Google voice with my Obi 100, however I do get the following Error:

Status Backing Off (3s):TCP connection to 74.125.71.125 failed

I have tried resetting the obi to factory settings, changing the DNS. it didn't work.
Here follows the configuration:



SteveInWA

1)  When did you try this?  The OBiTALK portal was down over the weekend, and returned to service sometime this morning, however, sporadic issues might still be present.  Try it again now, and see what happens.

2) How did you try to set up Google Voice on your device?   Did you add your 100 to the OBiTALK portal, and then follow the steps on the portal to configure Google Voice on it?  This cannot be performed via the device's local web page.

3) Did it work before, and now it's broken, or is this the first time you've tried it?

The_Eggman

This is happening to me too. I noticed it yesterday for the first time. My OBi110 just stopped connecting, keeps "backing off". It was working fine behind my IPCop firewall, nothing has changed on my end. I put the OBi in the DMZ, and it still won't connect.

1)  When did you try this?  The OBiTALK portal was down over the weekend, and returned to service sometime this morning, however, sporadic issues might still be present.  Try it again now, and see what happens.

This is happening now. I am logged into OBiTalk and my device keeps "backing off".

2) How did you try to set up Google Voice on your device?   Did you add your 100 to the OBiTALK portal, and then follow the steps on the portal to configure Google Voice on it?  This cannot be performed via the device's local web page.

I re-created the main account using the OBiTalk portal. I've been using an OBi for a while now with GV, so I am pretty familiar with how to do it.

3) Did it work before, and now it's broken, or is this the first time you've tried it?

I've had a couple working devices. This OBi110 was working fine and just stopped connecting.
[/quote]

P.S. I have two GV accounts configured in the Obi, and they both stopped working. I tried re-creating the main account a couple times and left the secondary alone, but no dice.

drgeoff

@The_Eggman

Are you following SteveInWA's instructions?  The old method of just inputting your google name and password no longer works.

The_Eggman

It was working just fine a few days ago and nothing has changed, so I'd be pleasantly surprised if it's just something wrong with the config, but it's worth a go.

SteveInWA has lots of instructions. Got a link?


The_Eggman

It was setup properly and working fine in the last few days, but I deleted both GV accounts, restarted the device and followed Steve's instructions. After setting up the primary GV service, the OBi is still backing off. The device is in the DMZ, and I can connect to and configure it using the OBiTalk portal. What am I missing?

P.S. I tried deleting OBiTalk's GV access from my GV settings, and then allowing that access to be recreated during the OBiTalk portal setup process. After deleting the GV account, restarting and following Steve's instructions again, the device is still not connecting to Google.

SteveInWA

Log onto your Google Voice accounts from a web browser, and go to this page:

https://www.google.com/voice/#phones

Take a screenshot, black out all personal information except for the last 4 digits of your phone numbers, and post the screenshots here.


SteveInWA

Thanks for the speedy reply!

That looks normal to me.  Ignoring the old method of authentication to Google Voice, the "backing off" issue is usually caused by a network problem on the user's end.  You should never need to put an OBi in a DMZ.  I'm not familiar with your firewall, and I would suspect something's not configured correctly.  Can you take the OBi to some other location (friend or family's house, etc.) to test it?  That would easily eliminate your network as a possible issue.  Is is safe to assume that you are currently located within the USA?

I have some time today, if you are interested:  I have an idle OBi 110 that I could configure with one of your GV accounts, if you want to contact me privately, to further isolate the problem.  Aside from that, I don't have any brilliant troubleshooting suggestions.

The_Eggman

Agreed. I shouldn't have to put it in the DMZ. I only did that for troubleshooting. I had it working fine with just the recommended port access behind the firewall. The DMZ should have removed many of the user-end network concerns. Something else seems to have changed. I thought of the same thing you did, but the other locations to which I have ready access also have an IPCop firewall. I will see what I can do. If I can't resolve, I will take you up on your offer.

The_Eggman

You were right Steve. IPCop + Copfilter includes a robust proxy, antivirus, antispam, url filter, etc services. I had the OBi working behind it previously and I had rebooted the firewall probably a dozen times today, but I had never shut down the extra services while it was running because I thought the DMZ would bypass all that. I shut them all off at once because I was going to restart the services one by one to find the offender. As soon as I shut them off, the OBi started working again. I turned them all back on in an orderly fashion, but the OBi didn't disconnect. I'm not really sure what did it, but once I started them all again manually, the OBi kept working and I'm able to place calls again. Now to put it back behind the firewall and hope it still works. Thanks for the advice!

SteveInWA

Great!  I'm glad you got it working, even if the specific issue with the security system isn't clear yet.  Thanks for the feedback.

The_Eggman

Backs off when I put it behind the firewall. If I'm running a transparent proxy on port 8080, do I need to configure anything special in the OBi?

SteveInWA

I don't have any experience trying to make Google Chat (XMPP) work through a proxy.  I wouldn't be surprised if it failed, though.

It doesn't answer your question regarding proxy use, but here are the ports used by XMPP and by Hangouts:

https://support.google.com/a/answer/1279090?hl=en

The_Eggman

Reconfiguration shouldn't be required given that it's a transparent proxy, but I don't think that's necessary.

I went through the same service shutdown process with it connected behind the firewall and the OBi started working again. It wasn't until I shut down the firewall's monitoring service that it re-connected, but that may be coincidence. My working theory is there is some sort of log that gets reset when I shut the services down that way that doesn't happen when I reboot the server.