My fax no longer completes connection - FIXED!!!!

Started by Agent88, November 07, 2015, 01:12:19 PM

Previous topic - Next topic

Agent88

I haven't used my fax in a while so I don't know when the issue developed, but I suspect an upgrade. >:(   I have my fax connected to my Obi202 from Phone port 2.  When attempting to fax, the receiving fax begins the handshake but then the line hangs up (goes to dial tone).  My call log shows each fax attempt to last 3 seconds.  It worked fine last year at this time, but sometime in the interim something happened and I can't figure it out.

I can't find instructions on how to properly configure the fax settings.  I can see that my Obi202 is configured to enable T38 codec, but there is also a setting labeled "FaxPassThru" set to G711u.  Do I set one or the other?  It doesn't seem likely that both should be checked.

edit:  1)I went to my device web page, logged in, and selected Codecs from the left nav window. 2) I deselected the default settings for T38Enable, T38Redundancy, and T38ECM.  I also unchecked the T38 Enable box, then submitted, re-booted, refreshed and checked to see that the changes were made.

Note: I left the FaxPassThrough codec set at G711u.

I will post my results after sending a test fax.

Result:  NOPE.  Still same-o, same-o.  Anybody have a suggestion?

LTN1

There can be potentially a number of reasons why your fax with GV (assuming you are using GV) and the OBi could not be working well.

1. The GV connection at a particular time may not be clear.
2. Your ISP connection may have issues not readily apparent. See http://www.voipmechanic.com/mos-mean-opinion-score.htm
3. The receiving fax line may have connection issues, especially if the receiving number is also a VoIP line.
4. Always a possibility...you may have unknowingly changed settings in the OBi such that it may be causing problems. If this is the case...or you don't know how to restore it to the original configurations, best to factory reset the device and add your accounts in again.

For me, it is often 1 and 2 when I do have problems with faxing using my GV and OBi. If you think it is 3, try faxing to another fax number to see if it can go through. Try this toll free fax test number (855-330-1239) and you can go here to view your test page after a few minutes: http://faxtoy.net/  If you still need another number, you can use one of mine at 206-208-5682.

Agent88

1) I am not using GV for this situation, my Voip line is via Anveo, and it is clear.  Furthermore, this has been an unresolved issue for over a month.
2) No issues with Anveo.  Voice calls are good.  Fax tones are clear.  Receiving fax answers, just does not stay connected long enough to complete the transaction.
3) Issue remains with any fax number or machine I call.  All faxes resolve to the same issue.
4) No change(s) made to OBi202 until today (after I tried everything else under the sun).  I have now upgraded my firmware, but this cannot explain the issue from back in September.  I did upgrade my router about six months ago.  You may have uncovered the problem for me... if it is in the router.
5) Thanks

Agent88

Continuing the saga:
I restored my T.38 settings since disabling them did not help.  On the outside chance that a swap of routers may have been the cause, I researched the SIP ALG issue and found that the new Pace router installed by ATT U-verse has SIP ALG enabled by default with no provision to disable it from the web interface.  I then tried the work-around in the OBiFAQ by disabling the "X_DiscoverPublicAddress" for the Service Provider.  Problem is, that no matter what I do, when I reboot the OBi device, it re-enables it.  It won't remain disabled.

Now what?

LTN1

#4
How are you disabling it? Are you going through the "Enter OBi Expert" from the OBiTalk web site or is it being done locally?

If you can take a screen shot of what you are doing and attach it, perhaps I and others more qualified than me can be in a better position to help you troubleshoot this.

drgeoff

#5
If your voice calls are working fine then I very much doubt that fiddling with SIP ALG or X_DiscoverPublicAddress will rectify the fax failures.  Those usually address problems of no audio or audio in one direction only.

The usual recommendations for fax over VoIP are to configure the fax machine to lower the baud rate to 9600 and turn off (yes 'off') error correction.  If that is successful, try increasing the baud rate in steps until failure reoccurs and then back-off.

http://www.voipmechanic.com/faxingissuesandotherdevices.htm

Agent88

#6
drgeoff:  Thank you for confirming what I guessed about SIP ALG.  I have adjusted the fax baud rate to no avail, it does not affect the issue.  (edit: followed your link to voipmechanic... didn't know about "overseas connection".  Set it to ON and will see if this helps.)  (edit:  NO, overseas set to ON does not help)

To all: I do my "fiddling" through the web interface of the device.  So far, all I get is screeching. :(

Let me be clear.... the receiving fax answers and they begin handshaking.... the problem is the handshaking stops and disconnects after 3 seconds.  My error report says "Busy/No Response" which the book says try again (which is no help).  I had the manufacturer (Brother)) tech support try to help, but they claim the problem is with the Voip provider, not the fax.  Anveo will not help.  I figure it is the settings with either Anveo or Obihai.  I need to know whether or not my OBi202 is configured properly.  Keep in mind that everything worked for several years until just this last several months.  I made no changes to equipment other than dropping ATT DSL for U-verse, which meant a new gateway router/modem. 

Agent88

@LTN1:.... I have the "X_DiscoverPublicAddress" set to the default values.  Attempts to change this only result in push back from the OBi202 to restore it to default.  IOW, it will not allow anything other than default.


Agent88

#8
To be clear about my setup:  My Brother MFC8660DN line port is connected to the Phone2 port of my OBi202.  The Obi202 is connected by Ethernet to my LAN. (Phone1 port goes to an analog desk phone).  My Voip account at Anveo has a primary account configured to my Cisco IP phone, and the secondary account configured to my Obi202.  The OBi202 is configured for SP1 to be Anveo.  No other SPs involved.  SP1 is set for line ports 1 and 2.  This has not changed, having worked like this for several years.

I do not know if the router/modem gateway swap from 2Wire to Pace caused the problem, or some other upgrade that I am not aware of. 

Brother tech support checked my fax settings and found nothing wrong with it.  They claim they received my fax, but no other fax machine I have tried will connect long enough to get the document I am attempting to send.  I sell insurance products and must have the ability to send applications to various insurance carriers.  None of them any longer will connect.  This is important to resolve as you can understand.

edit:  I tried my other fax (MFC9840CDW) with similar results.  The baud rate setting is at Basic (Voip).  Same-o, same-o.  IOW it is not the fax machine.

In an effort to be thorough, I swapped out the phone cord... no help.  Swapped ports on the OBi202... no help.

LTN1

#9
Quote from: Agent88 on November 08, 2015, 05:46:01 AM
@LTN1:.... I have the "X_DiscoverPublicAddress" set to the default values.  Attempts to change this only result in push back from the OBi202 to restore it to default.  IOW, it will not allow anything other than default.

The screenshot that you attached shows the current configuration page from your LAN--that is, you are viewing that configuration page from your browser via a local access via your local IP address for the device. Are you attempting to make the changes of unchecking from local access also?

From what I've been told (others have more expertise here like Steve), you need to make the changes after logging into your OBiTalk site--under Expert Configuration and then saving the changes from there. If you make the changes locally via the IP address that appears from the screenshot, you will find that when you reboot, the OBiTalk configuration will reload and change what you have made via local access.

When you have confirmed the changes from your OBiTalk web site under Expert Configuration (the link you have to click to enter it on the OBi site), take another screenshot or two of what you did.

Agent88

Quote from: LTN1 on November 08, 2015, 06:40:41 AM
Quote from: Agent88 on November 08, 2015, 05:46:01 AM
@LTN1:.... I have the "X_DiscoverPublicAddress" set to the default values.  Attempts to change this only result in push back from the OBi202 to restore it to default.  IOW, it will not allow anything other than default.

The screenshot that you attached shows the current configuration page from your LAN--that is, you are viewing that configuration page from your browser via a local access via your local IP address for the device. Are you attempting to make the changes of unchecking from local access also?

From what I've been told (others have more expertise here like Steve), you need to make the changes after logging into your OBiTalk site--under Expert Configuration and then saving the changes from there. If you make the changes locally via the IP address that appears from the screenshot, you will find that when you reboot, the OBiTalk configuration will reload and change what you have made via local access.

When you have confirmed the changes from your OBiTalk web site under Expert Configuration (the link you have to click to enter it on the OBi site), take another screenshot or two of what you did.
What you seem to be saying is that configuration changes cannot be made from the device web page interface.  I don't think that is correct, otherwise why have a device web page interface?

Agent88

#11
I compared my OBi202 configuration that is displayed through the web page interface with the service provider configuration for my Cisco IP phone.   Shouldn't the ports and other settings be the same for the same ITSP?  I noticed that OBi has port 5060 set for the proxy server, whereas Cisco has 5010 for it.  Anveo says use 5010, so that's what I put in the Cisco phone and it works, so I changed the OBi202 to match.  However, nothing seems to have changed.  I still have communication, just that my fax still hangs up as soon as the receiving fax says hello.  (edit:  Besides... it worked with OBi202 wizard setup configuration and I was able to fax for the last several years.  I keep harping on that point, because SOMETHING changed recently to prevent fax completion.  I just can't seem to find out what it was.)

SteveInWA

Quote from: Agent88 on November 08, 2015, 01:40:55 PM
Quote from: LTN1 on November 08, 2015, 06:40:41 AM
Quote from: Agent88 on November 08, 2015, 05:46:01 AM
@LTN1:.... I have the "X_DiscoverPublicAddress" set to the default values.  Attempts to change this only result in push back from the OBi202 to restore it to default.  IOW, it will not allow anything other than default.

The screenshot that you attached shows the current configuration page from your LAN--that is, you are viewing that configuration page from your browser via a local access via your local IP address for the device. Are you attempting to make the changes of unchecking from local access also?

From what I've been told (others have more expertise here like Steve), you need to make the changes after logging into your OBiTalk site--under Expert Configuration and then saving the changes from there. If you make the changes locally via the IP address that appears from the screenshot, you will find that when you reboot, the OBiTalk configuration will reload and change what you have made via local access.

When you have confirmed the changes from your OBiTalk web site under Expert Configuration (the link you have to click to enter it on the OBi site), take another screenshot or two of what you did.
What you seem to be saying is that configuration changes cannot be made from the device web page interface.  I don't think that is correct, otherwise why have a device web page interface?

OBi devices are designed for remote or centralized management via the OBiTALK portal.  By default, the portal controls the configuration of your device.  Every time the device reboots, it will check its configuration with the portal, and update it to match the portal if necessary.  The device's own embedded web server-generated configuration pages are an optional way to configure the device.  To make a change to a specific parameter on the local web page, you need to remove the check mark(s) from the "Default" column, to the right of the value you want to change, on the OBiTALK portal page in Expert mode.  Otherwise, the OBiTALK portal will just overwrite it on the device again.

SteveInWA

With regard to faxing, I realize you keep pointing out that it used to work and now it doesn't.  Nobody here knows why that is the case.  Faxing over VoIP is never going to be as reliable as using a traditional POTS line.  Sometimes, VoIP providers change the "transit" carriers they use to route calls, and the quality of the connection no longer is sufficient to support faxing.  That's just one example.

Drgeoff pointed you to some tips.  He specifically emphasized that you need to turn off ECM (error correction mode).  This seems counter-intuitive, since error correction sounds like a "good thing".  The problem is, it's only a good thing for traditional circuit-switched (POTS) telephony.  It identifies failures by the receiving end to receive error-free transmissions.  If it detects an error, it tells the sending end to re-transmit.  This can create a mess with VoIP, which results in endlessly re-transmitting the same packets over and over until it gives up.  Also, as he pointed out, try reducing the data rate on the fax machine.  9600bps is the maximum that is likely to work over VoIP, and 4800bps is more reliable.  Both the data rate and ECM mode are settings on your fax machine, not on the OBi.

The one thing you can try to change on the OBi device, using its Expert configuration mode, is to change your CODEC profile to only use the G.711 CODECs, and no others.  G.711 is a lossless CODEC that works best with faxing, however, it does require a high-quality internet connection (from your own internet service provider).

What if this doesn't help?  Here are two other options:

Get a Google Voice phone number.  Google has significantly improved its VoIP network over the years, and it is often more reliable for fax than other providers.

or...

Join the 21st century.  Don't use your fax machine.  Instead, scan your documents and email them as PDFs, or use a fax service provider that can fax the PDFs for you.  Get a fax mailbox from the service provider of your choice, to receive inbound faxes, which are then converted to PDFs that can be downloaded or emailed.  I don't know if Anveo offers them, but Callcentric does. 

Agent88

1)I have no access to the Expert mode from my OBiTalk portal. (see my screenshots in the thread about OBiFAQ issue)

2)When attempting to make configuration changes, I do uncheck the default box. (Then submit/reboot/refresh)

3)If the device web interface will not allow configuration changes, then OBihai needs to make that clear.  I cannot see the reason to have a web page interface if it can't be used.

SteveInWA

Go see drgeoff's screenshot in your other thread.  It's right there, at the bottom of the page.  Click the blue button.

SteveInWA

Quote from: Agent88 on November 08, 2015, 02:48:02 PM

2)When attempting to make configuration changes, I do uncheck the default box. (Then submit/reboot/refresh)

Again, you need to uncheck the two boxes on the OBiTALK configuration page, in Expert mode.

LTN1

Quote from: SteveInWA on November 08, 2015, 02:51:42 PM
Quote from: Agent88 on November 08, 2015, 02:48:02 PM

2)When attempting to make configuration changes, I do uncheck the default box. (Then submit/reboot/refresh)

Again, you need to uncheck the two boxes on the OBiTALK configuration page, in Expert mode.

For some reason he's not getting the fact that he needs to go to the OBiTALK site to make the configurations by entering Expert Configuration, etc. I don't know how many times people have to repeat similar suggestions.

The energy is being wasted in blaming Obihai for this and that...reminiscent of one other thread in the recent past. PEBKAC indeed.

drgeoff

#18
Quote from: Agent88 on November 08, 2015, 02:48:02 PM
3)If the device web interface will not allow configuration changes, then OBihai needs to make that clear.  I cannot see the reason to have a web page interface if it can't be used.
The web interface does allow configuration changes but they will be overwritten by whatever is current on the portal unless you disable Obitalk provisioning or do exactly what SteveInWA has told you.  Please read the sticky post http://www.obitalk.com/forum/index.php?topic=61.0

Agent88

Quote from: LTN1 on November 08, 2015, 03:08:00 PM
Quote from: SteveInWA on November 08, 2015, 02:51:42 PM
Quote from: Agent88 on November 08, 2015, 02:48:02 PM

2)When attempting to make configuration changes, I do uncheck the default box. (Then submit/reboot/refresh)

Again, you need to uncheck the two boxes on the OBiTALK configuration page, in Expert mode.

For some reason he's not getting the fact that he needs to go to the OBiTALK site to make the configurations by entering Expert Configuration, etc. I don't know how many times people have to repeat similar suggestions.

The energy is being wasted in blaming Obihai for this and that...reminiscent of one other thread in the recent past. PEBKAC indeed.

You know... you guys don't get it.  A lot of us do not frequent the OBiTalk interface often.  This is a good testimony to the reliable operation of OBihai devices.  However, when we do have a problem, the instructions are not clear.

Take for example this thread.  I wasted a full day just to learn that the OBiTalk configurator overrode whatever settings I put into the device web interface.

Secondly, that I was to scroll down below the fold to find the "OBi Expert Configuration" button.  This description is not intuitive... I thought this button was for setup and ran an auto configuration so I overlooked it.  The aforementioned instructions omit this step.  When selected, an ominous pop-up challenges you "Do you REALLY want to do this?... as if something might happen to screw things up.

Thirdly, when I eventually selected it, I was presented with numerous options, among which was ANOTHER button to enter the OBi Expert.  ??? Is all this necessary?

User feedback should be appreciated instead of denigrated.  If you don't want complaints, fix the stupid instructions.... Pardon me... fix the instructions so that they are clear.