December 11, 2017, 10:39:08 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: Star codes and phonepower  (Read 6927 times)
2ooarmz
Jr. Member
**
Posts: 31



« on: May 22, 2016, 08:54:17 pm »

My star codes with Phonepower are not working, why not? 

I recently purchased my obi202 to work with my phonepower.com service and I just realized that the star codes (*21 to access VM; *78 Do Not Disturb; etc.) are no longer working. 

I previously had a Grandstream device and had to change a setting to allow the star codes; if I have to do that with this Obi, how do I do it?
Thanks!
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #1 on: May 23, 2016, 02:47:54 am »

Iím assuming that Phonepower is set up on sp1 and that sp1 is your Primary Line. Add the codes to the beginning of this digitmap like so:

Service Providers > ITSP Profile A > General > DigitMap:
(*21|*78|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

If that works, then great! If not, then you will need to delete your OBiís internal Star Codes that may be intercepting the same digits.

Make changes via the OBi Expert Configuration pages. From your OBi Dashboard, click on your OBi number and follow the prompts to get there. To change a value uncheck both boxes to the right of the value and leave them unchecked. After changing the values on one page, press submit at the bottom of the page and wait a few minutes for the OBi to reboot.
Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #2 on: May 25, 2016, 09:20:04 pm »

Thank you for your reply!

Well, at first, I tried the the code you provided, but that didn't seem to work; and there is a red exclamation point at the end of the box. (Both check boxes are unchecked.)

Then I unchecked ALL the 2-digit code boxes, both columns, from the OBiís internal Star Codes, both profiles A & B.

Those settings (the unchecked star codes & the code you provided--complete with the red exclamation point) are how it stands now.

About a half hour after I made those changes, I tried both the *78 and *79 and now I get a voice saying "Sorry, your request cannot be accepted."
What?
Now what?
Thanks!
P.S.  I tried both the *78 and *79 several times with the same results.
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #3 on: May 26, 2016, 02:35:30 am »

That announcement does not sound like it's coming from your OBi. We need to know what is being sent to Phonepower to find where the problem is.

To see whatís happening you need to look at Status > Call History after a call. This can only be viewed via the local web page. Dial ***1 for the local ip address. Put the address in your browser. The username and password will both be ďadminĒ.

If Call History shows that *78 and *79 are being sent to Phonepower, then you will need to check with them to ask why those codes are not working.

Don't worry about the red exclamation marks, I have loads of them! If you really want, then I will send a long and boring explanation of what they mean   Smiley
Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #4 on: May 26, 2016, 01:53:53 pm »

Okay, so, all the attempted *78 & *79 calls look like the two shown below.  I can't  tell if they made it to Phonepower.com or not.  Although, the 2 calls shown under the dashed line were connected properly--even though they do not specifically show Phonepower either.

I emailed Phonepower last night; here (in blue) is what they said to me about this issue.  (I wasn't sure how to enter my SIP credentials, so I entered my username/password in the boxes of the same name on the Auto Provisioning page, via Obi's local web page.)
Phonepower's reply to me:
If you are not able to set *78 and *79. Please try factory resetting the device and add the SIP Credentials back on the device again.  If you still have issues, please contact Obihai as they should be able to help with star codes for the Obi adapter.
My email request to Phonepower:
Hello, The star codes *78 and *79 have stopped working, instead, we get a voice saying "Sorry, your request cannot be accepted."  We recently purchased an Obihai 202 and it is provisioned---it's just that the star codes are not working.  Can you fix this?  Thanks!


So, what's next?  How else can we try to fix the star code issues?

Call History:
Call 9   05/25/2016    21:55:01   
21:55:01   From PH1   To SP1(*78)
21:55:02      Call Connected
21:55:05      Call Ended

Call 10   05/25/2016    21:47:11   
21:47:11   From PH1   To SP1(*79)
21:47:12      Call Connected
21:47:15      Call Ended
==================================================
Call 6   05/25/2016    23:54:32   
23:54:32   From PH1   To SP1(*21) << my PhonePwr VM starCode.
23:54:33      Call Connected
23:54:37      Call Ended   
^^^^ This star code works fine.

Call 28   05/23/2016    12:46:33   
12:46:33   From PH1   To SP1(xxxxxxx) << my mom.
12:46:35      Ringing
12:46:44      Call Connected
13:34:39      Call Ended
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #5 on: May 27, 2016, 01:07:44 am »

Your Call History clearly shows that *78 and *79 are being sent to Phonepower. The problem is with them. Looking at their website, I see this info:

Code  Action taken 
*21  Used to access the VoiceMail 
*60  Selective Call Rejection IVR 
*62  Activates the Call Forwarding Busy Feature 
*63  Deactivates the Call Forwarding Busy Feature 
*67  Blocks caller id on one outgoing call 
*69  Activates the call return feature 
*70  Deactivates Call Waiting on One Outgoing Call 
*72  Activates the call forwarding feature 
*73  Deactivates the call forwarding feature 
*77  Activate Anonymous call rejection 

*78  Activates the do not disturb feature
***Can not be used with the Softphone***
 
*79  Deactivates the do not disturb feature
***Can not be used with the Softphone***
 
*82  Unblocks caller id on one outgoing call 
*83  Selective Call Forwarding IVR 
*87  Disables Anonymous Call Rejection 
*92  Activates the call forwarding no answer feature 
*93  Deactivates the call forwarding no answer feature 


It looks like they do treat *78 and *79 differently to other Star Codes. Maybe their servers are confusing your setup with a softphone? I don't know anything about Phonepower, so maybe any other users here can add some info.

As you have deactivated all the OBi Star Codes, if you wish to use the full range of Phonepower Star Codes, then you could change your config to this

Service Providers > ITSP Profile A > General > DigitMap:
(*xx|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

This enables a string of * followed by any two digits to be sent to sp1. Assumes that sp1 is your Primary Line.
Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #6 on: May 27, 2016, 09:33:51 am »

Well, that code, (the *xx| prefix), didn't work.  In fact, the only that is working --- and by 'working', I mean, getting that voice saying "Sorry, your request cannot be accepted." --- is by using the *78|*79| prefix code, along with deleting OBiís internal Star Codes.

Setting things any other way only results in a fast busy signal sound (FBSS). Meaning: the FBSS is what is heard upon dialing *78.  And it is the only thing that is heard after that...each time we pick up the receiver. 
In order to stop the FBSS, you have to dial *79.

In any case, I have an email in to Phonepower, hopefully this time, they will do some research and have a solution.

In the meantime, maybe someone else here, as you suggested, will have some insights.

(BTW, I consider it "working" because at least the call is being sent to Phonepower.  And speaking of calls being sent to Phonepower, how do you know that the calls in my call log made it to Phonepower?  Is it simply the "call connected" line?)
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #7 on: May 27, 2016, 10:15:48 am »

21:55:01   From PH1   To SP1(*78)

The string inside the parentheses *78 is recorded by the OBi as being sent out to SP1. The fact that the call is shown as connected means that the OBI has received a "200 OK" message from the voip provider's server. This is a standard SIP message indicating that the call has been answered by the called party. Also, you received an announcement from Phonepower.

As you can see Call History records exactly the same information when you send *21, which works correctly.

As I say, I know nothing about Phonepower, but many voip providers give you access on their web site to your call logs so that you can see what numbers you have called.

I can see no obvious reason why *xx does not work for you. In case the OBi is still trying to intercept the Star Codes, you can switch off the OBi Star Codes completely for Phone Port1 here:
Physical Interfaces > PHONE Port 1 > Calling Features > StarCodeProfile: None

« Last Edit: May 27, 2016, 10:18:36 am by ianobi » Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #8 on: May 27, 2016, 10:32:57 am »

So, it must be a Phonepower issue because I just entered the code to switch off the OBi Star Codes and still I get that voice telling me the same thing she always tells me.  Angry

Well, we'll see what Phonepower has to say.
Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #9 on: May 27, 2016, 02:20:27 pm »

Phonepower answered me--see below.  Given their answer, I put everything back to the ObiTalk settings--which seemed like to correct thing to do.

But still no joy!
I just dialed *78, heard that fast busy signal sound (FBSS) {is that supposed to mean that DND has been activated??},
hung up & called my number, hoping it would be in DND mode, but no, our phone rang!  Angry

So, based on what Phonepower just emailed me, what should I try now?

By the way, when Phonepower did their test, today, the Obi settings were not in the ObiTalk settings--I only just changed them back to the ObiTalk settings.  So would that have affected their test?

Phonepower email to me:
We tested your account on an in house tested device and DND works ok

When you dial *78 or *79, these star codes should not be transmitted to us, the should just toggle the phone adapter's  DND feature

Login the management interface of your obi device and check if you have the star codes active under the profile phone power is using

Example: Phonepower using ITSP Profile A General

1. Login obitalk

2. Click the settings icon of the obi device you are using with phonepower

3. Enter expert mode

4.  On the left Menu under Star Codes, Select "Star Code Profile A"

5.  Assuming we are using Code17 and Code18
 Code17  should have a value  *78, Do Not Disturb, set($Dnd,1)
 Code18  should have a value  *78, Do Not Disturb, set($Dnd,0)

Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #10 on: May 27, 2016, 02:47:16 pm »

Phonepower answered me--see below.  Given their answer, I put everything back to the ObiTalk settings--which seemed like to correct thing to do.

My mistake...actually, I changed code 18 to both:
*78, Do Not Disturb, set($Dnd,0)
and
*79, Do Not Disturb, set($Dnd,0)

I tried one then the other, with both check boxes unchecked each time, but it didn't matter  -- our line doesn't get put into DND mode--people can still call us.
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #11 on: May 28, 2016, 03:14:18 am »

Ok, so know we know a lot more. Star Codes should be sent to Phonepower except for *78 and *79. DND is not a feature I use, so I have done some testing today and now see how it works. Sorry for my slowness getting to this point.

Make sure only *21 is sent to Phonepower by setting this:

Service Providers > ITSP Profile A > General > DigitMap:
(*21|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)



*78 sets DND. This should show a check mark in this box:

Voice Services > SP1 Service > Calling Features > DoNotDisturbEnable

If this is checked when an OBi device receives an incoming call it replies with the SIP message ď486 Busy HereĒ. The calling party then gets a busy signal.

*79 unsets DND. This should show as no check mark in this box:

Voice Services > SP1 Service > Calling Features > DoNotDisturbEnable


Please ensure that this is set:
Physical Interfaces > PHONE Port 1 > Calling Features > StarCodeProfile: A

Also check that these are correct:
Code17  *78, Do Not Disturb, set($Dnd,1)
Code18  *79, Disable DND, set($Dnd,0)


With me it works fine with an OBi110 and an OBi1032. I get no change in dial tone after setting DND, so I cannot say where your fast busy is coming from. Itís normally an indication that the OBi has not accepted whatever digits you have dialled.

Please try setting DND and checking what shows here:
Voice Services > SP1 Service > Calling Features > DoNotDisturbEnable

Then unset and check it unsets correctly.

« Last Edit: May 28, 2016, 03:16:58 am by ianobi » Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #12 on: May 28, 2016, 02:08:29 pm »

Good grief, still no joy!  The star codes are a screwed up mess! Angry

Here (the image) is how my settings are set ... the settings that I changed, or put back, as the case may be.  In other words, the only item that is not in its original state is the DigitMap code.

I dialed *78 and as usual, immediately heard that fast busy signal sound.  Nevertheless, I dialed our number and the phone rang! 
~~ (I was so hoping that I would hear whatever a caller is supposed to hear when the person being called has their phone in DND mode.  But no, not only did the phone ring, it was answered [someone else here answered it, just to be sure that a real phone conversation could take place.)

I also dialed *79, and yes, heard that busy signal sound.

With both of those calls, the DoNotDisturbEnable check boxes remained in the unchecked state.
BTW, why are there 3 check boxes and which one should be checked?


Here is the call log showing those calls:
Call 1   05/28/2016    11:25:09   
11:25:09   From 'WIRELESS CALLER' SP1(xxxxxxxxx)   To PH1 << The call after the *79 call.
11:25:09      Ringing
11:25:12   Call Ended


Why isn't the *79 call showing on the log? (Call 2 ??)
Oh well.  Like with *78, all I got was the fast beep beep beep.


Call 3   05/28/2016    11:23:23   
11:23:23   From 'WIRELESS CALLER' SP1(xxxxxxxxxx)   To PH1
11:23:23      Ringing
11:23:34      Call Connected
11:23:40   Call Ended


Call 4   05/28/2016    11:19:54   
11:19:54   From PH1   To SP1(*78) << No more voice announcement, just beep beep beep.
11:19:54      Call Connected
11:19:57      Call Ended


I also checked the local web page and the settings there, mostly, matched those on the Obi dot com page.  "Mostly" because the DigitMap had a much longer code, this code:
(**|[3469]11|0|00|1xxxxxxxxxx|<1>[2-9]xxxxxxxxxS0|*21|*53xxxx|*6[027]xx.|[789]2xx.|*73|*74[0-1][0-9]*xxxxxxxxxx|*75[0-1][0-9]|011xx.|xx.|(Mipd)|[^*#]@@.|*21|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)
(Hopefully, I haven't given away any crucial bits of info by showing that code!  Undecided)

[Oh, I recently discovered that *78 & *79 aren't the only ones that don't work. I haven't tried them all, but have tried enough to be confident that the only star code that works is *21

Oh, here's another a fun fact (insert sarcasm here!) ... sometimes, after I dial *78, that fast busy signal remains on the line until I dial *79.   And any incoming calls during that time are immediately forwarded directly to our VM. 
But, if dialing star *79 does not bring back a dial tone, then we have to unplug the device from the wall and re-plug it.

If you haven't already guessed, we're having fun times here!!

Okay, I am my wits end; until there's more for me to try, my thought about star codes is: who needs them?!

Oh, hopefully my image will attach to the message.


* ObiSettings_2016-05-28_9-14-56.png (327.43 KB, 1261x2325 - viewed 261 times.)
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #13 on: May 29, 2016, 03:04:29 am »

Quote
Why isn't the *79 call showing on the log? (Call 2 ??)

*78 and *79 should not be showing in the Call History. They should be intercepted by the OBi202 and used internally for switching DND on and off.


Quote
(**|[3469]11|0|00|1xxxxxxxxxx|<1>[2-9]xxxxxxxxxS0|*21|*53xxxx|*6[027]xx.|[789]2xx.|*73|*74[0-1][0-9]*xxxxxxxxxx|*75[0-1][0-9]|011xx.|xx.|(Mipd)|[^*#]@@.|*21|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

This is a mess! Looks like Phonepower are provisioning their digitmap at every reboot and then the OBi is adding the digitmap I asked you to input.
In the OBi Expert Pages check both boxes next to:
Service Providers > ITSP Profile A > General > DigitMap
Then hit submit. At least then you should only have the Phonepower default digit map.


Quote
With both of those calls, the DoNotDisturbEnable check boxes remained in the unchecked state.
BTW, why are there 3 check boxes and which one should be checked?

My apologies here. I should have said when observing a setting always look at the web page. It will show the exactly how the device is set. DND will only show a change on the web page (left hand box). However, I do not think you will see it as *78 seems to be going out on sp1 instead of being used internally by the OBi202.

Check these on the web page:
Star Code Profile A
Code17  *78, Do Not Disturb, set($Dnd,1)
Code18  *79, Disable DND, set($Dnd,0)


Sorry, running out of ideas here. Short of doing a total reset of your OBi202 and that's a bit scary ...

Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #14 on: May 30, 2016, 12:30:08 am »

Quote
In the OBi Expert Pages check both boxes next to:
Service Providers > ITSP Profile A > General > DigitMap
Then hit submit. At least then you should only have the Phonepower default digit map.

It won't let me check both, just one or the other ('default' or 'Obi').


Quote
This is a mess! Looks like Phonepower are provisioning their digitmap at every reboot and then the OBi is adding the digitmap I asked you to input.

Should I go back in to the local web page and change that "messy" code?  If so, to what?


Quote
Check these on the web page:
Star Code Profile A
Code17  *78, Do Not Disturb, set($Dnd,1)
Code18  *79, Disable DND, set($Dnd,0)

Yes, that is what is entered in the local web page, and in the 'expert' page.


Quote
*78 seems to be going out on sp1 instead of being used internally by the OBi202

Anything else I can do to get *78 to be used internally by OBI?

Then, there's all the other star codes that aren't working.  What to do, what to do...
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #15 on: May 30, 2016, 12:47:47 am »

I don't think I can progress this any further. I can see no reason why your OBi is not using the *78 correctly. Even the "messy" digit map should bar *78 from being routed to sp1.

Your OBi202 is less than twelve months old, so I think you should now try Obihai Tech Support. Fill in a support request here:
http://www.obihai.com/supportTicketFormA

I would state that the main problem is "DND does not work". This is a totally OBi device based function, so they should take an interest.

I would be interested in their reply!
Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #16 on: May 30, 2016, 11:19:37 am »

I just submitted a ticket with them and will keep you posted ... at least as to the final outcome.

In the meantime, I did another *78 dialing test (just because I am ever hopeful Embarrassed )
and I heard the beep beep beep.

Then I hung up and dialed a friend (using the *82 prefix--might as well go for broke!);
I heard the beep beep beep, but I waited...and waited...then, to my surprise, the phone started to ring and it was answered!
So, has it been working all along?  Since I would get the beep beep beep after dialing *78, I figured it was not working---you did too...I think.
But maybe the beep beep beep is just a reminder to me that there is a star code setting on the line.

What do you think?
P.S. Happy Memorial Day!  (You're probably doing something day-appropriate, so we'll 'talk' later on. [We're off to the family BBQ; so I'll be back later on too]).
« Last Edit: May 30, 2016, 11:22:19 am by 2ooarmz » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #17 on: May 31, 2016, 01:11:43 am »

If I dial *78 I simply get returned to dial tone, which is how most Star Codes work. Then I get dial tone the next time I dial. DND should not affect outgoing calls. It only stops callers from calling you. You should be able to make outgoing calls with no problem with DND set to on.

If Call History shows the *78 code being routed to sp1, then I'm sure that DND is not being set.

Quote
P.S. Happy Memorial Day!  (You're probably doing something day-appropriate, so we'll 'talk' later on. [We're off to the family BBQ; so I'll be back later on too]).

Thanks for the kind wishes. Actually, I live in the UK, so we have a different set of days off. We called yesterday "Spring Bank Holiday", which is a day off for most people. The sun shone - not always the case here - so a good time was had by all!
Logged
restamp
Full Member
***
Posts: 193


« Reply #18 on: May 31, 2016, 11:24:16 am »

FWIW, on my OBi202, after I enter *78 I hear a slow stuttered dialtone for as long as DND remains in effect.  The stuttering is about half the frequency of the more conventional stuttered dialtone that informs you you have a message waiting.
Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #19 on: May 31, 2016, 08:14:17 pm »

Quote
FWIW, on my OBi202, after I enter *78 I hear a slow stuttered dialtone for as long as DND remains in effect.  The stuttering is about half the frequency of the more conventional stuttered dialtone that informs you you have a message waiting.

Thanks for sharing restamp!  Ours is a beep beep beep... not at all like a dial tone, slow or otherwise.  And as long as it's beeping (5 minutes later, 2 hours later), we cannot dial out.  The only way to get our dial tone back is to unplug it & re-plug it. (*79 does not work.)
At any rate, we're waiting to hear from Obi.


Thanks ianobi for telling me how your *78 works---wish mine did!  (BTW, our Memorial Day is like your Remembrance Day--I think.  I like the red poppies!  Your Spring Bank Holiday sounds like our Labor Day.)

Alright, TTFN
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC