December 17, 2017, 07:15:32 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Help with echoes and disconnects.  (Read 5318 times)
2ooarmz
Jr. Member
**
Posts: 31



« on: June 08, 2016, 06:42:07 pm »

We have a new Obi202 that we use with our phonepower.com VOIP.  We've been having other issues, but this issue, hopefully may be an easier fix.

1. So, how can I reduce, or eliminate echoes? 
2. How can I prevent unexpected disconnects.?

1. The echo is mostly very faint and far away sounding; but when I dial a particular number the echo is more noticeable.  And the person at the other end of the line complains that I sound like I'm underwater.

2. During calls, to this same particular number, the call disconnects after about 25-30 minutes---for no apparent reason. 
I wonder if the person I'm calling is the one with the problem line because I had these same issues, calling this same person, with our Grandstream device.
At any rate, is there a setting (or code) that would reduce/eliminate disconnects ?

Thanks!
Logged
Taoman
Hero Member
*****
Posts: 945


« Reply #1 on: June 08, 2016, 08:35:24 pm »

It's hard to say where the problem is but I doubt it is your OBi device. Do you have any other VoIP providers configured on your device? Like Google Voice? If so, do you have similar problems using that line?

I would suggest you download the Phonepower softphone and install it on your computer. Make the same calls with the softphone and see if you get the same or different results than when using your OBi.

I had a PhonePower subscription for a year but I rarely used it (except for E911) because I thought the call quality was inferior when forwarding from GV. I know a lot of people use and like PP but I find providers like VoIP.ms or Callcentric or even Google Voice have more consistently good call quality than PP. But that was only my personal experience and I was forwarding calls from Google Voice. Others may disagree.

Edit: When you get the disconnects are you also losing registration? You may wish to try changing your X_UserAgentPort to 12060. If I remember right, my connection to PP was more stable after making this port change.
« Last Edit: June 08, 2016, 08:44:47 pm by Taoman » Logged
Lavarock7
Sr. Member
****
Posts: 481



« Reply #2 on: June 09, 2016, 12:58:44 pm »

Recently I have spoken with two people and had echos. They were using Bluetooth headsets and when turned off, the problem disappeared.

Probably not your problem but worth asking.
Logged

My websites: Kona Coffee: http://ItsKona.Com and Web Hosting: http://PlanetAloha.Info
A simplified Voip explanation: http://voip.planet-aloha.com
2ooarmz
Jr. Member
**
Posts: 31



« Reply #3 on: June 10, 2016, 12:10:22 am »

Thank you Taoman & Lavarock7 for your responses!

@Taoman
I don't have any other VOIPs. 
I can't use the softphone (no microphone). 
I don't lose registration with disconnects; I'll see about changing the X_UserAgentPort though; couldn't hurt--could it?

I thought there was a setting that could be changed that affects echoes; I just don't know where it is, or what to input, if there is such a setting.

@Lavarock7
Good thought; but no, don't have Bluetooth (prefer white teeth! Grin )
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2737


« Reply #4 on: June 10, 2016, 12:51:43 am »

I interpreted Lavarock7's post as meaning that the Bluetooth devices were in use, not by him, but at the other end of those calls with echo.
Logged
Lavarock7
Sr. Member
****
Posts: 481



« Reply #5 on: June 10, 2016, 11:46:38 am »

Yes, I meant bluetooth on the far side. Still, probably not the problem but just thought I'd throw it in. In analog phones, I seem to remember that echo was caused by mismatched impedance.
Logged

My websites: Kona Coffee: http://ItsKona.Com and Web Hosting: http://PlanetAloha.Info
A simplified Voip explanation: http://voip.planet-aloha.com
2ooarmz
Jr. Member
**
Posts: 31



« Reply #6 on: June 10, 2016, 08:52:26 pm »

The annoying echo, oddly enough, is just with one particular number, and they do not have Bluetooth.  Any other echoes are very faint; but still, would like to reduce them.

I've been looking online and some say to try lowering your RX and TX values (different sites say they are talking about the ChannelTxGain & the ChannelRxGain).  I don't know though if "lowering" is, for example, changing from
 -2 to -1; or
from -2 to -3.  
There's disagreement here in our household as to which direction I should try (up or down). 

Elsewhere, I found others said that this helped with echoes:
FXO ACImpedance setting of 275+780||115nf and the Tx/Rx gains back to the default settings.
I don't know where to find the "FXO ACImpedance" settings.
« Last Edit: June 10, 2016, 09:00:46 pm by 2ooarmz » Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2737


« Reply #7 on: June 11, 2016, 12:24:57 am »

OBi110s have two impedance settings - one for the PHONE port and one for the LINE port.  Your OBi202 does not have a LINE port.

Changing impedance of your OBi PHONE port will have little if any effect on the echo you hear which is coming from the far end.  (But it may affect echo heard by the far end so probably best left at 600 if your phone is intended for use in the USA.) Some of your speech is being sent back to you by such things as poor electrical balance in the 4-wire to 2-wire hybrid in the distant Local Office, poor electrical balance in the 2-wire to 4-wire hybrid in the distant phone or acoustic leakage of received audio into transmitted audio at the far end.  The latter could be due to a poor handset design, a damaged handset or the use of a loudspeaking phone.  All of those things are outside your control.

That the echo is much higher on only some number(s) means that the cause is not at your end and there is nothing you can do to eliminate it.  You can tweak the gain control to attempt a better balance between echo and normal conversation.

Try reducing the ChannelRx gain.  That is the gain that the 202 applies to the signal FROM your phone and thus modifies the level of the signal that is sent to the other end.  Make is more negative.  Try it in small steps, subtracting 1 from the current value there each time.  Your speech will be sent slightly quieter to the far end so it will also be quieter when echoed back to you.  Also, the lower level of your voice heard at the far end will tend to make the person there speak more loudly.  So what you hear is louder wanted and quieter unwanted.

Echo is less apparent when the delay is short.  Do you also notice longer delay on the calls with high echo?
Logged
2ooarmz
Jr. Member
**
Posts: 31



« Reply #8 on: June 12, 2016, 07:54:24 pm »

Thank you drgeoff for the detailed info!

Quote
probably best left at 600
Where exactly is the setting?  (So that I can check if it is at 600)


Quote
subtracting 1 from the current value
I'm terrible at math, especially when it comes to negative numbers  Huh  So, if the setting is at
-2
to subtract from it would be:
-1 ??
or
-3 ??


Quote
Do you also notice longer delay on the calls with high echo?
I'm not sure; but the other person will often talk over me, as if she doesn't know that I am talking.  So maybe she's not hearing me right away.

I'm thinking that it is a problem at her end; especially because, the other day when we talked, there was no echo...it was so nice!!  Anyway, she said that she was on her cell, not her landline.  She still maintains, though, that it must be a problem with my phone because she only hears echoes when she's talking with me.  (She has a regular Verizon landline.)
Logged
Taoman
Hero Member
*****
Posts: 945


« Reply #9 on: June 12, 2016, 10:09:27 pm »


I'm thinking that it is a problem at her end; especially because, the other day when we talked, there was no echo...it was so nice!!  Anyway, she said that she was on her cell, not her landline.  She still maintains, though, that it must be a problem with my phone because she only hears echoes when she's talking with me.  (She has a regular Verizon landline.)

My bet is the problem is Phonepower and the cheaper routes they use. Been there, done that.

Don't know how much effort you want to put into this to find out for sure or not. But if desired you could get a free DID from IPComms and configure it on your OBi. I believe IPComms still gives you 50 minutes of free outbound minutes in addition to the unlimited incoming minutes with the free DID. If you contact support they also let you spoof your outgoing number to whatever your main number is.

http://ipcomms.net/freedid

I bet you a buck if you made/received a call to the same number using IPComms there would no echo and no disconnects. IPComms only uses Tier one routes. You can hear the difference compared to Phonepower on many calls. I have a 90 year old Dad who is very hard of hearing. I will only use my IPComms line when calling him.

PS. You said you had similar problems when calling the same person using a Grandstream ATA. Were you still using Phonepower as your provider when using that adapter? If not, you can forget the IPComms idea.




Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2737


« Reply #10 on: June 13, 2016, 12:53:16 am »

1.  Physical Interfaces, Phone Port, Port Settings, Impedance.

2.  If you subtract 1 from -2 the answer is -3.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC