Obi202 - Phone Not Ringing...sometimes

Started by StudioD, June 13, 2016, 10:41:47 PM

Previous topic - Next topic

StudioD

I have an Obi202 configured with:
SP1 - Callcentric for inbound calls to support CNAM; also for E911 service
SP2 - Google Voice for outbound calls; My GV inbound number is forwarded to Callcentric
PHONE 1: Panasonic cordless phone base
PHONE 2: FAX (Canon MX870 Multifunction printer w/ FAX)

Sometimes my phone has not been ringing on inbound calls.  My Callcentric log shows that the calls were received, though, so GV seems to be forwarding them to that number as expected.  So my phone doesn't ring but the FAX machine lights up as if it's detecting an incoming call.

The prime suspect in my mind is my SP2 setting. It's set to ring incoming calls on Phone 2 but not Phone 1. But since I have GV forwarded to my Callcentric number, I didn't think that should make any difference because the GV number is forwarded, not even ringing, right? (I would have set SP2 to ring *neither* phone on incoming calls, but I think the system makes me send it to at least one).

Can someone help me understand what's causing this?

SteveInWA

The four Service Provider configurations on the OBi (SP1-SP4) are configured independently of the two physical telephone jacks (Phone 1 and Phone 2).

If you only have one inbound service provider set up (Callcentric), then you would need to tell the OBi to ring Phone 1 on inbound calls, or of course, nothing plugged into Phone 1 is ever going to ring.

The correct way to share a fax with a phone on the same physical phone line, is to plug the fax's inbound line jack into the inbound phone line on the OBi (e.g. Phone 1), and plug the phone into the fax's telephone port.  This involves only one physical phone interface on the OBi.  You then configure the OBi to use the Phone 1 port, plug the fax into that port, and configure the fax to deal with ringing the attached phone for voice calls.

The better solution is to get a second inbound phone number from Callcentric.  You can then either forward that DID directly to Callcentric's fax mailbox, and have Callcentric email you the fax as an image file, or configure it as SP3 on the OBi, and route SP3 to ring Phone 2, and plug THAT line into the fax.

StudioD

I should have specified SP1 (Callcentric) is configured to ring both Phones 1 and 2.

I don't really want to plug the phone into the FAX machine, which is really just a multifunction printer that I seldom use for faxing. Sometimes I leave that printer/FAX device turned off, and I've never plugged the home phone into it. Even when I had traditional landline service, I used a wall splitter to give each device its own jack.

Are you telling me that I can't have two devices plugged into my OBi202 -- phone and FAX -- and configure both to use the same SP's?

SteveInWA

#3
You said:
Quote
The prime suspect in my mind is my SP2 setting. It's set to ring incoming calls on Phone 2 but not Phone 1.

and you said:
Quote
SP2 - Google Voice for outbound calls; My GV inbound number is forwarded to Callcentric

Then you said:
Quote
I should have specified SP1 (Callcentric) is configured to ring both Phones 1 and 2.

This is a mess.  You said that you are only using Google Voice for outbound calls, but you contradict yourself by saying it rings on SP2.  That doesn't make sense.  Furthermore, there is no advantage to configuring both Phone 1 and Phone 2 to ring with the same SP.  It accomplishes nothing, and wastes a phone jack.

You can do what you want, but I'm going to describe how it should be configured:

Goals:

  • You want to route inbound calls through Callcentric, on SP1.
  • You want to make outbound calls via Google Voice, on SP2.
  • You want your telephone to work for inbound and outbound calls using those two SPs
  • You have a fax/printer combo that is "seldom used" for faxing.  When it is used, it should operate independently from, and not interfere with, your regular telephone.

Solution:

  • Log onto your Google Voice account on the web, go to this page, https://www.google.com/voice#phones, and ensure that you have a check mark to the left of your Callcentric number, and no checkmark next to Google Chat.
  • Log onto your OBiTALK portal page, go to your OBi202 configuration, and edit SP1.  Set "Incoming calls will ring on" to Phone 1 only.  Do not check-mark "Primary line for outgoing calls"; this SP will be inbound only, except for 911 calls.  Check-mark "Use This Service for Emergency 911 Calls".
  • Edit SP2's configuration.  Check-mark "Primary line for outgoing calls" for both Phone 1 and Phone 2.  SP2 is outbound-only, and it will never ring, because there is no check mark next to Google Chat on Google Voice settings.
  • Get another inbound phone number (DID) from Callcentric.  You can get one of their free NY State numbers.
  • Configure your OBi's SP3 to use that CC DID.
  • Configure SP3 to ring on Phone 2 only.  This will also be an inbound-only SP.
  • Plug a phone cord from the OBi Phone 1 jack into your Panasonic phone base.
  • Plug a different phone cord from the OBi Phone 2 jack into the fax/printer.
  • Grab a beer and congratulate yourself on a technically-elegant solution.


StudioD

It took me a couple of days to get back to this project but thank you for the clear step-by-step instructions, they were very helpful.

I didn't realize we could get more than one free DID number from Callcentric on the same account, and I'd been sharing my phone and fax line for so long with my old landline service that I hadn't even thought about doing it differently with 2 free DID numbers on the OBi, so thanks again for the direction.

It's set up as you recommended and seems to be working correctly now. The only bug I've encountered is one call that just kept ringing and did not go to voicemail, but I haven't been able to reproduce that problem so I'm going to hope it was just a one-time glitch with GV.

Anyway, thanks again.
.


SteveInWA

Quote from: StudioD on June 16, 2016, 08:45:23 AM
It took me a couple of days to get back to this project but thank you for the clear step-by-step instructions, they were very helpful.

I didn't realize we could get more than one free DID number from Callcentric on the same account, and I'd been sharing my phone and fax line for so long with my old landline service that I hadn't even thought about doing it differently with 2 free DID numbers on the OBi, so thanks again for the direction.

It's set up as you recommended and seems to be working correctly now. The only bug I've encountered is one call that just kept ringing and did not go to voicemail, but I haven't been able to reproduce that problem so I'm going to hope it was just a one-time glitch with GV.

Anyway, thanks again.
.



Great!  Thanks for the feedback, and for being willing to try a different approach.  This forum is littered with people who are too stubborn to consider any alternative to whatever way they think things should work.

StudioD

I thought I had resolved this but it turns out my phone still fails to ring on some calls.

This is frustrating because I've missed important calls and never knew the person tried to call until I got a notification for new Google voicemail.

Any further things I can try to solve this?

Taoman

Quote from: StudioD on July 15, 2016, 11:32:12 AM
I thought I had resolved this but it turns out my phone still fails to ring on some calls.


When did this happen? Callcentric had a couple outages yesterday.

https://www.dslreports.com/forum/r30868118-CallCentric-Callcentric-down

This is why I always have a backup route configured on my OBi(s). That way if my primary route goes down the secondary route automatically takes over and I don't even know there's been an outage unless I look at my call logs. One of my (3) backup routes is a free IPComms DID forwarded to a free Anveo account via SIP URI. Very reliable.

Edit: Yesterday, I actually did realize Callcentric was down because my incoming calls no longer had CNAM.

StudioD

It happened today. I checked my Callcentric call log which showed the incoming calls marked as "Medium Probability" as being spam (they're not).

I don't think I have a call treatment set up to block spam calls. Instead, I have simultaneous ringing set up in Callcentric to ring both my phone and NoMoRobo.  I wonder if that 's somehow causing the problem.

Taoman

Quote from: StudioD on July 15, 2016, 02:38:49 PM
It happened today. I checked my Callcentric call log which showed the incoming calls marked as "Medium Probability" as being spam (they're not).

I don't think I have a call treatment set up to block spam calls. Instead, I have simultaneous ringing set up in Callcentric to ring both my phone and NoMoRobo.  I wonder if that 's somehow causing the problem.

Should be easy enough to figure out just by looking at your call logs.

On the line where Spam Probability is Medium, what is listed under the Extension column? Was the call routed to your extension or not?

If you are using Simulring for Nomorobo then every incoming call should have two entries (depending on how you prioritized your call treatments). If the call was blocked by Nomorobo you should see "1 min" under the Duration Total column for the call to your Nomorobo number. Otherwise it would say 0 min.

IMHO, your Nomorobo call treatment should be your very last call treatment and only gets triggered if your incoming call drops thru all other call treatments above it.

I assume you have friends, family, and known good numbers in your CC phone book? And I'll make the further assumption that they are all in the group called General? If so, I would recommend your first call treatment route all calls from anyone in the General group directly to your desired extension.
If you have any "undesirables" in your phone book that you don't want to ring directly to your extension then just put them into a different group. And then perhaps make a call treatment that sends anyone from that group to purgatory.

StudioD

I find the Callcentric site unnecessarily difficult to figure out.

On my Dashboard, where it shows Calls Received, each incoming call is shown twice but it doesn't show whether it was sent to an extension. So when I click on View Complete Report, each incoming call is shown 3 times. One shows the Spam Probability, another one shows it was forwarded to EXT 100, and the third one shows it was forwarded to the NoMoRobo number. 

To answer your question, yes each call shows it was forwarded to EXT 100 but the phone never rang.

As for my call treatments, I only have one set up...
REDIRECT CALL TO: Simultaneous Ringing
1.  Send to my extension;  100 - default extension;  Ring for 25 seconds
     Send to this number;  [NoMoRobo number];  Ring for 25 seconds
2.  Calling Card

I have no idea why there is a mandatory Step 2 entry above where I have to select from Calling Card, Fax or Busy Tone.  All I want to do is simultaneously ring my 'extension' and NoMoRoBo, but the only way to do that is to use this call treatment that requires that other entry about the calling card, etc. I have no idea how to answer that dropdown.

To your final point, I don't have any entries in my CC phone book and it wouldn't have mattered in this case anyway because the callers were an insurance company and a bank, from numbers I would not have known in advance.

SteveInWA

Change the "Ring for" value from 25 seconds to 30 seconds.  Google Voice rings forwarding numbers for approximately 25 seconds (give or take a couple of seconds depending on network varibility).  Your rule could send valid callers to the "Calling card" entry at the 25 second mark.

Also, set up Callcentric voicmail if you haven't already done so.  It's free.  Change the #2 destination from "Calling card" to "Voicemail".

See my screenshot for an example.

StudioD

OK, I changed it to 30 seconds but that probably won't help if it's not ringing at all in the first place, right?

I don't want to set up CC voicemail because my cordless phone base already has a physical answering machine  that I enabled to pick up after 5 rings as a fallback if GV doesn't kick in for some reason.  I don't want to juggle 3 possible locations for VM so I just changed #2 to Busy Tone.

Finally, under Additional Options the Called Number was set to Any instead of my CC DID. I changed it as your screenshot suggested, but would that be the cause of my phone not ringing? I assume 'Any' would include my CC DID and should still ring.


SteveInWA

Why don't you just try it and let us know?  The busy signal choice for #2 should be fine.

StudioD

Well it's inconsistent, it seems to ring most of the time but not every time.

I just called from my wife's cell. The phone rang but despite the fact she's in my CC phonebook and caller ID normally shows her name as it's saved in that phonebook, this time the caller ID showed the name as 'Dir Assist Ny'.

Then I tried a test call from the NoMoRobo website and it did not ring, even though NoMoRobo showed it should have.

Taoman

#15
Quote from: StudioD on July 15, 2016, 05:05:19 PM
So when I click on View Complete Report, each incoming call is shown 3 times. One shows the Spam Probability, another one shows it was forwarded to EXT 100, and the third one shows it was forwarded to the NoMoRobo number.  


But you didn't answer the most important question. Which of those 3 entries (when the phone didn't ring) had "1 min" listed under Total? Whichever entry shows 1 min is where the call was routed.

As Steve said, change your ring group default extension to 30 seconds ring time.
However, change your Nomorobo ring time to 10 seconds. (this is per Nomorobo instructions. Any action NMR might take will happen within 10 seconds so having a longer ring time accomplishes nothing and can actually cause problems.)

Edit: Some people report having false positives when using Nomorobo. This does not happen if you set your ring time to 10 seconds.

SteveInWA

Try making calls directly to your CC phone number, not to your Google Voice number.

Call from various other numbers.  Document what happens.  If the calls don't ring on your OBi, consistently, and / or don't show the correct caller ID or caller ID name, then something is hosed up with your CC number, and you will have to open a ticket with them.

If every call works properly, then call your Google Voice number from the same phone numbers used in the test above, and document what happens.

StudioD

I called my CC number directly and it was hit-and-miss. Sometimes it rang, other times I got no ringing at either end, just some open line noise on the calling phone like the connection was in progress but never completed.

Calls to my GV number sometimes ring my home number with correct caller ID, other times just ring on the calling end until they go to VM. I'm assuming that on those latter calls, the connection to CC doesn't get completed as was the case when I called the number directly.

I guess I'll open a ticket with CC. It doesn't seem like the problem is with the way I have call treatments set up or anything like that since the number never rings in the first place.

Thanks for the help guys.

voipmvtalk

Glad I found this to know I'm not alone.  Have my GV forwarding to CC.  tried both the free number and a paid number from CC and both are hit or miss.  Calling  CC direct seems to ring the 202 ok.  If I call my GV number the first attempt the 202 doesn't ring my phone but if I call right back within a few minutes the follow up calls do ring the phone.  All attempted calls show in the CC log so they are getting the forward from GV.

So for some reason the initial call to my GV number does forward to CC but then CC doesn't ring the 202.  Any ideas?  Is it possible even the paid CC numbers are hit or miss when being called from GV?

SteveInWA

If every inbound call to your CC number shows up in your CC call log, then this is neither a GV nor CC issue.  More likely, you've got an internet service or local network problem causing your OBi to drop its registration to Callcentric. 

The symptom of "If I call my GV number the first attempt the 202 doesn't ring my phone but if I call right back within a few minutes the follow up calls do ring the phone." suggests that your own network is the culprit.

Did you manually configure Callcentric on your OBi?  If so, log into the OBiTALK web portal, not the local web page interface.  Click on your OBi device, then click the trash can icon to delete the Callcentric SP configuration off of the device.  Wait a few minutes and watch your OBi to confirm that it reboots.

Then, click the desired SP again, and scroll all the way down to the bottom of the web page.  Select the link for OBiTALK compatible service providers.  On the next page, select the link for Callcentric.  On the next page, enter your Callcentric 1777xxxxxxx user name and SIP password.  The portal will configure your OBi with the correct parameters for Callcentric.