Obi202 - Phone Not Ringing...sometimes

Started by StudioD, June 13, 2016, 10:41:47 PM

Previous topic - Next topic

StudioD

I haven't solved it either. CC gave me a new number, I disabled all my call treatments and it's still happening. It seems like I've ruled out all the configuration issues.

I'm beginning to wonder if it's a defective Obi failing to send a ring signal to the phone. I'm using Panasonic cordless phones that have worked for years without an issue on both copper and fiber from Verizon.

voipmvtalk

Quote from: StudioD on September 13, 2016, 03:00:19 PM
I haven't solved it either. CC gave me a new number, I disabled all my call treatments and it's still happening. It seems like I've ruled out all the configuration issues.

I'm beginning to wonder if it's a defective Obi failing to send a ring signal to the phone. I'm using Panasonic cordless phones that have worked for years without an issue on both copper and fiber from Verizon.

I have a ticket open with CC right now and hoping they can shed some light on this.  I would think if Obi is defective then GV would not be 100% ring consistency and mine seems to be if I only use GV.  I'm using ATT phone on mine but it has a ringing base station so I don't think it is our phones.

I think it must be one of the following:

1) CC is not ringing the Obi for some reason TBD

2) The obi is receiving a signal from CC but is not seeing that as a call to ring action 100% of the time.  In my case the 2nd call placed from same number rings all the time.  It's as if you have to "prime the pump" for it to work.  I wonder if the first call it does a cname or SIP lookup but doesn't complete it in time for call initiation.  Once it is done though it is cached so that is why the 2nd call always works from the same calling number in short periods.  Cache expires after X period and then that call is a "fresh" phone and once again fails on initial call.  Calls made shortly after though work ok.

Now when I call direct it always seems to work so I wonder if there is some failing or slow handoff of the caller id number from google's call to CC which causes initial fail.  When calling CC direct no failures so the telco's are handing off the number faster perhaps. 

Just a guess.  I hope CC has some advice.  I dumped my xfinity for GV then realized no name callerID so did the CC thing.  if they can't fix I may go back to xfinity where I started.  Oddly enough xfinity charges me less for having phone service than if I remove it.  Triple play is cheaper than double play. Go figure.  I also found that out after porting to ATT so I could then port to GV.  Now I'm in $10 at CC.  $20 ATT port.  $20 GV port and $5.95/month for the CC number (tried that as I heard the "free" ones could be the issue...nope).  Now might be in for charge to port it all back to xfinity!  LOL.  Too funny

SteveInWA

Quote from: voipmvtalk on September 13, 2016, 03:35:23 PM
Quote from: StudioD on September 13, 2016, 03:00:19 PM
I haven't solved it either. CC gave me a new number, I disabled all my call treatments and it's still happening. It seems like I've ruled out all the configuration issues.

I'm beginning to wonder if it's a defective Obi failing to send a ring signal to the phone. I'm using Panasonic cordless phones that have worked for years without an issue on both copper and fiber from Verizon.

I have a ticket open with CC right now and hoping they can shed some light on this.  I would think if Obi is defective then GV would not be 100% ring consistency and mine seems to be if I only use GV.  I'm using ATT phone on mine but it has a ringing base station so I don't think it is our phones.

I think it must be one of the following:

1) CC is not ringing the Obi for some reason TBD

2) The obi is receiving a signal from CC but is not seeing that as a call to ring action 100% of the time.  In my case the 2nd call placed from same number rings all the time.  It's as if you have to "prime the pump" for it to work.  I wonder if the first call it does a cname or SIP lookup but doesn't complete it in time for call initiation.  Once it is done though it is cached so that is why the 2nd call always works from the same calling number in short periods.  Cache expires after X period and then that call is a "fresh" phone and once again fails on initial call.  Calls made shortly after though work ok.

Now when I call direct it always seems to work so I wonder if there is some failing or slow handoff of the caller id number from google's call to CC which causes initial fail.  When calling CC direct no failures so the telco's are handing off the number faster perhaps. 

Just a guess.  I hope CC has some advice.  I dumped my xfinity for GV then realized no name callerID so did the CC thing.  if they can't fix I may go back to xfinity where I started.  Oddly enough xfinity charges me less for having phone service than if I remove it.  Triple play is cheaper than double play. Go figure.  I also found that out after porting to ATT so I could then port to GV.  Now I'm in $10 at CC.  $20 ATT port.  $20 GV port and $5.95/month for the CC number (tried that as I heard the "free" ones could be the issue...nope).  Now might be in for charge to port it all back to xfinity!  LOL.  Too funny

voipmvtalk:  I should have suggested that you create your own discussion thread, instead of adding on to a possibly unrelated discussion.  Disregard the original poster's issue and comments.  Your OBi isn't defective.   Follow my instructions above to delete the configuration and re-add it from the OBiTALK web portal, not the local web page.

voipmvtalk

Hi.  I was hesitant to follow the instructions as I think my setup was just slightly different.  Also I did set all this up via the web portal.  I did none of the setup locally.

I think my problem was generally same problem as thread title but could start new thread if you think better to do so.

In my circumstance, I have the following:

Obi 202
Port 1 - Fax line with separate GV number on SP1 for incoming and outgoing on Telephone Port 1. Working fine
Port 2 - SP2 with another GV number set for outgoing calls on Phone 2 port.  Incoming calls are GV/SP2 and also CC/SP3.  Google chat unchecked.  

I think if I read your instructions for my setup this is correct?  Again all done via web portal.  If I'm not translating one of these parts correctly though please lmk.  As I said initial "fresh" call doesn't ring the obi but immediate follow up calls do.  

thank you.

SteveInWA

Quote
Port 2 - SP2 with another GV number set for outgoing calls on Phone 2 port.  Incoming calls are GV/SP2 and also CC/SP3.  Google chat unchecked.  

This is behaving as if you may have Google Chat actually check-marked/enabled, as well as forwarding the calls to your Callcentric number, causing contention to ring that phone port.

Try deleting the SP2 configuration completely off of your OBiTALK dashboard.  Then, try some test calls to your GV number, to see if they reliably ring SP3-->Phone 2 via Callcentric every time.  If that's the case, then it suggests a problem with your Google Voice configuration for that particular GV phone number.

voipmvtalk

Quote from: SteveInWA on September 13, 2016, 05:07:36 PM
Quote
Port 2 - SP2 with another GV number set for outgoing calls on Phone 2 port.  Incoming calls are GV/SP2 and also CC/SP3.  Google chat unchecked.  

This is behaving as if you may have Google Chat actually check-marked/enabled, as well as forwarding the calls to your Callcentric number, causing contention to ring that phone port.

Try deleting the SP2 configuration completely off of your OBiTALK dashboard.  Then, try some test calls to your GV number, to see if they reliably ring SP3-->Phone 2 via Callcentric every time.  If that's the case, then it suggests a problem with your Google Voice configuration for that particular GV phone number.


Ok so I deleted the SP2 config which was google voice completely off Obitalk dashboard.  made first test call all my cellphones rang but the obi attached phone did not.  I hung up. Immediately called the number again and it rang the obi attached phone like I described before.    So again just the 2nd call rings the phone and initial call after long wait period does not.  3rd call rang it fine too.  Now if I wait until morning and call the number the first time again it won't ring and all immediate follow up calls will.  Strange!

Double checked Chat is unchecked.   Callcentric log does show the initial and follow up calls made

I have not received a reply from CC support ticket to see if they have any idea why the initial call placed won't ring the phone.

SteveInWA

OK, so we eliminated the SP2 configuration as a possible cause, and you can add it back.  The next step would be to delete the SP3 configuration, and add it back again, as I explained earlier, using the OBiTALK dashboard's custom settings for Callcentric.

If it still fails after that, then I'd go back to my first guess, that you have some sort of issue with your OBi not being able to register to the Callcentric server.

voipmvtalk

One other clue maybe.  I waited just a couple minutes since my last test and post above.  Called again and no ring.  Called right back and got a ring. Noticed one thing on the first attempt.  My fax line on port 1 let out a small little ring (not enough to pickup).  I didn't hear that on the 2nd call right after that did ring port 2.  I do occasionally hear little short ring on the fax machine "randomly".  Not somebody calling but just what I would call a brief "micro ring" sound.

Maybe I should delete port 1 and test to rule that out too even though that shouldn't really affect port 2.  Testing now and will report back in a moment

voipmvtalk

Ok deleting fax line SP1 didn't make a difference. I just deleted and re-registered CC on SP3.  Did a test call and it went through but have to wait a bit for proper test as it may already be "primed" for the follow on calls.

SteveInWA

The chirp ring could be caused by electrical induction between the conductors of the phone cord.  To eliminate the fax machine from the puzzle, it would be helpful to completely unplug the modular phone jack of the cord running to the fax machine.  Unplug it from the back of the OBi.

You should make absolutely sure that you are only using a two-wire/two-pin modular phone cord between the OBi and the fax machine.  Phone port 1 on the back of the OBi is electrically wired as a RJ-14, four-conductor jack.  It has Phone line #1 on the center two pins, and phone line #2 on the outer two pins.  Using a 4-conductor phone cord on that port, connected to a fax machine, can cause all sorts of problems.

So:  use one two-conductor/two-pin (RJ-11) phone cord between the OBi and the fax machine, and a completely different two-conductor/two-pin phone cord between the OBi and your telephone.

voipmvtalk

Ok.  So I deleted CC on SP3 and re-registered it.  Tested it and call rang ok.  Good sign maybe but need to wait more time to be 100%.

Checked the phone jack's per your advice.  The one to the fax was a proper two wire/pin going into Port 1.  Going into port 2 however was a split of a 2 line phone wire.  The side going into obi had just two pins on center.  That side was part of a Y configuration (since my base station was designed as a 2 line phone with a single jack on base station).  The other half of the Y was not plugged into anything but also a 2 pin.  I replaced that with a standard phone jack wire just in case.

A couple test calls and I'm hopeful now as I had a decent wait and it rang on 1st shot.  So if this works won't be sure if re-registering was the fix or the wires (or both).  I will test first thing in the morning.

If this works I wonder if it is ok to switch back to a free DID instead of the $5.95 one I'm using now with CC.  Only did that paid one because one thread a couple years ago here said the GV CLEC may have issues connecting with CC's free DID's CLEC.

SteveInWA

I'd suggest taking "baby steps" and testing your current setup for a week, before changing the Callcentric DID you are using as your forwarding target.

There have been no significant/reported issues with Google Voice forwarding to Callcentric's free DIDs for a long time.  There was a transit carrier issue between the two that was resolved, so there should be no difference forwarding to a free Telengy (Callcentric's own CLEC) number vs. any other number supplied by Callcentric.

voipmvtalk

I waited 30 minutes and same thing. First call no ring. Second call ring ok.  CC just responded to my ticket and said they will attempt to troubleshoot as well now.

SteveInWA

Quote from: voipmvtalk on September 13, 2016, 09:36:15 PM
I waited 30 minutes and same thing. First call no ring. Second call ring ok.  CC just responded to my ticket and said they will attempt to troubleshoot as well now.

Good luck.  Let us know what they have to say about it.

voipmvtalk

Ok so I heard back from them and they said they sent an INVITE to my obi but it did not receive a response on the first call.  Follow up calls they did see the response.

I thought maybe my router or some setting so put obi directly onto xfinity modem port and initial tests all worked ok.  CC got back to me and said to disable SIP Passthrough under my WAN setting so I tried that, put  the obi back on the router and initial tests appear to indicate it is now working properly. 

I will do a few more tests over the day with a couple different numbers and also allow the router to "time out" like before but I suspect the SIP Passthrough setting was the culprit here. 

Why the initial call failed and follow up calls immediately after were successful I do not know unless the initial call opens up the SIP or closes it so it is set favorably for the follow up calls.

Anyway so far so good with this setting change!

voipmvtalk

Ok premature celebration.  Same issue.  Inconsistent ringing even with their change or hanging directly on the comcast modem and bypassing router altogether. 

I don't think it is a lookup issue with caller id.  I had one friend call in and no ring.  next friend one minute later it rang.  so the first call seems to be opening up a port or "waking up" the device which the follow on calls take advantage of and ring.  after some time period it seems to reset and require a wake up call to get another call to ring.  So bizzare.


SteveInWA

Well, regarding your router, if it has a "SIP ALG" setting, that setting should be DISABLED.  I don't know how that translates to "SIP Passthrough".  I am just guessing here,  that SIP Passthrough ENabled = SIP ALG DISabled.  The goal is for your router to NOT act on the SIP packets, so that sounds right.

I'm sticking with my original hunch that you have some sort of network (router) configuration problem.  What model router is this?  Did you replace it or update it when the problem started?

voipmvtalk

Quote from: SteveInWA on September 14, 2016, 12:56:13 PM
Well, regarding your router, if it has a "SIP ALG" setting, that setting should be DISABLED.  I don't know how that translates to "SIP Passthrough".  I am just guessing here,  that SIP Passthrough ENabled = SIP ALG DISabled.  The goal is for your router to NOT act on the SIP packets, so that sounds right.

I'm sticking with my original hunch that you have some sort of network (router) configuration problem.  What model router is this?  Did you replace it or update it when the problem started?

Here is latest update and you are probably right regarding network/router.  Callcentric also said same and wanted me to hook up to DMZ on my comcast modem.  A little digging and my comcast modem was still in router mode and not bridge mode so it was doing its own routing before my router. 

What I did was put the comcast modem into bridge mode (no router - straight shot to my router) and am now testing.  My router is Asus. 

So far all test calls in the last hour have been successful in ringing the phone.  I will wait a couple hours and test calling again after no calls have hit the number for awhile in order to duplicate most closely what I was seeing before.

If this fixes it that means the comcast/xfinity modem's router was clogging up the SIP packets but not in a consistent way.  Possibly acting as a port trigger with the first call to open it up and then the second call has the pathway through.  Then the port trigger closes after some time and I was back to the same again.  At least I'm hoping this is what was occuring here.

Will update after a few more tests throughout the afternoon and evening. 

thanks

voipmvtalk

Ok so good news.  all the phone call tests so far have been successful and the phone is now ringing on first and follow up attempts even after longer intervals in between.

I'd say it is now safe to say the Comcast/Xfinity cable modem was the root cause.  Being that it was in router mode (instead of Bridge mode) it was indeed acting as a router and must have been filtering SIP packets before they could ever hit the obitalk.  The reason only follow on calls would ring the phone I suspect is that the initital call triggered a port which then opened it up for follow on calls afterwards.  However once the port closed after after keepalive was over the next "first" call failed and so on.

So the fix was indeed to put comcast into Bridge mode and forward to my Asus router and let that do all the routing. Also they suggested my SIP passthrough be disabled. 

Glad this is finally resolved.  Big thanks to Callcentric Support and SteveInWa right here for providing the guidance, tips and assistance to track this one down and get it fixed up.  One more day and I was going to lose it!

SteveInWA

Glad to hear it.  Yes, cascading through multiple NAT routers does cause problems with VoIP.  Setting your Xfinity modem to bridge mode is the solution.