Google Voice Voicemail Issue

Started by jellyville, July 20, 2011, 08:35:52 PM

Previous topic - Next topic

jellyville

Per the release notes:

Quote- When there are new or unheard messages in the user's Google Voice voicemail box, the attached telephone's message waiting indicator lamp and/or new message display icon will light up. Also a "stutter" dial tone will be heard on the telephone indicating a new or unheard message.

I have two Obi100s both connected to separate Google Voice accounts. However, both of them are indicating that I have new voicemail when neither account has any voicemail at all. While this is not a debilitating problem, it does get rather annoying to have my voicemail indicator flashing all the time and having this "stutter" dial tone every time I make a call. Is there any way to either fix this or turn it off? Thanks in advance.

RonR

#1
Assuming you have Google Voice configured on SP1, verify that you have the following settings:

Voice Services -> SP1 service -> MWIEnable : (checked)
Voice Services -> SP1 service -> X_VMWIEnable : (checked)
Voice Services -> SP1 service -> MessageWaiting : (unchecked) (Default unchecked)

jellyville

#2
I see MWIEnable and X_VMWIEnable and both are checked. However I do not see MessageWaiting and cannot verify it.

Edit:
Ok, it would have helped I had read the documentation first. I forgot to uncheck "Send missed calls to Inbox" in my Google Voice settings. Sorry.  :(

RonR

Quote from: jellyville on July 20, 2011, 09:49:42 PM
I see MWIEnable and X_VMWIEnable and both are checked. However I do not see MessageWaiting and cannot verify it.

MessageWaiting is only available by logging into the OBi itself.  It's not available on the OBiTALK Web Portal.  Clearing it in the OBi should clear your Message Waiting indication on the phone.

R_Chandra

hmmm....I will second the not-necessarily-the-best-behavior sentiment.  But the (firmware) fix could be complicated.  I get my MWI put on when new SMSes arrive.  They show up in the GV inbox, so that's probably what causes the OBi to think there is a voicemail waiting.  I'm not super familiar with how the OBi firmware does this (whether it's part of Jingle, it does a screen scrape of the GV page, it uses the unofficial GV API, or whatever), but it would be preferable to determine the type of the unread message before "declaring it" a voicemail.

Fallin

Hope this helps..Might be completely off or somewhat helpful.

I had the same problem with my phone (it kept stating that i had a voice mail) but every time i checked on my Google voice account via web there was nothing nor in my google mail account.  So to fix that problem I had to hear my voice mails by calling my own number google number and once in voicemail settings went on to hear my messages and then pressed "7", so they can be archived.  If you tried this already, and it states there are no messages then you probably need to do the following. 

When you initially registered for your google voice account you were asked to validated a number by calling a land or cell phone number and then pressing "52" or whatever number they asked you to press.  For some weird reason that number that you confirmed it on, is now is registered on your google account and when it gets a voicemail, it saves it on your google account. So you do have a voicemail, but its from the other number (e.g registered land or cellphone). Thus giving you a voicemail indicator on your house phone.

So if i get a voicemail left on my cell phone (e.g the phone that i use to initially confirm the two digit google validation number), i get a message on my home phone stating i have a voicemail.  To get rid of the new voicemail indicator, i downloaded GV app on my phone and registered with my google voice account and now i have immediate access hearing them and deleting them.   Now if you don't have an android phone or an iphone i'm not sure what to do from there on.  Hope this was helpful.