December 13, 2017, 08:18:39 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Outbound Call Route Configuraiton  (Read 4424 times)
kelemvor4
Newbie
*
Posts: 3


« on: February 17, 2017, 12:28:47 pm »

Greetings,

I'm a new OBI202 user moving from POTS to this system.  I'm using a couple google voice accounts in SP1 and SP2.   I'm trying to setup the OBI to use SP2 for most any call.  SP1 for calls destined for a specific area code, and SP4 for E911.  I believe I've got regular (SP2) and E911 (SP4) done.   I can't quite make sense of the call route configuration I need for SP1.

Basically I want calls destined for US area code 508 to go through SP1 instead of SP2.

I don't suppose I could add {1508:sp1} into the OutboundCallRoute for the phone port, could I?


Edit: I tried putting this for the outbound call route bit it didn't have the desired effect.

{1508:sp1},{911:sp4},{933:sp4},{([1-9]x?*(Mpli)):pp},{(<##:>):li},{(<#:>):ph2},{(<**70:>(Mli)):li},{(<**82:>(Mbt2)):bt2},{(<**81:>(Mbt)):bt},{(<**8:>(Mbt)):bt},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**3:>(Msp3)):sp3},{(<**4:>(Msp4)):sp4},{(<**9:>(Mpp)):pp},{(Mpli):pli}

My modification in bold.   Any suggestions?
« Last Edit: February 17, 2017, 12:42:01 pm by kelemvor4 » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #1 on: February 17, 2017, 12:59:32 pm »

Try: {(1508xxxxxxx):sp1}

You need to enclose the rule with parentheses. With the parentheses the rule is considered a DigitMap, so you are checking for 1508 followed by 7 digits. Without the parentheses the rule is considered a literal, so you would be checking for 1508 followed by 7 alpha x's.
Logged
kelemvor4
Newbie
*
Posts: 3


« Reply #2 on: February 17, 2017, 01:46:47 pm »

Thanks for the quick reply!

That didn't work.  Can you confirm that the "OutboundCallRoute" under "Physical Interfaces" -> "Phone 1" is the right place for this?

I'm using a handset connected to the phone1 jack on my obi202.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #3 on: February 17, 2017, 02:31:33 pm »

That's the correct place for the rule.
What is happening?
You can login via the local interface and look at the Call History under Status.
UserID and the default Password are both "admin" without the quotes.
This will show where the call is routed.
What is your Primary Line for Phone1?
If it's SP2, post the ITSP B DigitMap.
Maybe there is something there causing the problem.
Logged
kelemvor4
Newbie
*
Posts: 3


« Reply #4 on: February 17, 2017, 03:04:31 pm »

15:38:38   From PH1   To GT2(TEL# Removed from post)
15:38:39      Ringing
15:38:50   Call Ended   

SP2 is the primary line for both phone1 and phone2. 

For the phone1 port, DigitMap is:
([1-9]x?*(Mpli)|[1-9]S9|[1-9][0-9]S9|911|**0|***|#|##|**70(Mli)|**8(Mbt)|**81(Mbt)|**82(Mbt2)|**1(Msp1)|**2(Msp2)|**3(Msp3)|**4(Msp4)|**9(Mpp)|(Mpli))

Default is still checked for the digitmap entry.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #5 on: February 18, 2017, 09:40:29 am »

I'm back, got busy with other things.
I didn't want to see the phone digit map, I asked for the ITSP B digit map.
Service Providers -> ITSP B General -> DigitMap
You need to uncheck both boxes to the right of the Value to see the actual value.
I doubt anything is there that will cause a problem, I just don't see anything wrong.
Let's try a different method.

Service Providers -> ITSP A General -> DigitMap: (1508xxxxxxx)

Now use: {(Msp1):sp1}

Post your Phone OutboundCallRoute
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC