Latest Firmware Updates for OBi1000 Devices

Started by WelshPaul, February 24, 2017, 12:13:10 AM

Previous topic - Next topic

WelshPaul

New firmware has been released for the OBi1022, OBi1032 and OBi1062 IP Phones.

You can download the latest 5.0.5 (Build: 4087) firmware file here.

Release Notes are available here.
For everything VoIP
www.ukvoipforums.com

WelshPaul

New firmware has been released for the OBi1022, OBi1032 and OBi1062 IP Phones.

You can download the latest 5.0.6 (Build: 4176) firmware file here.

Release Notes are available here.
For everything VoIP
www.ukvoipforums.com

WelshPaul

New firmware has been released for the OBi1022, OBi1032 and OBi1062 IP Phones.

You can download the latest 5.0.7 (Build: 4489) firmware file here.

Release Notes are available here.
For everything VoIP
www.ukvoipforums.com

hong

Quote from: WelshPaul on February 24, 2017, 12:13:10 AM
New firmware has been released for the OBi1022, OBi1032 and OBi1062 IP Phones.

You can download the latest 5.0.5 (Build: 4087) firmware file here.

Release Notes are available here.

WelshPaul

New firmware has been released for the OBi1022, OBi1032 and OBi1062 IP Phones.

You can download the latest 5.0.8 (Build: 4643) firmware file here.

Release Notes are available here.
For everything VoIP
www.ukvoipforums.com

PWTm105

Paul:

Is there a more recent FW update?

I'm getting a CheckSum error on the file at the latest link you provided.

Thanks!

Pat

RFC3261

Quote from: PWTm105 on July 02, 2018, 07:36:56 AM
I'm getting a CheckSum error on the file at the latest link you provided.
Recent 2xx, 3xx, 1xxx, and 20xx device firmware validate the firmware image to insure that it is cryptographically signed as "genuine".  You cannot go back to a previous firmware that was not signed (and the older firmwares would not be signed) and (it has been reported) the message you get is checksum error.

WelshPaul

#7
Quote from: PWTm105 on July 02, 2018, 07:36:56 AM
Paul:

Is there a more recent FW update?

I'm getting a CheckSum error on the file at the latest link you provided.

Thanks!

Pat

Hi,

The latest non OBiEXTRAS firmware for the OBi2xx & OBi3xx devices is 3.1.2 (Build: 5896). If you have flashed your device with the latest OBiEXTRAS variant (3.2.2 (Build: 5859EX)) then you will not be able to install the non OBiEXTRAS firmware because the OBiEXTRAS variant uses a higher revision number.

As pointed out above, OBIHAI/POLYCOM have cryptographically signed the latest firmware files for security reasons and downgrading is no longer possible.

Same applies to the OBi1000 series phones.

FYI, latest release for the OBi1000 series is:
http://fw.obihai.com/OBiPhone-5-0-8-4643.fw
http://fw.obihai.com/OBiPhone-5-1-8-4643.fw

OBIHAI did release 3.0.10 (Build: 4808) but it was pulled a week or so after release.
For everything VoIP
www.ukvoipforums.com

drgeoff

Quote from: WelshPaul on July 03, 2018, 03:55:01 AM
The latest non OBiEXTRAS firmware for the OBi2xx & OBi3xx devices is 3.1.2 (Build: 5896). If you have flashed your device with the latest OBiEXTRAS variant (3.2.2 (Build: 5859EX)) then you will not be able to install the non OBiEXTRAS firmware because the OBiEXTRAS variant uses a higher revision number
Something is erroneous there.

5896 (non OBiEXTRAS) is higher than 5859 (OBiEXTRAS).

Taoman

Quote from: drgeoff on July 03, 2018, 06:08:13 AM

5896 (non OBiEXTRAS) is higher than 5859 (OBiEXTRAS).

True, but 3.1.2 is lower than 3.2.2. I'm guessing that's what WelshPaul is referring to?

WelshPaul

#10
Quote from: Taoman on July 03, 2018, 06:29:42 AM
Quote from: drgeoff on July 03, 2018, 06:08:13 AM

5896 (non OBiEXTRAS) is higher than 5859 (OBiEXTRAS).

True, but 3.1.2 is lower than 3.2.2. I'm guessing that's what WelshPaul is referring to?

Correct, 3.2.2 is a higher revision than 3.1.2 so you cannot downgrade from 3.2.2 to a 3.2.1 revision regardless if the build number is higher on the earlier revision (even if the earlier revision is a newer release lol).

I'm sure that Polycom/Obihai want retail units running on OBiEXTRA firmware and Voip Providers using non OBiEXTRA on devices such as the OBi3xx series devices.

Anyway, I don't follow much of what's happening with these devices anymore as they are no longer sold here, I will probably stop following any firmware updates in due course too.

EDIT: Maybe you can move between builds if both are signed? I will test it out and post back...
For everything VoIP
www.ukvoipforums.com

WelshPaul

#11
You cannot downgrade to an earlier version even if it was signed:



Looks like mine is stuck on 3.2.2 (Build: 5859EX) now too!  ;D :D :)
For everything VoIP
www.ukvoipforums.com

Taoman

Quote from: WelshPaul on July 03, 2018, 07:18:01 AM
You cannot downgrade to an earlier version even if it was signed:

Looks like mine is stuck on 3.2.2 (Build: 5859EX) now too!  ;D :D :)

Latest version is 3.2.2 (Build: 5897EX) which got pushed to my 2 OBi200s yesterday and promptly borked all outgoing calls for me on both ATAs. I downgraded back to 5859 and outgoing calls started working again.

http://www.obitalk.com/forum/index.php?topic=14264.msg91285#msg91285

WelshPaul

Quote from: Taoman on July 03, 2018, 07:28:37 AM
Quote from: WelshPaul on July 03, 2018, 07:18:01 AM
You cannot downgrade to an earlier version even if it was signed:

Looks like mine is stuck on 3.2.2 (Build: 5859EX) now too!  ;D :D :)

Latest version is 3.2.2 (Build: 5897EX) which got pushed to my 2 OBi200s yesterday and promptly borked all outgoing calls for me on both ATAs. I downgraded back to 5859 and outgoing calls started working again.

http://www.obitalk.com/forum/index.php?topic=14264.msg91285#msg91285

OK, maybe 3.2.2 (Build: 5859EX) won't allow for the downgrade? Will try installing 3.2.2 (Build: 5897EX) and attempt to downgrade to the non EX firmware again...
For everything VoIP
www.ukvoipforums.com

tvBilly

I feel like I must be missing something, but the Obi1062 I bought the beginning of the year has firmware 5.1.11 4858EX.1311

Never wants to update the firmware, and I haven't seen 5.1.11 mentioned anywhere. I am not an extras customer.

I found a few cosmetic bugs when I was first programming it, but none worth reporting (not even sure how to anymore; ObiHai is not the same company it was when I bought my first 200)...

fwiw

SteveInWA

Quote from: tvBilly on July 03, 2018, 04:39:47 PM
I feel like I must be missing something, but the Obi1062 I bought the beginning of the year has firmware 5.1.11 4858EX.1311

Never wants to update the firmware, and I haven't seen 5.1.11 mentioned anywhere. I am not an extras customer.

I found a few cosmetic bugs when I was first programming it, but none worth reporting (not even sure how to anymore; ObiHai is not the same company it was when I bought my first 200)...

fwiw


Yes, you are missing something:  the discussion just above your post is about the 200-series OBi ATAs, not the IP phones.  The current IP phone firmware is 5.1.7 (Build: 4666EX.1311) as far as I know.

SteveInWA

Quote from: Taoman on July 03, 2018, 07:28:37 AM
Quote from: WelshPaul on July 03, 2018, 07:18:01 AM
You cannot downgrade to an earlier version even if it was signed:

Looks like mine is stuck on 3.2.2 (Build: 5859EX) now too!  ;D :D :)

Latest version is 3.2.2 (Build: 5897EX) which got pushed to my 2 OBi200s yesterday and promptly borked all outgoing calls for me on both ATAs. I downgraded back to 5859 and outgoing calls started working again.

http://www.obitalk.com/forum/index.php?topic=14264.msg91285#msg91285

I have a 200 and a 202 running 3.2.2 (Build: 5897EX).  I just got back from a week out of town, so I hadn't been using the phones.  I tested both now, and both successfully make outbound calls.  So, I dunno what was up with yours.


tvBilly

Quote from: SteveInWA on July 04, 2018, 05:52:14 PM
Quote from: tvBilly on July 03, 2018, 04:39:47 PM
I feel like I must be missing something, but the Obi1062 I bought the beginning of the year has firmware 5.1.11 4858EX.1311

Never wants to update the firmware, and I haven't seen 5.1.11 mentioned anywhere. I am not an extras customer.

I found a few cosmetic bugs when I was first programming it, but none worth reporting (not even sure how to anymore; ObiHai is not the same company it was when I bought my first 200)...

fwiw


Yes, you are missing something:  the discussion just above your post is about the 200-series OBi ATAs, not the IP phones.  The current IP phone firmware is 5.1.7 (Build: 4666EX.1311) as far as I know.

Uh, OK, but if you look at the subject for this thread, what does it say? Would you have preferred that I start a new thread because you (and others) had hijacked this one, rather than try to bring this one back on topic? For someone that helps so many (including me in the past), you sure don't have a way with words.

Most everyone seemed to think that 5.1.7 or 5.1.8 was the current version. So I was pointing out that the current firmware I have on my 1000 series phone hasn't been mentioned anywhere on the forum, and I thought it might be interesting to those who have 1000 series phones. Even @WelchPaul hadn't mentioned it, and he's been the source of firmware that's hard to find in the past.

@Dan-Voip was kind enough to provide a link for the 5.1.11 firmware for everyone.

glambx

#19
I'm on 5.1.11 (Build: 4858EX.1311) at the moment, and my 1062 has started occasionally rebooting itself while reactivating the screen (set to power save after ~5 minutes).  I'd like to back out to 5.1.8, but it appears they introduced an additional new bug in 5.1.11.

Every version of every firmware I've tried to flash (including the new non-official firmware) produces the error:

Firmware Update Failed
Firmware package checksum error

Anyone found a workaround?  Are they locking customers onto the latest version of their firmware so they can start stripping features away?