Can't call Google Voice Number using Linked Cell Phone Number

Started by Zenzuki, February 24, 2017, 12:55:08 PM

Previous topic - Next topic

Zenzuki

I called my house phone (Google Voice with Obi202) from my Linked Cell Phone and it didn't ring, but went directly to Voice Mail and being asked for PIN. There're advise on this forum and also on Google Voice Help to 1) Do NOT forward call from GV to Linked Cell Phone. 2) Under Legacy Google Voice --> Settings --> Phone Tab --> Voicemail Access --> NO.

Well, that settings USED to work until recently (Feb 23 2017). No matter what I set, my call to said house phone went to my Google Voicemail. Hours of trials, no improvement. Here is my solution.

REMOVE my Linked Cell Phone Number. Close GV. Then, reopen GV and Linked that Cell phone number again with the above settings (Choose Option "NO" to Voicemail Access).

Hope it helps

SteveInWA

It is working as designed.

Google Voice has a "Voicemail access" option, which determines the behavior when calling your own Google Voice number from one of your "linked" or "forwarding" telephone numbers.

The default behavior for phones classified as type = mobile, is to not ring the other forwarding destinations when calling into the GV number.  This is so that people can easily check their voicemail by calling in.

The default behavior for phones classified as land lines (type = home or type = work) is to first ring all the other forwarding destinations.

You can change this in Google Voice settings.  In your case, since you do want to call your GV number from your cell phone, you'd set "Voicemail access" to off.

This setting isn't easy to find, because the newly-redesigned GV web user interface left out a lot of settings.

From a laptop/desktop web browser, you need to go to your Google Voice account and click the three-bar, "hamburger" icon in the upper left corner, then scroll down to get to "Legacy" GV.  From there, you can click the gear icon in the upper right corner to get to Settings.


  • Click the Edit button under your desired forwarding phone number.
  • Click "Show advanced settings.
  • Change Voicemail access to "no".
  • Scroll down and click "Save"

Do not simply delete your cell phone off of the list of forwarding phone numbers, as this will remove the ability to easily check your voicemail from a phone other than the OBi-attached phone.

tsvieps

 ??? I have a similar but slightly different problem. I want to be able to call my cell phone with our house phone. The latter is associated with my cell on Google Voice. It accesses my voicemails instead of calling the phone. I did what was suggested here. I can call the house phone with my cell because its number is owned by a different VOIP carrier, Localphone. I am OK with having the voicemails to the Localphone number show up on Google Voice, but not at the cost of not being able to call my cell from the house phone.

Maybe the trick is learning to access the secondary carrier, Localphone from the house phone by first dialing *something.

SteveInWA

Quote from: tsvieps on March 05, 2017, 03:35:01 PM
??? I have a similar but slightly different problem. I want to be able to call my cell phone with our house phone. The latter is associated with my cell on Google Voice. It accesses my voicemails instead of calling the phone. I did what was suggested here. I can call the house phone with my cell because its number is owned by a different VOIP carrier, Localphone. I am OK with having the voicemails to the Localphone number show up on Google Voice, but not at the cost of not being able to call my cell from the house phone.

Maybe the trick is learning to access the secondary carrier, Localphone from the house phone by first dialing *something.

I read your post three times, and I can't make any sense out of it.  Normal behavior is:


  • You have a Google Voice inbound telephone number, and you set up that number on your OBi device.  You can make outbound calls from that number on the telephone attached to your OBi.  Inbound calls to your Google Voice number from a mobile phone number that is listed as a "linked"
    or forwarding phone number on your Google Voice account will, by default, directly access your voicemail box.
  • If you want to have your OBi-attached telephone ring when called from your forwarding/linked mobile phone number, then I explained how to do that in my previous post.
  • You seem to be describing the opposite:  call your mobile phone number from your OBi-attached phone.  If that is what you want to do, then it simply works.  It is a regular telephone call to your mobile phone, as far as both carriers are concerned.  I don't know what you are trying to do with regard to a Localphone number.

Try again to explain your issue if this doesn't answer your question.

mrtsherman

    Quote from: SteveInWA on March 05, 2017, 05:40:01 PM

    • You seem to be describing the opposite:  call your mobile phone number from your OBi-attached phone.  If that is what you want to do, then it simply works.  It is a regular telephone call to your mobile phone, as far as both carriers are concerned.  I don't know what you are trying to do with regard to a Localphone number.

    Try again to explain your issue if this doesn't answer your question.

    I am having the same issue as tsvieps. Perhaps you can help us both out SteveInWA?

    I just got an Obihai 200 and linked it to my GV number. When I call my GV number from home, it goes straight to voicemail so that I can check my messages. I want it to actually ring my cell phone though. Not sure how to accomplish this.



    drgeoff

    Quote from: mrtsherman on January 25, 2018, 09:50:23 AM
      Quote from: SteveInWA on March 05, 2017, 05:40:01 PM

      • You seem to be describing the opposite:  call your mobile phone number from your OBi-attached phone.  If that is what you want to do, then it simply works.  It is a regular telephone call to your mobile phone, as far as both carriers are concerned.  I don't know what you are trying to do with regard to a Localphone number.

      Try again to explain your issue if this doesn't answer your question.

      I am having the same issue as tsvieps. Perhaps you can help us both out SteveInWA?

      I just got an Obihai 200 and linked it to my GV number. When I call my GV number from home, it goes straight to voicemail so that I can check my messages. I want it to actually ring my cell phone though. Not sure how to accomplish this.



      You don't seem to understand the third bullet in SteveInWA's post.  If you want to call the cellphone from the phone plugged in to the OBi, dial the cellphone number.[/list]

      SiEntomologist

      I have been having the same problems with calling linked numbers starting, I think, last October or November (2018):  before then, I never had a problem with my OBi200.  Now, whenever (100% of the time) I connect it to a different router (i.e., through different service providers) either I cannot call my Google Voice linked cell phone from the OBi phone (after several rings with a hiccup, I get a message "We are unable to complete your call at this time; please try again later", sometimes repeated in Spanish followed by something like "message 12 switch 113."  Or I cannot call my OBi phone from my cell phone (I get a busy signal).  Or often it fails both ways.  Usually after rebooting the OBi200, it works at least one way or the other (seemingly randomly), but to get it to work both ways usually takes rebooting a dozen times, unplugging and rechecking wires each time, checking Google Voice settings from my laptop, waiting an hour, reciting incantations and invectives while standing within a circle of candles ...  I have no idea what makes it work but eventually it does.  And it stays working until I move it again -- which happens about twice a week.

      I got used to this routine of testing a couple of years ago with an OBi100 when Google was apparently changing servers so it sometimes worked and sometimes didn't.  Is Google in the process of changing something affecting the OBi200?

      SteveInWA

      Quote from: SiEntomologist on January 23, 2019, 12:45:51 PM
      I have been having the same problems with calling linked numbers starting, I think, last October or November (2018):  before then, I never had a problem with my OBi200.  Now, whenever (100% of the time) I connect it to a different router (i.e., through different service providers) either I cannot call my Google Voice linked cell phone from the OBi phone (after several rings with a hiccup, I get a message "We are unable to complete your call at this time; please try again later", sometimes repeated in Spanish followed by something like "message 12 switch 113."  Or I cannot call my OBi phone from my cell phone (I get a busy signal).  Or often it fails both ways.  Usually after rebooting the OBi200, it works at least one way or the other (seemingly randomly), but to get it to work both ways usually takes rebooting a dozen times, unplugging and rechecking wires each time, checking Google Voice settings from my laptop, waiting an hour, reciting incantations and invectives while standing within a circle of candles ...  I have no idea what makes it work but eventually it does.  And it stays working until I move it again -- which happens about twice a week.

      I got used to this routine of testing a couple of years ago with an OBi100 when Google was apparently changing servers so it sometimes worked and sometimes didn't.  Is Google in the process of changing something affecting the OBi200?


      This is another example of someone doing something that the service is not designed to handle, and then considering it a bug.  Or, like the old doctor joke:  Patient:  "Doc, it hurts when I do this."  Doctor:  "Well, then don't do it."

      Why are you continually swapping internet connections to the OBi?  That serves no useful purpose, and it is causing the problem.  Google Voice has some protections against abuse, and it may temporarily refuse connections when rapidly disconnected and reconnected, especially via a different public IP address.  Don't do that.

      If you are doing it because you want to use the device in two different locations (e.g. home and office), then just buy another OBi device.  You can connect multiple OBi devices to one Google account.

      SiEntomologist

      First, I don't consider twice a week as "continually."  The only reason for rapidly disconnecting and reconnecting is because it isn't working and rebooting seems to have some impact on fixing the problem.

      Second, as I mentioned, the problem started only recently.

      Third, even if I got another OBi device and left one at home that (hopefully) wouldn't be affected, I would still expect a problem with a second one used when traveling if Google is deliberately doing something deliberate to prevent moving it.

      Most importantly, if Google is doing something deliberate, exactly what?  The symptoms don't fit any sensible test I can think of.  I wouldn't object if it asked for some kind of passcode.

      I mentioned the ip address change because it has occurred to me that Google Voice might cache information about my device somewhere and doesn't completely reset things when it is disconnected. But a minimum of a couple of hours ought to be enough for anything to realize that something has been disconnected.  And anyway, once again, it didn't use to be a problem.


      SteveInWA

      Quote from: SiEntomologist on January 23, 2019, 03:19:19 PM
      First, I don't consider twice a week as "continually."  The only reason for rapidly disconnecting and reconnecting is because it isn't working and rebooting seems to have some impact on fixing the problem.

      Second, as I mentioned, the problem started only recently.

      Third, even if I got another OBi device and left one at home that (hopefully) wouldn't be affected, I would still expect a problem with a second one used when traveling if Google is deliberately doing something deliberate to prevent moving it.

      Most importantly, if Google is doing something deliberate, exactly what?  The symptoms don't fit any sensible test I can think of.  I wouldn't object if it asked for some kind of passcode.

      I mentioned the ip address change because it has occurred to me that Google Voice might cache information about my device somewhere and doesn't completely reset things when it is disconnected. But a minimum of a couple of hours ought to be enough for anything to realize that something has been disconnected.  And anyway, once again, it didn't use to be a problem.



      There is nothing inherent in Google Voice that would cause intermittent loss of connection.  Every time you reboot/power cycle the device, it has to re-authorize to the service.  If this happens repeatedly, the connection attempt may be temporarily blocked.  Flip-flopping between ISPs is not the way to troubleshoot or mitigate this issue.

      You can watch this yourself.  Sign into your OBiTALK web portal, and expand the SP1-SP4 detail under the device.  When you reboot the device, it should take a few minutes to reconnect, as indicated by "Connected" showing to the right of the SP number.  If you do this repeatedly, you will see that it temporarily fails, with one of several errors.  One example is a bogus message that it is connecting to some IP address.  If this happens,  don't tweek with it.  Just let it sit there and it should eventually reconnect ("eventually" defined as 5-10 minutes).

      If your device drops connections, then you probably have a problem with one or more of these things:


      • Bad Ethernet cable between OBi and switch or router
      • Bad/flaky OBi power supply (the "wall wart")
      • Bad/flaky OBi hardware
      • Inadequate/failing ISP service caused by wet/corroded damaged outside cabling, or poor quality of service