December 17, 2017, 07:08:15 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: Rings But Cannot Answer  (Read 4056 times)
RickM2
Newbie
*
Posts: 7


« on: August 23, 2017, 09:44:51 am »

I am a Long-time user of OBI202 with Google Voice with a connected phone. No problems until a few days ago I found that even though the phone would ring, I could not answer any calls. For an incoming call the caller ID (number) displays. When attempting to answer I will hear a few seconds of silence and then the dial tone. My linked cell phone continues to ring and can be used to answer the call. Outgoing calls work normally. There is a steady green light on the OBI202.

I have followed OBI's troubleshooting suggestions of 1. deleting Google Chat in the Google Voice setup, 2. placing a call from Google Voice number in Gmail which put Google Chat back in Google Voice, and 3. checking that Google Chat is checked in Google Voice Setup. I have also powered the OBI202 off and back on again. These steps have not changed anything.

Around the time this problem developed, my Google Home gained the ability to make phone calls and I allowed it to use my Google voice number. Google Home's calling feature allows the placement of calls but not their receipt. In case my GH might be an issue, I switched it back to using an unidentified number for calls instead of my GV number and repeated the above steps, again with no help. Thoughts?
« Last Edit: August 25, 2017, 11:39:53 am by RickM2 » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3973



« Reply #1 on: August 23, 2017, 05:21:55 pm »

Hi Rick:

I don't think your Google Home has anything to do with this.  I have one, with calling enabled, and it isn't interfering with my inbound Google Voice-->OBi calls.  Google Voice allows multiple connections to the same Google account, and the Google Home is (at this time) an outbound-only service.

Using a laptop or desktop computer web browser, not a smartphone or tablet, open an "Incognito" or "Private browsing" session (Ctrl-Shift-N for Chrome browser, or Ctrl-Shift-P for other browsers).  Log into the Gmail account that holds your Google Voice number.  Click Ctrl-T to open another browser tab, leaving the first tab logged in.

On the second tab, log into your OBiTALK web portal dashboard and click on your OBi.  Click on the SPx that hosts your Google Voice number, and get past the 911 warning.  Click the link to "Sign-in to the correct account, and then, Click Here to connect the OBi with your active Google Account".

Wait, then confirm that the SPx status is "Connected".  Now, try calling your Google Voice number from some other number, NOT from one of your forwarding phone numbers,  The OBi's phone should ring.
Logged

RickM2
Newbie
*
Posts: 7


« Reply #2 on: August 24, 2017, 03:49:53 am »

Steve,

I really appreciate your help. I followed the instructions using incognito mode and then checked the connection status. Unfortunately it did not restore the ability to answer the call. I will note that the OBI connected phones (house phones) do ring and show the caller ID, they just are unable to answer the call. Just a few seconds of silence when trying to pick up, followed by a dial tone.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3973



« Reply #3 on: August 24, 2017, 12:45:45 pm »

How many times do the phones ring when an inbound call happens?  Normally, if not answered, the ring period is approximately 25 seconds.  If the ring period is less than that, then you may have a 10-digit forwarding phone number on your GV account that is grabbing the calls.

Log onto your Google Voice account, go to settings, and look at the list of "linked" or "forwarding" destinations.  You'll have Chat, plus up to six conventional phone numbers.   Delete any numbers you no longer control (abandoned, canceled service).  Add and verify one conventional land line or mobile phone number.  Call your GV number from an unrelated phone number, and see if you can answer it on the conventional phone (not an OBi-connected phone).
Logged

drgeoff
Hero Member & Beta Tester
*****
Posts: 2737


« Reply #4 on: August 24, 2017, 03:35:17 pm »

Add and verify one conventional land line or mobile phone number.  Call your GV number from an unrelated phone number, and see if you can answer it on the conventional phone (not an OBi-connected phone).
Wasn't that test what RickM2 mentioned in the opening post: "My linked cell phone continues to ring and can be used to answer the call."
Logged
RickM2
Newbie
*
Posts: 7


« Reply #5 on: August 25, 2017, 08:54:25 am »

The phone rings for 25 seconds and goes to voice mail if not answered first by the cell phone. Attempted answering by means of the OBI connected phone stops the ringing on the Obi Connected phone but not the cell phone. Google Voice show only Google Chat and my one cell phone.

Thanks for the ideas.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3204


« Reply #6 on: August 25, 2017, 09:16:42 am »

Did you try using Phone Port#2 on the OBi202 or a different phone? The OBi202 default will ring both phone ports.  

Edit:

Don't use your house wiring, plug the phone directly into the OBi202.
« Last Edit: August 25, 2017, 09:23:12 am by azrobert » Logged
RickM2
Newbie
*
Posts: 7


« Reply #7 on: August 25, 2017, 10:07:03 am »

I will try these things later today. Thanks.
Logged
timandheike
Newbie
*
Posts: 4


« Reply #8 on: August 25, 2017, 11:38:51 am »

I have the exact same issue and it also started at the time Google Home gained the ability to make outgoing phone calls. Like you stated, you can configure whether the outgoing call you place with Google Home will just use an unidentified number or you can associate it with a Google Voice or Fi number. 

The problem happened with a 110 I had been using for years.  So I switched to my 202 that I had sitting in my garage, same issue.

After reading that you had the same problem, I'm quite certain that it has something to do with a change Google made on their end for Google Home users who opt to associate their GV nr.  And to add insult to injury, the voip quality over the Google Home is terrible. I tried to order a pizza, but had to call back with my mobile phone because the lady taking the order couldn't hear me.
Logged
timandheike
Newbie
*
Posts: 4


« Reply #9 on: August 25, 2017, 11:51:58 am »

I just setup a secondary Google Voice account that I have, and it receives calls just fine. That google account is not associated with my Google Home. 
Logged
timandheike
Newbie
*
Posts: 4


« Reply #10 on: August 25, 2017, 12:52:27 pm »

Hi Steve, I deleted the permissions to it and the problem still exists. I still think that something was done when I tied the home to use my GV number.

Perhaps like the ObiHai devices they're using the Google Chat option for outbound VOIP calling through the Home, but since Home only supports outbound calling at this time, they change some internal setting in the GV account related to that Google Chat option when you elect to display your own GV number rather than having an unidentified number.

As mentioned, if I setup another Google Voice account not associated with the Google Home device then it works.  Also, removing the oAuth permission might not necessarily undo the change they made to the GV chat option.

This is all hypothetical and I might be wrong, but I'm trying to make sense of it. :-)  Thank you for your help!
Logged
Driv3l
Newbie
*
Posts: 1


« Reply #11 on: August 26, 2017, 03:11:00 pm »

I have the exact same problem, and it about the same time voice calling became enabled on the google home.

I am almost 100% certain it's related to Google enabling voice calling on the home (and if you use the same google voice on the Obi).

I tried all options to get it working viz. different phone ports on the Obi, different phone, unlinking the google voice account from the Google Home etc. Nothing works.

I also completely factory reset my Obi202 (after deleting it from the Obitalk account), updated the firmware, and completely reconfigured everything... problem is still there.

It seems the issues are related on the Google side once the account is enabled for voice called for the Google Home.
« Last Edit: August 26, 2017, 03:13:43 pm by Driv3l » Logged
sunqx
Newbie
*
Posts: 2


« Reply #12 on: August 26, 2017, 03:19:38 pm »

I am also having the same issue. It came right after I linked my Google Home with my Google Voice number.  I switched back to using an unidentified number but the problem still exists.  I used all of the solutions that Steve suggested but no success.
Logged
sunqx
Newbie
*
Posts: 2


« Reply #13 on: August 26, 2017, 04:07:14 pm »

 I removed the affected google voice account from my OBitalk account and set up with a different google voice number, which has never been associated with my Google Home.  Then incoming calls work fine and I can answer.  So I am pretty sure this issue is related to Google Home's voice call.
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2737


« Reply #14 on: August 27, 2017, 01:21:17 am »

Another instance http://www.obitalk.com/forum/index.php?topic=12911.0.

5 people reporting this may not be concrete proof that Google Home is implicated but surely there is a prima facie case for SteveInWA to bring this to the attention of his contacts at GV.
Logged
RickM2
Newbie
*
Posts: 7


« Reply #15 on: August 27, 2017, 01:23:01 pm »

Did you try using Phone Port#2 on the OBi202 or a different phone? The OBi202 default will ring both phone ports.  

Edit:

Don't use your house wiring, plug the phone directly into the OBi202.

I'm just reporting back that I hooked up a different phone directly to OBI202. The same problem persists on either port.
Logged
RickM2
Newbie
*
Posts: 7


« Reply #16 on: August 27, 2017, 01:42:29 pm »

I can also report one additional observation. When calling in from a trusted caller number on the affected account, OBI attendant is not accessed as was possible before the problem started. Perhaps this might be helpful in understanding where the issue lies.
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2737


« Reply #17 on: August 27, 2017, 02:51:00 pm »

I can also report one additional observation. When calling in from a trusted caller number on the affected account, OBI attendant is not accessed as was possible before the problem started. Perhaps this might be helpful in understanding where the issue lies.
Your OBi device can only know if a call is from a trusted caller by looking at the incoming Caller ID.

If your phone normally displays Caller ID (number) check what it now shows on incoming calls to your GV number.

If your phone is not equipped to show the Caller ID number, log in to the OBi's local web server, click on Status and then on Call History. Do you see the expected number(s) there?
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3973



« Reply #18 on: August 27, 2017, 05:31:06 pm »

Please take this conversation over to the Google Voice Help Forum, where I am asking users to perform troubleshooting steps and to collect data for Google's engineering team's use.

Here is the link:  https://productforums.google.com/d/topic/voice/q-og2PmuE-4/discussion

I'll bring this up with my contacts at Google tomorrow, too.
Logged

drgeoff
Hero Member & Beta Tester
*****
Posts: 2737


« Reply #19 on: August 28, 2017, 11:25:25 am »

Another victim. http://www.obitalk.com/forum/index.php?topic=12915.0
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC