December 15, 2017, 07:34:48 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Obi200 Call forwarding on busy worked once  (Read 3835 times)
static1120
Newbie
*
Posts: 9


« on: September 19, 2017, 12:59:23 pm »

Hello, everyone

Two days ago I set up a At&t syn248 with 3 extension telephones.

A google voice account set up on the obi as the primary line on the PBX gateway.

A secondary home line is connected to the PBX Gateway that is only supposed to be used in-case of a rollover if the primary google voice line is busy.

I went to the OBI200 configuration and changed the calling features and enabled call number on busy and specified the secondary number.

I tried calling the primary number once, left the line working and got a second phone and called the primary line again, and as it should the second line started ringing and the phones showed line 2 blinking.

A day later, the feature is no longer working, when trying to get call on busy rollover to work, if I call while the line is in use, I only hear a beep sound on the primary line and it wont rollover to the secondary line anymore.

Anyone have any more experience with call forwarding on busy?

Thanks guys.
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2726


« Reply #1 on: September 19, 2017, 01:38:11 pm »

Have you fallen for the old gotcha of making a configuration change via the ATA's onboard web server GUI while Obitalk remote provisioning is still enabled?

http://www.obitalk.com/forum/index.php?topic=61.msg109#msg109
Logged
static1120
Newbie
*
Posts: 9


« Reply #2 on: September 19, 2017, 02:36:10 pm »

I believe I understand where this is going,
Yes I did the changes via the web GUI (Local IP address, 192.168.0.XXX)


So if I understand correctly I would need to disable Auto-provisioning?
and I still do the changes under local IP?
or is there changes that can be made from the website for the configuration? 

Hopefully this is what is causing the current issue I am facing

Thank you for your support
« Last Edit: September 19, 2017, 02:37:56 pm by static1120 » Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2726


« Reply #3 on: September 19, 2017, 03:14:32 pm »

All the useful configuration settings are also available using the Expert mode on the portal.  Set up the Call Forwarding there.

You need to have both boxes at the right hand end of a settings line unticked before you can make a change.  Then click the 'Submit' button at the bottom.  The portal will send the updated configuration to the ATA and make it reboot.
« Last Edit: September 19, 2017, 03:18:16 pm by drgeoff » Logged
static1120
Newbie
*
Posts: 9


« Reply #4 on: September 22, 2017, 09:12:17 am »

I have been trying to get call forwarding to work for the longest time, and im still stumped.

I have wanted to reset the device and start from scratch.

If I understand correctly, I can make changes from the device onboard web GUI with its local IP address

But... Any changes I do there directly conflict with obitalk servers if auto provisioning is enabled correct?

I have been doing changes on the device and on the OBIexpert configurations but I can get them to play nicely with each other, I know I may be overlooking something fairly simple
 
but when I do changes for the call forward on busy, I get a red exclamation mark next to it, meaning after a bit of research that the input conflicts with the obitalk expert configuration settings.

A bit more guidance guys, id really appreciate it

Thanks
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #5 on: September 22, 2017, 10:18:39 am »

Making some changes on the local web browser interface, and making other changes on the OBiTALK interface, makes a mess.  The OBiTALK settings will normally overwrite the locally-made settings, but, in some cases, you can end up with them being out of sync.  The red exclamation marks simply let you know that you changed a value from the default; it doesn't mean anything is wrong.

If you really want to clean this up, I'd suggest starting over.
  • Delete your OBi device from the OBiTALK web portal and wait a few minutes for OBiTALK to remotely access the device.
  • Unplug the power and Ethernet cables from the device.
  • Find the recessed reset switch on the bottom of the device.  On the OBi 2xx series, there is a raised bump with a hole in it.  Set the device on a flat service, upside down.  Using a paper clip, gently depress and hold in the recessed button.  You should feel a slight click.
  • While continuing to hold in the button with one hand, plug in just the power cord with the other hand.  Wait at least 10 seconds, then remove the paper clip.  Wait a couple minutes.
  • Your OBi is now restored to factory defaults.
  • Now, add it back to the OBiTALK web portal. following the **5 procedure.
  • Set up your service provider(s) as needed.  If you are using a major SIP VoIP provider that OBi supports, scroll down to the bottom of the OBiTALK service provider selection page, and click "OBiTALK compatible service providers", and select your provider from the list.  This will load a pre-configured settings template for that service provider.
  • From now on, do not make changes on the local UI.  Make all changes from the OBiTALK web portal, using it's "Expert configuration" mode if needed.
Logged

drgeoff
Hero Member & Beta Tester
*****
Posts: 2726


« Reply #6 on: September 22, 2017, 11:52:28 am »

I have been doing changes on the device and on the OBIexpert configurations but I can get them to play nicely with each other, I know I may be overlooking something fairly simple
You overlooked the 'NOT' in the title of the post I referred you to.  Clearly you failed to either read or comprehend that post.
Logged
static1120
Newbie
*
Posts: 9


« Reply #7 on: September 27, 2017, 04:07:54 pm »

Thank you both for your help, regarding the issue I am having, in response to drgeoff, sorry I did look at your post, but I simply had already messed around with both configurations by the time I saw the post and was trying to clean up the mess I made (new user error)

Thanks for the detailed info Steve

I went ahead and cleaned up the mess I did using Steves guide, deleted device from obitalk
Reset device to factory, then Re-added device using the **5 code

After doing so I got it back up and did changes only trough obitalk

Went down to voice services, SP1 and under calling features deselected Obitalk to be able to select the call forward on busy checkbox, and entered the number (1XXXXXXXXXX) I tried (XXX-XXX-XXXX) and (XXXXXXXXXX) but they all still end up giving me the previous issue, when I call the primary number the second time I only hear a beep on the main line, and the call does not roll-over to the other number that needs to be called.

I am still trying to figure out why I got it to work once and I have not been able to get it to work anymore  Cry

Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #8 on: September 27, 2017, 04:26:57 pm »

It doesn't make sense that you'd set up call forwarding on the OBi.  That's something that should be handled either by the Syn248 gateway, or via a service provider (e.g. a VoIP service).

Google Voice is NOT a free VoIP trunk.  It's a full-featured, inbound call forwarding and voicemail/text message management system.  It's going to have conflicts trying to interact with forwarding from the OBi to another number (azrobert's claims to the contrary).

It's a shame that you bought the AT&T system, instead of a bunch of true IP phones, that could function with either a true VoIP PBX or a cloud-based PBX-like service.  But, given that you have to work with what you bought, I'd suggest dumping Google Voice and whatever service is providing your landline, and getting as many SIP VoIP DIDs and channels as you need from a SIP VoIP service provider (e.g. Callcentric, voip.ms, Phonepower), then using one OBi 200 per analog port on the 248, or buy a OBi 202 to support two analog ports.
Logged

azrobert
Hero Member & Beta Tester
*****
Posts: 3203


« Reply #9 on: September 27, 2017, 04:29:53 pm »

You need to specify the trunk you want to use for the call forward.
sp1(1xxxxxxxxxx)

This really isn't a call forward, it's bridging the call. You use your service provider to make a new call then connect the inbound call to the target. The target will see your service provider's CallerID, not the original inbound CallerID.
« Last Edit: September 27, 2017, 05:43:29 pm by azrobert » Logged
static1120
Newbie
*
Posts: 9


« Reply #10 on: September 27, 2017, 06:47:19 pm »

Hey everyone again thanks for the help, let me explain a bit on why I did this

I have a cellphone used for company use, this number is known by a lot of people, it gets many calls and texts (pictures).
I wanted to switch this out to the syn248 to use the phone with the phone systems without loosing access to text messages so picture messages go straight into the google voice web portal.

Now the system is working perfectly and messages are arriving to the google page.

since we have a home phone line to work with, we just need to use it as a secondary when the main primary number is on a call, the call is transferred to the second number so another person on a different desk set can pick up that incoming call with the extra line.

Working with what I have I was able to get it to work once but from the reply's I understand its not possible or it worked out of luck?

or based on what I have Is it possible to still get it working using the trunking method

Sorry for being so lost but I appreciate the help once again

 
« Last Edit: September 27, 2017, 06:50:21 pm by static1120 » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3203


« Reply #11 on: September 27, 2017, 07:39:35 pm »

I forgot something. If Call Waiting is enabled, you won't receive a Busy.

Physical Interfaces -> Phone1 Port-> CallWaitingEnable: unchecked

See following for the number format:
http://www.obihai.com/OBiDeviceAdminGuide#_Toc367543037

You can get the original CallerID if you forward to an SIP device, like an SIP softphone installed on a smartphone or a VOIP Phone.
Logged
static1120
Newbie
*
Posts: 9


« Reply #12 on: September 27, 2017, 08:13:16 pm »

Ok so under physical interfaces -> Phone 1 call waiting is enabled

https://imgur.com/a/Qaby6

will try disabling this setting and verifying if it fixes the call forwarding issue

This is the most logical explanation as to why I heard a beep on the line whenever a second call tried to go in, most likely to let you know theres someone on hold

Thank you

« Last Edit: September 27, 2017, 08:17:57 pm by static1120 » Logged
static1120
Newbie
*
Posts: 9


« Reply #13 on: September 29, 2017, 12:28:56 pm »

After disabling call waiting, the issue is still happening, call forwarding on busy is not being made

I will try to remove the line and connect it to a regular home phone to see if I can eliminate the possibility that the issue might be related to the Syn248

Thanks
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3203


« Reply #14 on: September 29, 2017, 02:01:55 pm »

You can define forward on busy on the Phone1 Port or the SPx Service. I just tried forward on busy with my OBi200 and it didn't work when defined on the Phone1 Port, but worked when defined on the SP1 Service. I'm running firmware 5657. When testing you can't just take the phone off-hook to make it busy, it must be on an active call.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #15 on: September 29, 2017, 02:47:55 pm »

You could easily solve this, and have a more logical setup, with one, unified voicemail box, if you'd simply port your two existing numbers to Callcentric or another inexpensive SIP VoIP service provider, like voip.ms.  You can then setup a hunt group to automatically send calls to the available number.
Logged

Smerel
Newbie
*
Posts: 3


« Reply #16 on: November 17, 2017, 06:24:52 am »

azrobert  You mentioned besides setting call forward you need to select where it forwards from.
Where do you set that up ?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC