December 16, 2017, 01:15:08 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: No incoming calls on OBI200  (Read 1569 times)
MMark
Newbie
*
Posts: 13


« on: November 01, 2017, 07:53:57 pm »

I've had OBI200 with Google Voice for about a year. Several months ago incoming calls stopped ringing. When I power cycle the unit it starts working but only for few minutes. I tried to delete the Google Chat in GV per instructions but immediately reappears. Any help would be appreciated. The lights are green and steady and outgoing calls are fine.

Michael
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #1 on: November 01, 2017, 08:02:02 pm »

There are a gazillion posts about this issue on this forum.  See any of the discussions with "Backing Off" in them.

This is a back-end bug that Obihai needs to fix.  There is nothing wrong with your device, and nothing you can do to fix it yourself.
Logged

MMark
Newbie
*
Posts: 13


« Reply #2 on: November 01, 2017, 08:18:24 pm »

I did but I don't see error messages that others are reporting. The lights are fine. Couldn't find a similar case - could you point me to a solution if there's one?
Thanks!

Michael
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #3 on: November 01, 2017, 08:28:14 pm »

I see.  Well, let's try to troubleshoot it, then.

Log onto the Google/Gmail account that holds your Google Voice number, and go to the Settings page.  Do you see your inbound Google Voice number displayed?  If not, then either you are looking at the wrong Google account, or your number was reclaimed (taken back by Google for lack of use).

If you see the number, then continue.  If not, then stop and reply.

Leaving that web browser tab open to your Google Voice settings page, press Ctrl-T to open a new browser tab.  Sign into your OBiTALK account and look at your device (expand it if necessary, to see the status of the service providers).  If you have a working Google Voice connection, it should show "Connected" status.  Does it?  If not, stop and reply.

If anything other than "Connected" status, then click the SPx and, on the next page, click the link to re-authorize your OBi to your Google account.  When doing this, you must make sure to examine the Gmail address it displays during the authentication procedure, and confirm that it is the same as the Gmail address shown in your other browser tab, with the GV number.

Did that work?
Logged

MMark
Newbie
*
Posts: 13


« Reply #4 on: November 01, 2017, 08:39:19 pm »

Everything seems in order and it says Connected on SP1.

Michael
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #5 on: November 01, 2017, 09:08:18 pm »

So, by "seems in order", do you mean that you saw your inbound Google Voice phone number on the Google Voice settings page?  If so, what happens when you call that number from some other phone (not from Google Hangouts, and not from any other Google account)?  It should ring for about 25 seconds before going to Google Voice's voicemail, and then you should be able to leave a message. 

If you don't already have a regular 10-digit forwarding phone number on your Google Voice configuration, add one now, verify it, and confirm that it rings when you call the GV inbound number.

Confirm that you have a check mark to the left of Google Chat on this page:  https://www.google.com/voice/redirection/voice#phones
Logged

MMark
Newbie
*
Posts: 13


« Reply #6 on: November 02, 2017, 05:04:21 am »

Please see my answers below:

So, by "seems in order", do you mean that you saw your inbound Google Voice phone number on the Google Voice settings page? 
YES
If so, what happens when you call that number from some other phone (not from Google Hangouts, and not from any other Google account)?  It should ring for about 25 seconds before going to Google Voice's voicemail, and then you should be able to leave a message. 
CORRECT. Note that when I powercycle OBI the first call gets through.

If you don't already have a regular 10-digit forwarding phone number on your Google Voice configuration, add one now, verify it, and confirm that it rings when you call the GV inbound number.

Confirm that you have a check mark to the left of Google Chat on this page:  https://www.google.com/voice/redirection/voice#phones
I do have the checkmark. Interestingly, when I delete GoogleChat it immediately reappears which didn't happen say 6 months ago. They must have changed something in GV. I tried logging out of Hangouts but it's irrelevant.
 Something must have changed either in the firmware or GV.


Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #7 on: November 02, 2017, 05:48:51 pm »

Please see my answers below:

So, by "seems in order", do you mean that you saw your inbound Google Voice phone number on the Google Voice settings page? 
YES
If so, what happens when you call that number from some other phone (not from Google Hangouts, and not from any other Google account)?  It should ring for about 25 seconds before going to Google Voice's voicemail, and then you should be able to leave a message. 
CORRECT. Note that when I powercycle OBI the first call gets through.

If you don't already have a regular 10-digit forwarding phone number on your Google Voice configuration, add one now, verify it, and confirm that it rings when you call the GV inbound number.

Confirm that you have a check mark to the left of Google Chat on this page:  https://www.google.com/voice/redirection/voice#phones
I do have the checkmark. Interestingly, when I delete GoogleChat it immediately reappears which didn't happen say 6 months ago. They must have changed something in GV. I tried logging out of Hangouts but it's irrelevant.
 Something must have changed either in the firmware or GV.



Hangouts has nothing to do with this.  It operates independently of Chat/XMPP.

Firmware level has nothing to do with this.

Deleting the "Google Chat" forwarding destination doesn't do anything.

You didn't perform the test I requested:  forget about the OBi for a moment.  Add and verify a 10-digit US telephone number as a linked/forwarding number.  Make several calls to your inbound GV number, from several different telephone carriers (e.g. a land line carrier and a mobile carrier), and confirm that they always ring the forwarding phone number.
Logged

MMark
Newbie
*
Posts: 13


« Reply #8 on: November 02, 2017, 08:04:05 pm »

I see. To add an entirely different number. Let me try it and I will get back to you.
Thanks!

M
Logged
MMark
Newbie
*
Posts: 13


« Reply #9 on: November 02, 2017, 08:27:30 pm »

I added a US number in addition to Google chat and both my GV number and this number ring when GV number is called. When I uncheck the US number and call GV it says that GV is not available and asks to leave a message.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #10 on: November 02, 2017, 08:29:00 pm »

Well then, it's working.
Logged

MMark
Newbie
*
Posts: 13


« Reply #11 on: November 02, 2017, 08:32:34 pm »

I'm not sure why do I need this second number to be there. All I need is for the GV number to ring the phone attached to OBI.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #12 on: November 02, 2017, 09:29:52 pm »

I asked you to add a linked telephone number so we could test inbound calling to your Google Voice number, subsequently forwarding to a linked number.

Google Voice is not a free VoIP trunk.  It's a comprehensive inbound call, text and voicemail management system.  OBi devices act as Google Chat XMPP clients.  When someone calls your inbound Google Voice phone number, Google Voice forwards the call to your list of check-marked forwarding destinations, which can be up to six regular telephone numbers, and/or to Chat, and to any Hangouts clients that are set to ring on inbound calls.

Given that it is working now, you can remove the check mark from your 10-digit phone number.  I recommend leaving it on your account, as it is the only way to record a voicemail greeting, and to access your voicemail messages over the phone.
Logged

MMark
Newbie
*
Posts: 13


« Reply #13 on: November 03, 2017, 04:42:59 am »

I tested it again this morning and it's not working even with the other phone checked. By not working I mean that the other phone rings but not the GV phone attached to OBI. It's a similar pattern - it works once and then stops. Same will happen if I power cycle the unit. Possibly after some idle time it goes into hibernation.
Logged
MMark
Newbie
*
Posts: 13


« Reply #14 on: November 05, 2017, 05:24:31 pm »

Here's the latest: I powered down and up the OBI unit, added a 10 digit phone to GV forwarding and both phones rang on incoming calls. I then uncheked the second phone in GV "transfer" setup and nothing rang. So I checked it back and disabled just ringing leaving it checked. The GV phone worked so far on incoming calls, we'll see what happens tomorrow.
Logged
MMark
Newbie
*
Posts: 13


« Reply #15 on: November 15, 2017, 05:58:08 pm »

This problem hasn't been resolved yet. Calls on SP1 are not ringing. I've setup an entirely new number on SP2 and it's working just fine for both incoming and outgoing calls. Steve, any advice would be appreciated.
Thanks!

Michael
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3972



« Reply #16 on: November 15, 2017, 06:14:21 pm »

I'm sorry, but I don't understand what you're doing with your configuration on both the Google Voice and OBiTALK portals.  I'm not going to try to diagnose it further.

At this point, I'd recommend that you give up on Google Voice, and instead sign up for a phone number with a SIP VoIP service provider, or port your Google Voice number to that provider.  Callcentric, voip.ms or Anveo should suit your needs, and each one has a pre-built configuration template on the OBiTALK portal, under the "OBiTALK compatible service providers" section.

For example, Callcentric will port in numbers for free, and their choices of monthly rate plans include E911 service and caller ID name service, and free voicemail.
Logged

MMark
Newbie
*
Posts: 13


« Reply #17 on: November 15, 2017, 06:30:48 pm »

I had a simple Obi200/GV setup that stopped working for some reason on incoming calls. I have no idea why. I thought it's the phone or the router but getting a new phone # on a new Gmail acct and adding it to SP2 is working perfectly and calls get through on that second #.
Where else to look?
One clue is that when I delete Google Chat it immediately reappears. Very different from what it used to be.
Logged
LTN1
Sr. Member
****
Posts: 478


« Reply #18 on: November 15, 2017, 09:22:26 pm »

I had a simple Obi200/GV setup that stopped working for some reason on incoming calls. I have no idea why. I thought it's the phone or the router but getting a new phone # on a new Gmail acct and adding it to SP2 is working perfectly and calls get through on that second #.
Where else to look?
One clue is that when I delete Google Chat it immediately reappears. Very different from what it used to be.

There is a high probability of user error with the first GV setup--likely done after usage. Obviously, when you set up a new GV account on SP2, it works fine. Why? Because it hasn't yet been tampered by user error.
Logged
MMark
Newbie
*
Posts: 13


« Reply #19 on: November 16, 2017, 05:07:23 pm »

I'm not sure what the user error means... I tried factory reset, etc. I now switched SP1 and SP2 accounts, let's see what happens.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC