December 17, 2017, 09:19:21 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Simonics Stopped Working for Incoming Calls  (Read 535 times)
yehob150
Jr. Member
**
Posts: 21


« on: December 11, 2017, 05:47:00 pm »

As the title says, was using Simonics on my Obi 110 for about a week with no issues.
Starting today no calls ring the Obi, just go straight to voicemail.
Using the gmail web browser, incoming calls do go through so nothing wrong with google voice/chat.

However outgoing calls still work through the obi/simonics system.

Still using TLS port 5061.

Tried deleting and resetting with no help. Status still says "Registered" in Obi

Anyone?
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3973



« Reply #1 on: December 11, 2017, 05:53:52 pm »

1) Go to the old, "Legacy" Google Voice web page, on the Phones tab. Make sure you are looking at the correct Google/Gmail/GV account.  Make sure there is a check mark to the left of Google Chat.  Go to this page:

https://myaccount.google.com/security#connectedapps

Click the blue "MANAGE APPS" link, and delete the authorizations for OBiTALK and for Simonics GVGW (see my screenshot attached below).

Press Ctrl-T to open a new browser tab.  Sign into the Simonics GVGW site and re-authorize it to access your Google Voice service.


* Screenshot 2017-12-11 at 17.52.46.png (71.83 KB, 956x707 - viewed 23 times.)
Logged

Taoman
Hero Member
*****
Posts: 945


« Reply #2 on: December 11, 2017, 06:22:52 pm »


Still using TLS port 5061.

Interesting. I know Simonics supports that configuration but I could never get it to work. I could register just fine but incoming calls never worked. If I remember right I could make outgoing calls which sounds like your current experience.

This might be a question best answered by Bill Simon. He might have an idea as to what might be blocking incoming calls when using TLS.

However, I would still try SteveInWA's suggestion. Certainly can't hurt.
Logged
billsimon
Jr. Member
**
Posts: 47


« Reply #3 on: December 11, 2017, 06:37:52 pm »

Using the gmail web browser, incoming calls do go through so nothing wrong with google voice/chat.

As far as I know, calls will ALWAYS ring in your web browser if you have Hangouts up, regardless of the setting of Google Chat as a forwarding target.
Logged
billsimon
Jr. Member
**
Posts: 47


« Reply #4 on: December 11, 2017, 06:40:05 pm »

Interesting. I know Simonics supports that configuration but I could never get it to work. I could register just fine but incoming calls never worked. If I remember right I could make outgoing calls which sounds like your current experience.

This might be a question best answered by Bill Simon. He might have an idea as to what might be blocking incoming calls when using TLS.

It should work fine. I use TLS for my connections to GVGW via Asterisk and the Grandstream Wave softphone. Be sure you have disabled media encryption/SRTP. Even if you set it to optional it will likely fail to negotiate and incoming calls will be rejected with a SIP 488 Not Acceptable message or similar.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3973



« Reply #5 on: December 11, 2017, 06:54:17 pm »

Using the gmail web browser, incoming calls do go through so nothing wrong with google voice/chat.

As far as I know, calls will ALWAYS ring in your web browser if you have Hangouts up, regardless of the setting of Google Chat as a forwarding target.

Good point, and yes, that's right.  The web browser user interface is, in fact, Hangouts, not Google Voice, and each Hangouts client, be it on a computer's web browser, or on an Android or iOS device, has its own, individual toggle switch setting to ring or not ring on inbound calls.  There is no setting in Google Voice itself that controls call behavior in Hangouts.
Logged

yehob150
Jr. Member
**
Posts: 21


« Reply #6 on: December 11, 2017, 07:14:25 pm »

Interesting. I know Simonics supports that configuration but I could never get it to work. I could register just fine but incoming calls never worked. If I remember right I could make outgoing calls which sounds like your current experience.

This might be a question best answered by Bill Simon. He might have an idea as to what might be blocking incoming calls when using TLS.

It should work fine. I use TLS for my connections to GVGW via Asterisk and the Grandstream Wave softphone. Be sure you have disabled media encryption/SRTP. Even if you set it to optional it will likely fail to negotiate and incoming calls will be rejected with a SIP 488 Not Acceptable message or similar.

So i tried revoking and reauthorizing google voice with no change.
It is set to forward calls to google chat
again, it was working a day ago and I didn't change any settings so I'm stumped why it stopped working
Logged
yehob150
Jr. Member
**
Posts: 21


« Reply #7 on: December 11, 2017, 07:20:20 pm »

Interesting. I know Simonics supports that configuration but I could never get it to work. I could register just fine but incoming calls never worked. If I remember right I could make outgoing calls which sounds like your current experience.

This might be a question best answered by Bill Simon. He might have an idea as to what might be blocking incoming calls when using TLS.

It should work fine. I use TLS for my connections to GVGW via Asterisk and the Grandstream Wave softphone. Be sure you have disabled media encryption/SRTP. Even if you set it to optional it will likely fail to negotiate and incoming calls will be rejected with a SIP 488 Not Acceptable message or similar.

I never enabled media encryption.... don't even know how to
And side note, I switched back to UDP 5060 and still can't get incoming calls...
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3973



« Reply #8 on: December 11, 2017, 07:22:31 pm »

Try setting up GVGW on SP2 instead of SP1.  What happens?
Logged

yehob150
Jr. Member
**
Posts: 21


« Reply #9 on: December 11, 2017, 07:43:58 pm »

Try setting up GVGW on SP2 instead of SP1.  What happens?

Interestingly SP2 works.
Just tried resetting all SP1 settings that I could and tried again and that works finally for SP1.
Thank you!

Did notice a 1-2 second delay after the person picks up (the first "hello" isn't heard). Is this normal?

I spent too much time tonight but will try TLS 5061 again perhaps tomorrow- but if it's buggy I don't want to risk this happening again...
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3973



« Reply #10 on: December 11, 2017, 07:49:44 pm »

So, you had some left-over setting on SP1 from the previous configuration.

For anyone else reading, if/when this happens, and you can't figure out why, the easiest thing to do is to:
  • Delete your OBi completely off of the OBiTALK dashboard, and wait a few minutes while OBiTALK remotely resets the device.
  • Restore the OBi to factory defaults by picking up the attached phone and keying in ***8 then 1 to confirm, then wait while it performs the factory restore, which takes several minutes.  Do not proceed until the power LED stops blinking.
  • Add the OBi back to the OBiTALK web portal by using the **5 procedure.
  • Configure the SP again to use GVGW.

The delay is normal when using the gateway.  If it bothers you, consider buying a new OBi device (ATA or IP phone), which natively supports Google Voice, and won't have that delay.
Logged

yehob150
Jr. Member
**
Posts: 21


« Reply #11 on: December 12, 2017, 04:10:35 pm »

So, you had some left-over setting on SP1 from the previous configuration.

For anyone else reading, if/when this happens, and you can't figure out why, the easiest thing to do is to:
  • Delete your OBi completely off of the OBiTALK dashboard, and wait a few minutes while OBiTALK remotely resets the device.
  • Restore the OBi to factory defaults by picking up the attached phone and keying in ***8 then 1 to confirm, then wait while it performs the factory restore, which takes several minutes.  Do not proceed until the power LED stops blinking.
  • Add the OBi back to the OBiTALK web portal by using the **5 procedure.
  • Configure the SP again to use GVGW.

The delay is normal when using the gateway.  If it bothers you, consider buying a new OBi device (ATA or IP phone), which natively supports Google Voice, and won't have that delay.

It stopped working again.
This time it rings the home phone, but when picking up the phone (on even the first ring) the person doesn't hear anything. The dialer hears many rings and then it goes to Google voice voicemail. So basically the ringing is going through but its not connecting the call....

This was working fine 24 hours ago and I haven't made any changes...
Logged
yehob150
Jr. Member
**
Posts: 21


« Reply #12 on: December 12, 2017, 04:43:27 pm »

and tried deleting SP1 and entered my info into SP2 and the same thing happened.
Incoming calls rings but call doesn't connect and the dialer (after a bunch of rings) goes to voicemail even if the ringing phone is picked up.
Is the Simonics gateway overloaded?
Logged
billsimon
Jr. Member
**
Posts: 47


« Reply #13 on: December 12, 2017, 04:53:54 pm »

No. Your symptoms are probably from NAT or SIP ALG causing you problems. The symptoms are that signaling works ok (ringing, calling out) but there is one-way or no audio. SIP can be a little more difficult to configure than Google Voice and more susceptible to router/firewall/ISP interference.
Logged
yehob150
Jr. Member
**
Posts: 21


« Reply #14 on: December 12, 2017, 05:19:58 pm »

No. Your symptoms are probably from NAT or SIP ALG causing you problems. The symptoms are that signaling works ok (ringing, calling out) but there is one-way or no audio. SIP can be a little more difficult to configure than Google Voice and more susceptible to router/firewall/ISP interference.

sorry but I don't understand....
I have Fios as my ISP, and other than the standard router based firewall that doesn't cause me any issues ever there shouldn't be any firewall blocking.

Also, I tried deleting/factory resetting/re-setting up my Obi110. The first call went through after a 4 second delay.
However incoming calls 2,3,4... are not working.
Again, they ring the phone, but the person picks up doesn't hear anything, and the one dialing in (from an outside line) just hears rings until getting to voicemail.

So what do I do?
Logged
Taoman
Hero Member
*****
Posts: 945


« Reply #15 on: December 13, 2017, 06:35:08 pm »


So what do I do?

Does your router have a SIP ALG (or just alg) setting? Yes or no? If yes, is it enabled?

I would set up a softphone on your computer and configure it for Simonics and see if you have the same symptoms. I would suggest trying Phonerlite unless you have another preference.
Logged
yehob150
Jr. Member
**
Posts: 21


« Reply #16 on: December 13, 2017, 06:53:19 pm »


So what do I do?

Does your router have a SIP ALG (or just alg) setting? Yes or no? If yes, is it enabled?

I would set up a softphone on your computer and configure it for Simonics and see if you have the same symptoms. I would suggest trying Phonerlite unless you have another preference.

i have tomato by shibby.
Under "tracking/nat helpers" I have SIP's check box checked. RTSP's check box is unchecked. This is the default.
Does this need to be changed?

The problem is that this is very unreliable. Today for instance it is working again- but who knows what will happen tomorrow. And it is really hard to test these things when sometimes it works and other times it doesn't.
Logged
Taoman
Hero Member
*****
Posts: 945


« Reply #17 on: December 13, 2017, 07:08:34 pm »


The problem is that this is very unreliable. Today for instance it is working again- but who knows what will happen tomorrow. And it is really hard to test these things when sometimes it works and other times it doesn't.

Indeed. When you get inconsistent results it is hard to troubleshoot.

Quote
Under Advanced > Conntrack/Netfilter, in the Tracking/NAT Helpers section, if SIP is checked, SIP ALG is enabled

I would uncheck SIP, restart everything, and see if anything changes.

I would also still try a softphone. The goal is to try and isolate where the problem is. Trying a softphone may help in troubleshooting.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC