Simon Telephonics Google Voice Gateway info

Started by billsimon, November 11, 2017, 08:41:58 AM

Previous topic - Next topic

Gogyroswin

I switched over to Simonics this morning to revive my Obi 110. Seems to be working fine. Thanks Bill! I am having an issue that I no longer get the stutter tone if there is a voice mail pending on GV. I have Voicemail Notification for Phone 1 active on the configuration page. Is there something else I need to do to enable the stutter/voicemail indicator?

ceg3

I think he will tell there is no MWI for GV.

billsimon

That's correct. Google Voice does not provide us a message waiting indicator thus we do not relay one to your device.

You must have been using an old (pre-oauth2) firmware if you were still getting GV message waiting indicators.

jgjg

#63
I'm still waiting for your invitation mail. I did not request for all devices I have, so just submitted for another one yesterday. Thank you for your work, Bill.

proteus

@billsimon

What service do you use for CNAM lookups?

oreader

#65
Thanks Simon for saving my Obi100. Now I want to explore some of the additional features. I am a complete novice, so any expanded instructions for these two features would be appreciated:

-Register multiple extensions, all tied to your Google Voice number. Call and transfer calls between them like a miniature phone system.

-Receive faxes by e-mail. Here is what happened when I had topfreefax.com fax my own phone #:
1. I got an email that said: Transmission Status: Failed. Reason for Failure: No remote fax device. Attached to this email was the contents of the fax, but this email goes to the sender, not the receiver.
2. I received a 51 second voice mail from (000)000-0000 <-- yes, it showed as all zeros, that appeared in hangouts. The phone did not ring, and the call did not show up in Google Voice history. The voice mail was a series of beeps. So the receiver does not get the fax.

billsimon

@proteus - the CNAM provider is Telo.

@oreader - support.simonics.com FAQ section describes how you can register multiple devices to the same GVGW account, and how you can register them with extension numbers in order to dial between them like a PBX.

The fax service (remember: experimental) works by clicking "Receive Fax" on the GVGW dashboard. From then on all calls are directed to the fax service which will receive the fax and e-mail it to you. If you don't want the fax service to answer, you need to go back to the dashboard and use the "Clear URI" button to unset the fax option. Then calls will be sent to your registered Obi device instead.

vtsnaab

Here are the exact links to those details:

1st:
http://support.simonics.com/support/solutions/articles/3000031438

2nd:
http://support.simonics.com/support/solutions/articles/3000031447

The search feature is a little less than helpful & the articles' names don't make them easy to find.

For us, the best thing is having multiple accounts at GVGW as to keep our ATAs on separated lines.

tone_la

#68
Hello all.  I've been trying to get Simonics GVGW working for the past few days, but no luck so far.  I've followed the instructions closely and read all of the suggestions in this thread.  So far, nothing fixes the issue.  I have an OBI100 with 2886 firmware configured with Google Voice.  Was previously configured with Vestalink VoIP.  I've reset the OBI multiple times using both the OBI button and the ***8 reset from handset.

Before configuring GVGW, I have Google Voice working correctly on the OBI and am receiving and making calls with no issues; bi-directional voice works.  Once I configure GVGW, the portal successfully shows as "Registered" on SP1.

But, here is the behavior:

- Outbound calls from OBI to my cell phone work and my voice can be heard by the cell phone.  However, I can't hear anything back from the cell phone.

- Inbound calls from my cell phone to OBI are not received by OBI.  Instead they are received only by Google Voice and my computer rings.

Can someone please help me troubleshoot this behavior?  I've done all I can do and now relying on the good folks in this forum.  Thank you!


GPz1100

I would start by connecting the obi box directly to your modem and retest.  Make sure you reboot the modem after connecting the obibox and later when reconnecting your router.  This will determine if it's a firewall (router) issue or a obi/gv config issue.  My money is on this being a firewall issue.

Taoman

Quote from: tone_la on February 12, 2018, 07:23:51 PM

Before configuring GVGW, I have Google Voice working correctly on the OBI and am receiving and making calls with no issues; bi-directional voice works.  Once I configure GVGW, the portal successfully shows as "Registered" on SP1.


Did you delete your Google Voice config before configuring GVGW or is it also still configured on your OBi?

What kind of router do you have? Does it have a SIP ALG setting?

Connecting your OBi directly to your modem (temporarily bypassing your router) as GPz1100 suggested would be a good test.

tone_la

Quote from: GPz1100 on February 12, 2018, 07:59:06 PM
I would start by connecting the obi box directly to your modem and retest.  Make sure you reboot the modem after connecting the obibox and later when reconnecting your router.  This will determine if it's a firewall (router) issue or a obi/gv config issue.  My money is on this being a firewall issue.

Good idea here, thanks!  I'll try to do this later tonight and try to rule out the router.  You are correct in your assumption that the OBI is connected to an Asus router, then connecting to a cable modem.  I'll report back on this later today.

tone_la

Quote from: Taoman on February 12, 2018, 11:05:17 PM
Quote from: tone_la on February 12, 2018, 07:23:51 PM

Before configuring GVGW, I have Google Voice working correctly on the OBI and am receiving and making calls with no issues; bi-directional voice works.  Once I configure GVGW, the portal successfully shows as "Registered" on SP1.


Did you delete your Google Voice config before configuring GVGW or is it also still configured on your OBi?

What kind of router do you have? Does it have a SIP ALG setting?

Connecting your OBi directly to your modem (temporarily bypassing your router) as GPz1100 suggested would be a good test.

Yes, Google Voice was previously on SP1.  Per the instructions, I deleted that first before configuring GVGW.

My router is an Asus RT-AC66R.  It has a setting called "SIP Passthrough" in the WAN/NAT section and the setting is enabled.  Only setting disabled in this section is "Enable PPoE Relay".

tone_la

Quote from: tone_la on February 12, 2018, 07:23:51 PM
Hello all.  I've been trying to get Simonics GVGW working for the past few days, but no luck so far.  I've followed the instructions closely and read all of the suggestions in this thread.  So far, nothing fixes the issue.  I have an OBI100 with 2886 firmware configured with Google Voice.  Was previously configured with Vestalink VoIP.  I've reset the OBI multiple times using both the OBI button and the ***8 reset from handset.

Before configuring GVGW, I have Google Voice working correctly on the OBI and am receiving and making calls with no issues; bi-directional voice works.  Once I configure GVGW, the portal successfully shows as "Registered" on SP1.

But, here is the behavior:

- Outbound calls from OBI to my cell phone work and my voice can be heard by the cell phone.  However, I can't hear anything back from the cell phone.

- Inbound calls from my cell phone to OBI are not received by OBI.  Instead they are received only by Google Voice and my computer rings.

Can someone please help me troubleshoot this behavior?  I've done all I can do and now relying on the good folks in this forum.  Thank you!



Update:  My phone connected to OBI now rings on incoming calls and shows the callerid from GVGW.  However, still no inbound voice, but they can hear me.

Also, I temporarily disabled the firewall on the ASUS router, no change.  I'll still do the test connecting directly to the modem, but I can't do this until the end of the day.

Taoman

Quote from: tone_la on February 13, 2018, 08:33:05 AM

My router is an Asus RT-AC66R.  It has a setting called "SIP Passthrough" in the WAN/NAT section and the setting is enabled. 

My RT-AC68U is set for "Enabled + NAT helper" for SIP Passthrough.

tone_la

#75
Quote from: Taoman on February 13, 2018, 10:30:24 AM
Quote from: tone_la on February 13, 2018, 08:33:05 AM

My router is an Asus RT-AC66R.  It has a setting called "SIP Passthrough" in the WAN/NAT section and the setting is enabled.

My RT-AC68U is set for "Enabled + NAT helper" for SIP Passthrough.

Thanks for the info.  Your router is one step "better" than mine I guess.  I have these options under NAT, no NAT helper.  Allowed values are only Enable or Disable:

PPTP Passthrough   
L2TP Passthrough   
IPSec Passthrough   
RTSP Passthrough   
H.323 Passthrough   
SIP Passthrough   
Enable PPPoE Relay

All are enabled except the last one.  Tried flipping "SIP Passthrough" to disabled, but still no joy, so flipped it back.

tone_la

Quote from: tone_la on February 12, 2018, 07:23:51 PM
Hello all.  I've been trying to get Simonics GVGW working for the past few days, but no luck so far.  I've followed the instructions closely and read all of the suggestions in this thread.  So far, nothing fixes the issue.  I have an OBI100 with 2886 firmware configured with Google Voice.  Was previously configured with Vestalink VoIP.  I've reset the OBI multiple times using both the OBI button and the ***8 reset from handset.

Before configuring GVGW, I have Google Voice working correctly on the OBI and am receiving and making calls with no issues; bi-directional voice works.  Once I configure GVGW, the portal successfully shows as "Registered" on SP1.

But, here is the behavior:

- Outbound calls from OBI to my cell phone work and my voice can be heard by the cell phone.  However, I can't hear anything back from the cell phone.

- Inbound calls from my cell phone to OBI are not received by OBI.  Instead they are received only by Google Voice and my computer rings.

Can someone please help me troubleshoot this behavior?  I've done all I can do and now relying on the good folks in this forum.  Thank you!


Solution found!  :)

Step 2 in the instructions says to delete the Service Provider (SP1 or SP2) used by Google Voice.  BUT... there is another deletion that was needed to enable my service and fully clear the past OBI configuration.  In the "Device Information" section in the OBI portal (just above the Service Provider section), there is a button called "Delete Device".  Once I pressed this and again reconfigured OBI, it worked!  ;D ;D ;D Evidently my past service provider "Vestalink" made a change here that is incompatible with Simonics GVGW.

THANK YOU to GPz1100 and Taoman for offering your helpful suggestions!  Hoping SteveInWA will edit the step by step instructions to include the device deletion so that others won't have this issue.

SteveInWA

Quote from: tone_la on February 13, 2018, 06:13:12 PM
Quote from: tone_la on February 12, 2018, 07:23:51 PM
Hello all.  I've been trying to get Simonics GVGW working for the past few days, but no luck so far.  I've followed the instructions closely and read all of the suggestions in this thread.  So far, nothing fixes the issue.  I have an OBI100 with 2886 firmware configured with Google Voice.  Was previously configured with Vestalink VoIP.  I've reset the OBI multiple times using both the OBI button and the ***8 reset from handset.

Before configuring GVGW, I have Google Voice working correctly on the OBI and am receiving and making calls with no issues; bi-directional voice works.  Once I configure GVGW, the portal successfully shows as "Registered" on SP1.

But, here is the behavior:

- Outbound calls from OBI to my cell phone work and my voice can be heard by the cell phone.  However, I can't hear anything back from the cell phone.

- Inbound calls from my cell phone to OBI are not received by OBI.  Instead they are received only by Google Voice and my computer rings.

Can someone please help me troubleshoot this behavior?  I've done all I can do and now relying on the good folks in this forum.  Thank you!


Solution found!  :)

Step 2 in the instructions says to delete the Service Provider (SP1 or SP2) used by Google Voice.  BUT... there is another deletion that was needed to enable my service and fully clear the past OBI configuration.  In the "Device Information" section in the OBI portal (just above the Service Provider section), there is a button called "Delete Device".  Once I pressed this and again reconfigured OBI, it worked!  ;D ;D ;D Evidently my past service provider "Vestalink" made a change here that is incompatible with Simonics GVGW.

THANK YOU to GPz1100 and Taoman for offering your helpful suggestions!  Hoping SteveInWA will edit the step by step instructions to include the device deletion so that others won't have this issue.

In the very large majority of cases, there's no need to delete the device.  You just happened to have some left-over configuration mess on your OBi.  Given that the dreadful Vestalink seems finally dead, I'm not going to worry about this.

tone_la

#78
Quote from: SteveInWA on February 13, 2018, 06:55:02 PM
Quote from: tone_la on February 13, 2018, 06:13:12 PM
Quote from: tone_la on February 12, 2018, 07:23:51 PM
Hello all.  I've been trying to get Simonics GVGW working for the past few days, but no luck so far.  I've followed the instructions closely and read all of the suggestions in this thread.  So far, nothing fixes the issue.  I have an OBI100 with 2886 firmware configured with Google Voice.  Was previously configured with Vestalink VoIP.  I've reset the OBI multiple times using both the OBI button and the ***8 reset from handset.

Before configuring GVGW, I have Google Voice working correctly on the OBI and am receiving and making calls with no issues; bi-directional voice works.  Once I configure GVGW, the portal successfully shows as "Registered" on SP1.

But, here is the behavior:

- Outbound calls from OBI to my cell phone work and my voice can be heard by the cell phone.  However, I can't hear anything back from the cell phone.

- Inbound calls from my cell phone to OBI are not received by OBI.  Instead they are received only by Google Voice and my computer rings.

Can someone please help me troubleshoot this behavior?  I've done all I can do and now relying on the good folks in this forum.  Thank you!


Solution found!  :)

Step 2 in the instructions says to delete the Service Provider (SP1 or SP2) used by Google Voice.  BUT... there is another deletion that was needed to enable my service and fully clear the past OBI configuration.  In the "Device Information" section in the OBI portal (just above the Service Provider section), there is a button called "Delete Device".  Once I pressed this and again reconfigured OBI, it worked!  ;D ;D ;D Evidently my past service provider "Vestalink" made a change here that is incompatible with Simonics GVGW.

THANK YOU to GPz1100 and Taoman for offering your helpful suggestions!  Hoping SteveInWA will edit the step by step instructions to include the device deletion so that others won't have this issue.

In the very large majority of cases, there's no need to delete the device.  You just happened to have some left-over configuration mess on your OBi.  Given that the dreadful Vestalink seems finally dead, I'm not going to worry about this.

If it helps even 1 person, isn't it worth updating?  What if there is an issue with some other VoIP config?  Yeah, probably Vestalink is the only one using OBI, but people still may be transferring out from them.  It was VERY difficult getting my number ported out of Vestalink and their staff was not much help!  Took me 3 weeks and MANY hours trying to communicate with them.  So glad I'm finally back on GV and using the GVGW!

nang

My OBI110 on simonics was working fine for months since I got it. Now from last few weeks I randomly get no service configured and I had to reboot my OBI110 that fixes it. Any one else? Any fix? Is this OBI or Simonics?