December 14, 2017, 07:01:46 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: OBI200 - 2 Google Voice accounts, SP1 works/ SP2 won't ring  (Read 671 times)
ernbot
Newbie
*
Posts: 12


« on: December 01, 2017, 10:47:00 am »

I have an OBI200 device configured with two Google Voice accounts.  The first on SP1 works fine.  I can make calls and receive them with no issue.  The second account on SP2 will make outgoing calls fine but will not ring on incoming calls.  I followed the guides for both but can figure it out.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #1 on: December 01, 2017, 11:31:11 am »

Using a desktop or laptop computer's web browser, not a phone or tablet, sign into the Google account (Gmail address and password) that you configured on SP2.  Go to the old, "Legacy" settings, on the Phones tab.  Make sure you see your inbound Google Voice number on the left side of the page, under "Your number".  If it says "Get a voice number" or "Access number", then this account has no inbound number to ring.  Look at the right side of the page, and make sure you have a check mark to the left of Google Chat.
« Last Edit: December 03, 2017, 06:10:36 pm by SteveInWA » Logged

ernbot
Newbie
*
Posts: 12


« Reply #2 on: December 01, 2017, 04:41:57 pm »

Thanks for the reply.  I definitely have followed those instructions and confirmed that Google Chat is checked but the OBI device still won't ring.  I receive calls through Hangouts and all of the other forwarded numbers.



* gv_config.png (31.92 KB, 918x571 - viewed 22 times.)
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #3 on: December 01, 2017, 04:48:46 pm »

Thanks for the screenshot.

I suggest that you completely delete the SP2 configuration, and then add it again, making sure you are signed into the correct Google account.
Logged

ernbot
Newbie
*
Posts: 12


« Reply #4 on: December 01, 2017, 09:51:46 pm »

Deleted and reconfigured the account, but still no luck. Embarrassed
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #5 on: December 02, 2017, 01:54:14 pm »

Do inbound calls ring your mobile phone?
Logged

ernbot
Newbie
*
Posts: 12


« Reply #6 on: December 03, 2017, 01:59:32 pm »

I didn't have my mobile configured, as it's associated with another GV account.  I added it, made sure it rang, but it didn't make a difference.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #7 on: December 03, 2017, 02:03:04 pm »

If inbound calls to your Google Voice number are successfully forwarded to your linked mobile phone number, which rings and can be answered, then there is nothing wrong with your Google Voice setup.  You are likely authenticating OBiTALK to a different Google account -- not the one that holds the Google Voice number.

Try again.  Look closely at the Gmail address of the Google account shown in your screenshot of the Google Voice web page.  From the OBiTALK dashboard, click on the SP (SP1 through SP4) that you set up with Google Voice.  Look at the Gmail address it displays.  If it's wrong, click the link to correct it.
Logged

ernbot
Newbie
*
Posts: 12


« Reply #8 on: December 03, 2017, 02:27:52 pm »

It is most definitely logged into the correct account.

For troubleshooting purposes, I removed all the accounts and swapped the order of the two GV accounts.

The GV account (that previously wouldn't ring) provisioned on SP1, now rings, and the other on SP2 now doesn't ring.  This leads me to believe that there's something wrong with the OBi200.  I does have the latest firmware.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #9 on: December 03, 2017, 02:39:32 pm »

It's impossible for this to be a hardware problem.  It's just firmware running on a CPU inside the OBi, and if it works on one SP, it should work on all SPs.

I suggest that you start completely over.

Delete the OBi 200 completely off of your OBiTALK dashboard.  Wait a few minutes while OBiTALK remotely resets your device, and the power LED stops flashing.  Then, pull all three plugs out of the OBi (telephone, Ethernet and power).

Turn the OBi upside-down on a flat surface.  Find the small bump with the hole in it.  Using a straightened paper clip, gently depress the recessed button until you feel a click.  Continue to hold down the button while you plug in only the power plug.  Wait at least 10 seconds or longer.  Release the button.  Wait another couple minutes until the LEDs settle down.  Pull the power plug.

Log into each of the two Google accounts, one at a time, and go to this page:  https://myaccount.google.com/security?pli=1#connectedapps

Look at the section that says "Apps with access to your account".  Click the link that says "MANAGE APPS".  On the next page, find and delete the OBiTALK Google Voice item.  Sign out of the account, and repeat this with the other account, then sign out of that account.

Plug back in the Ethernet and phone plugs.  Plug in the power plug.  Wait for it to boot up.  Add it back to the portal, using the **5 procedure.  Do NOT make any changes on the local web page (192.168.x.x or 10.0.x.x).  Just follow the steps to configure Google Voice on SP1 and SP2.
Logged

ernbot
Newbie
*
Posts: 12


« Reply #10 on: December 03, 2017, 03:25:13 pm »

I just went through the process. 

1. Delete OBi200 from dashboard
2. Reset device, held button down until the status light went from red to flashing green, to steady green, etc.
3. Removed apps access to OBi Talk in each Google account.
Reconnected phone and provisioned accounts using the Obi Dashboard.

I get the same result the account configured to SP1 rings but the account on SP2 will not.  I can make outbound calls fine on both accounts.  I'm stumped.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #11 on: December 03, 2017, 03:37:44 pm »

Try defining the 2nd GV account on SP3 or SP4.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #12 on: December 03, 2017, 03:49:31 pm »

You need to click and add a check-mark to the box on the SP configuration page that says "Incoming Calls Will Ring On".
Logged

azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #13 on: December 03, 2017, 04:46:05 pm »

You need to click and add a check-mark to the box on the SP configuration page that says "Incoming Calls Will Ring On".

That option is for the OBi202. The OBi200 doesn't have that option and will default to Phone1.
« Last Edit: December 03, 2017, 05:07:32 pm by azrobert » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #14 on: December 03, 2017, 05:29:28 pm »

Yes, the OBi 200 does have that setting.

See below.


* screenshot-www.obitalk.com-2017-12-03-17-26-44-697.png (152.62 KB, 881x630 - viewed 25 times.)
Logged

SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #15 on: December 03, 2017, 06:14:40 pm »

Upon re-reading your posts:

In this post, http://www.obitalk.com/forum/index.php?topic=13234.msg85087#msg85087 you provided a screenshot of the account that supposedly won't ring.  I then asked you if it rang on your mobile phone, which was shown on that screenshot.  You replied in a subsequent post that you didn't have a mobile phone configured on the problem account, which is clearly incorrect, if viewing the earlier-linked screenshot.  So, I still doubt that you are working with the correct accounts on both the Google Voice and OBiTALK sides.  Something's fishy.
Logged

azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #16 on: December 03, 2017, 06:19:51 pm »

I have 2 GV accounts defined on my OBi200 and neither one has that option.  Maybe it's just for SIP accounts. I have 2 SIP accounts that I can't check. The dashboard lists them as undefined because they were manually defined.


* Capture.PNG (32.79 KB, 675x580 - viewed 18 times.)
Logged
Taoman
Hero Member
*****
Posts: 942


« Reply #17 on: December 03, 2017, 06:20:51 pm »

You need to click and add a check-mark to the box on the SP configuration page that says "Incoming Calls Will Ring On".
Interesting. For my Callcentric and Anveo DIDs I have that option but for VoIP.ms, Simonics, and Google Voice that checkbox isn't there on my OBi200s.

However, azrobert's point remains. Checking or unchecking that box on a 200 does absolutely nothing.
« Last Edit: December 03, 2017, 06:23:15 pm by Taoman » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #18 on: December 03, 2017, 06:23:01 pm »

Fine.  It's a red herring.

I am pretty certain that this is a PEBCAK issue.  Have you ever heard of a service working on one SP but not another SP?
Logged

ernbot
Newbie
*
Posts: 12


« Reply #19 on: December 03, 2017, 08:15:04 pm »

That "mobile" number is what Google labeled my landline.  Which does ring when dialing my GV.  Not sure what that has to do with OBi200 not ringing. 
There is no checkbox in the configuration screen of my Obi on SP1 with the GV line.

I fully admit that I may have made an error somewhere, but if there's an option or setting I'm missing, I just don't see it. 



I have configured many VoIP, SIP and ATA devices and understand there are nuances but this is frustrating.

Also, as I stated, I swapped the accounts on SP1 and SP2 and the SP2 account still won't ring with no other changes to the GV settings.  I even tried removing all of the numbers from GV and starting over, still not ringing on the OBi200.  One nice benefit of doing this is that I was able to force GV to accept my mobile number on both accounts.  Something I was not able to do before GV updated the interface.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC