December 11, 2017, 08:42:04 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Obi110 ring and 200 to not ring  (Read 2418 times)
MatthewF
Newbie
*
Posts: 16


« on: July 14, 2017, 10:42:51 am »

How can I get my obi110 to ring for my GV number and allow my obi200 to make calls using that same GV number, but without ringing on incoming calls?

I have an obi110 and an obi200. I primarily use the obi110 for my work and have it connected to two GV numbers (work and personal). I have the obi200 connected for my family to a separate family GV number and an e911. All has worked well with this setup for quite a while.

Occasionally I want to make a work call from my home phone and so decided to use the sip3 slot on the 200 to connect to my work GV number with the idea that I could turn off the ringing and use **3 to dial out from my home phone when I wanted to make a work call from my home line. Unfortunately, when I did that, my work phone stopped ringing when someone called my work number.

I saw this similar topic on the forum https://www.obitalk.com/forum/index.php?topic=10454.0 but in that case it sounds a little complex and they want ringing on both lines.

Any suggestions on how to proceed? Should I follow the instructions in that post and then turn off ringing for sip3 on the 200? or is there a better way in this case?
Logged
MatthewF
Newbie
*
Posts: 16


« Reply #1 on: July 14, 2017, 11:34:10 am »

Here's what I did in case it is helpful to any others. So far it is working well, though we'll see if it creates any other problems. Also, if anyone has a better/ simpler solution please let me know.

1) Go to obitalk.com and configure my obi200 (using obiexpert). In this case I'm using sp3 so do the following where XXXXX = the obi number for my 110.

Voice Services -> SP3 Service -> X_InboundCallRoute: pp(XXXXXXX)

2) now configure the obi110.

Voice Services -> obitalk service -> ph,ph2

Which in my case I accomplished just by checking device default.

Essentially this is the same as the solution I linked to except in this case rather than having the 200 send the call to its own ph line plus another obi, it just sends it to the other obi.
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2705


« Reply #2 on: July 14, 2017, 12:34:46 pm »

2) now configure the obi110.

Voice Services -> obitalk service -> ph,ph2

Which in my case I accomplished just by checking device default.
That's odd.  An Obi110 has only one phone port, so ph2 does not make sense.  The default is ph.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3190


« Reply #3 on: July 14, 2017, 02:29:31 pm »

There is a flaw in your new setup. It requires a functioning OBiTalk network. The network has been very stable lately, but it does occasionally go down. If it goes down, you will not be able to receive calls on your OBi110. There are 2 possible solutions to solve this problem.

It is my understanding that the device with the highest priority will receive inbound calls. I have not tried this, so I don't know if it will work. The priority must be greater than 32 with a max of 127. The default is zero which will auto adjust to the highest priority. Set OBi200/SP3 to a low priority and hopefully the OBi110 will start receiving calls. Please post if this works or not.

OBi200:
Voice Services -> SP3 Service -> X_InboundCallRoute: ph,ph2
Voice Services -> SP3 Service -> X_XMPPPriority: 33

If that doesn't work you can delete GV from SP3 then route outbound calls from the OBi200 over the OBiTalk network to the OBi110. You would have the same problem with outbound calls not working from the OBi200 when the OBiTalk is down, but I think that would be preferable than not be able to receive calls. You could use a more complex setup and route calls over your local network and therefore not be reliant on the OBiTalk network. If the priority fix doesn't work, I'll show you how to configure this.

Edit:
I have a test OBi110. I also have an OBi200, but it doesn't have the same GV account as the OBi110 and I don't want to mess with it. I do have a Raspberry Pi with Raspbx that has the same GV account as the OBi110. When I power up the OBi110 it will receive inbound calls, so it looks like the last device to connect to GV will receive calls when both have the same priority.  I then changed the XMPP priority on the OBi110 to 33  and now Raspbx receives inbound calls, so it looks like this will work for you.
« Last Edit: July 14, 2017, 03:40:08 pm by azrobert » Logged
Taoman
Hero Member
*****
Posts: 931


« Reply #4 on: July 14, 2017, 04:28:20 pm »


OBi200:
Voice Services -> SP3 Service -> X_InboundCallRoute: ph,ph2


On an OBi200 or Obi1xx device, what does "ph2" signify?
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3943



« Reply #5 on: July 14, 2017, 09:24:50 pm »


OBi200:
Voice Services -> SP3 Service -> X_InboundCallRoute: ph,ph2


On an OBi200 or Obi1xx device, what does "ph2" signify?

Well, I think Macbeth has that answer.

She should have died hereafter;
There would have been a time for such a word.
To-morrow, and to-morrow, and to-morrow,
Creeps in this petty pace from day to day
To the last syllable of recorded time,
And all our yesterdays have lighted fools
The way to dusty death. Out, out, brief candle!
Life's but a walking shadow, a poor player
That struts and frets his hour upon the stage
And then is heard no more: it is a tale
Told by an idiot, full of sound and fury,
Signifying nothing.

Enter a Messenger


Thou comest to use thy tongue; thy story quickly.
Logged

MatthewF
Newbie
*
Posts: 16


« Reply #6 on: July 26, 2017, 02:14:40 pm »

First off all, sorry for the delay. And thanks for the Macbeth quote. Well deserved. On this point...
2) now configure the obi110.

Voice Services -> obitalk service -> ph,ph2

Which in my case I accomplished just by checking device default.
That's odd.  An Obi110 has only one phone port, so ph2 does not make sense.  The default is ph.
I don't konw why i wrote ph,ph2. Indeed the default is ph and that is what my system shows. Sorry for the confusion.
Logged
MatthewF
Newbie
*
Posts: 16


« Reply #7 on: July 26, 2017, 02:42:41 pm »

Set OBi200/SP3 to a low priority and hopefully the OBi110 will start receiving calls. Please post if this works or not.

OBi200:
Voice Services -> SP3 Service -> X_InboundCallRoute: ph,ph2
Voice Services -> SP3 Service -> X_XMPPPriority: 33

I really like the idea of this solution, but this did not work for me. My obi200 would still ring and not my obi110. However...

when I went to the ip address for my obi110 I saw that it also has this setting (though oddly not through obitalk.com). When I set that like this:

OBi110:
Voice Services -> SP3 Service -> X_XMPPPriority: 127

Then it worked.

Logged
MatthewF
Newbie
*
Posts: 16


« Reply #8 on: December 08, 2017, 04:28:47 pm »

I recently replaced my obi100 with the obi1062. i found that there was one more setting I had to change in order to get the new phone to ring but not the obi200.

Voice Services -> SP3 Service -> X_GTalkSimultaneousRing

Uncheck the box.

That worked.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC