February 24, 2021, 10:24:48 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Multiple Google Voice accounts only working on SP1 on Obihai 202  (Read 6110 times)
J.Mattern
Newbie
*
Posts: 3


« on: May 08, 2018, 12:28:37 pm »

I have had two Google Voice accounts setup on my Obihai 202 working flawlessly since November 2017.  SP1 is a Google Voice number (lets call it...GV1) working on Phone Line 1.  SP2 is a second Google Voice number (lets call it GV2) working on Phone Line 2.  Sometime within the last week or so, SP2 is no longer working.  When I try to dial out a number on Phone Line 2, the Obihai attendant says, "number dialed XXX-XXX-XXXX has not received a response from the service provider". I cannot receive call on that line either though GV is forwarding the number properly to my cell phone (so GV is not the issue).  ObiTalk shows the SP2 status as "Registration Not Required".

What I have done to resolve so far.  Nothing has worked
1. Deleted and re-added SP2
2. Moved SP2 setup (GV2) to SP1 provider slot.  GV2 then works fine in SP1 slot but adding GV1 to SP2 slot gives same error from attendant.
3. Deleted and re-added SP1 and SP2. Renamed them to different names.
4. Restored backup of config
5. Reset to factory defaults then re-added GV1 and GV2 on SP1 and SP2 via ObiTalk setup
6. Ensured that ObiTalk settings are checked in Obi Expert Config
7. Unplugged power and ethernet to 202.
8. Rebooted after each config change
9. Tried updating firmware. received error about checksum
10. Banged head on desk repeatedly
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4089


« Reply #1 on: May 08, 2018, 01:06:20 pm »

OBihai is rolling out new firmware to support Google Voice switch from XMPP to SIP. The current version is build 5859EX.

After a re-boot the GV status should go from "Registration Not Required" to "Connecting" then "Connected". I'm having the same problem with my SP2 getting stuck in "Connecting". Re-booting sometimes fixes the problem. I don't think the OBi does a complete re-boot. In the past the power LED would start to flash red then turn flashing green and finally solid green. Now you don't get the flashing red. I started doing a power re-cycle and it "SEEMS" to have better results than a re-boot. I did see you tried unplugging power.

You could try defining GV2 on SP3. I would appreciate if you report back if this solves the problem or not.
Logged
J.Mattern
Newbie
*
Posts: 3


« Reply #2 on: May 10, 2018, 12:59:38 pm »

I did try the GV2 on SP3 before and it didnt work.  Even tried setting up GV1 on SP2 and GV2 on SP3 with nothing on SP1. No cigar on any of those either.

I do notice that my firmware version is showing as Build 5859EX.  I'm thinking there is a problem with that build as everything seemed to work fine on the Build 5757EX that I had previously.

For the last 2 days I have had only my GV2 line setup on SP1 since this is my more important line to be working.  I just re-added GV1 on SP2 and it did start out as "Registration Not Required" and after several minutes changed to "Connection to 64.9.241.108" (obviously Google's IP) but SP2 never moves to "Connected".  Actually, SP2-SP4 when defined never move to "Connected" even though SP1 always connects just fine regardless of whether I have GV1 or GV2 defined on SP1. 
Logged
J.Mattern
Newbie
*
Posts: 3


« Reply #3 on: May 10, 2018, 01:27:41 pm »

Ok.. Just tried GV2 on SP1 and GV2 on SP4 (SP2 and SP3 are not configured).   Everything is now working.  Not sure why SP2 and SP3 dont function when defined but I'm not going to complain now that it is working properly.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 6204



« Reply #4 on: May 10, 2018, 05:10:17 pm »

Sorry to hear you had some initial issues.  This happens sometimes when your device firmware gets updated, but the configuration on your Google account is still in the progress of being updated.  You're good to go now.
Logged

Joshua
Newbie
*
Posts: 1


« Reply #5 on: January 30, 2019, 10:24:57 am »

I'm having the same issue.

I'm trying to setup Google Voice 1 to SP1 and Google Voice 2 to SP2. I'm getting the error message " Registration Not Required " on both account SP1 and SP2. In the comments, it was suggested to use GV1 to SP1 and GV2 to SP4. There was no problem. It didn't work for me though.

I have one phone with 1 phone line. I was hoping to use 2 Google Voice numbers. So Google Voice 2 is set to ring on primary line and Google Voice 1 will also be on primary line and used for outgoing calls as well.

If I use one Google Voice account, I have no problem with incoming and going calls. I don't get an error message of any kind.  I am wanting to use the second line for business purposes. For some reason, it's not working.  I have brought Obi Talk software with the understanding that I would be able to use for personal and professional purposes.

I have had two Google Voice accounts setup on my Obihai 202 working flawlessly since November 2017.  SP1 is a Google Voice number (lets call it...GV1) working on Phone Line 1.  SP2 is a second Google Voice number (lets call it GV2) working on Phone Line 2.  Sometime within the last week or so, SP2 is no longer working.  When I try to dial out a number on Phone Line 2, the Obihai attendant says, "number dialed XXX-XXX-XXXX has not received a response from the service provider". I cannot receive call on that line either though GV is forwarding the number properly to my cell phone (so GV is not the issue).  ObiTalk shows the SP2 status as "Registration Not Required".

What I have done to resolve so far.  Nothing has worked
1. Deleted and re-added SP2
2. Moved SP2 setup (GV2) to SP1 provider slot.  GV2 then works fine in SP1 slot but adding GV1 to SP2 slot gives same error from attendant.
3. Deleted and re-added SP1 and SP2. Renamed them to different names.
4. Restored backup of config
5. Reset to factory defaults then re-added GV1 and GV2 on SP1 and SP2 via ObiTalk setup
6. Ensured that ObiTalk settings are checked in Obi Expert Config
7. Unplugged power and ethernet to 202.
8. Rebooted after each config change
9. Tried updating firmware. received error about checksum
10. Banged head on desk repeatedly
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 6204



« Reply #6 on: January 31, 2019, 04:57:02 pm »

I'm having the same issue.

I'm trying to setup Google Voice 1 to SP1 and Google Voice 2 to SP2. I'm getting the error message " Registration Not Required " on both account SP1 and SP2. In the comments, it was suggested to use GV1 to SP1 and GV2 to SP4. There was no problem. It didn't work for me though.

I have one phone with 1 phone line. I was hoping to use 2 Google Voice numbers. So Google Voice 2 is set to ring on primary line and Google Voice 1 will also be on primary line and used for outgoing calls as well.

If I use one Google Voice account, I have no problem with incoming and going calls. I don't get an error message of any kind.  I am wanting to use the second line for business purposes. For some reason, it's not working.  I have brought Obi Talk software with the understanding that I would be able to use for personal and professional purposes.

I have had two Google Voice accounts setup on my Obihai 202 working flawlessly since November 2017.  SP1 is a Google Voice number (lets call it...GV1) working on Phone Line 1.  SP2 is a second Google Voice number (lets call it GV2) working on Phone Line 2.  Sometime within the last week or so, SP2 is no longer working.  When I try to dial out a number on Phone Line 2, the Obihai attendant says, "number dialed XXX-XXX-XXXX has not received a response from the service provider". I cannot receive call on that line either though GV is forwarding the number properly to my cell phone (so GV is not the issue).  ObiTalk shows the SP2 status as "Registration Not Required".

What I have done to resolve so far.  Nothing has worked
1. Deleted and re-added SP2
2. Moved SP2 setup (GV2) to SP1 provider slot.  GV2 then works fine in SP1 slot but adding GV1 to SP2 slot gives same error from attendant.
3. Deleted and re-added SP1 and SP2. Renamed them to different names.
4. Restored backup of config
5. Reset to factory defaults then re-added GV1 and GV2 on SP1 and SP2 via ObiTalk setup
6. Ensured that ObiTalk settings are checked in Obi Expert Config
7. Unplugged power and ethernet to 202.
8. Rebooted after each config change
9. Tried updating firmware. received error about checksum
10. Banged head on desk repeatedly

You're referencing and posting in an old discussion.  Anything you read from old posts may now be either inaccurate or obsolete.

All Polycom OBiTALK devices in the 200 series can host up to four separate Google accounts.  Understand  that Google Voice is not a standalone app.  It is a service, just like Gmail, Calendar, Contacts, Docs, that is "owned" by a Google account (Gmail address or G Suite address).

So, all you need to do is to correctly set up the SPx slot of your choice and grant permission to that SPx to access the Google Voice service on a given Google account.

There is no requirement to use a specific SPx for Google Voice.  You can "mix and match" any combination of Google Voice or other SIP service provider (e.g. voip.ms, Callcentric, Phonepower, etc.).

So:  Delete the SPx configuration that doesn't work.  Let the device reboot and sit there untouched for 10 minutes.

Open a laptop/desktop web browser.  On Google Chrome Browser or Safari, press Ctrl-Shift-N to open an "incognito browsing" window, or, on Firefox, press Ctrl-Shift-P to open a "private browsing" window.

In that window, sign into the one, and only one, Google account that you want to use on the new SPx.  Go here:  https://voice.google.com/settings and look at the top of the page. Make sure you see the correct Google Voice phone number.  If you don't, then either you don't have one on this account, and/or you are looking at the wrong account.  If you need to instead sign into a different Google account close the incognito/private browsing window, open a new one, and sign in again.

After you're in the correct Google account, press Ctrl-T to open another window in that private/incognito session.  Sign into OBiTALK in that window:  http://www.obitalk.com/obinet/pg/obhdev

Click on your OBiTALK device, then click on the SPx you want to use, and follow the instructions to set up Google Voice.  Carefully confirm that, when it asks your permission to use your Google account, the correct Gmail or G Suite email address appears.  If not, you didn't follow the instructions above.  If so, complete the procedure.  Let the device sit untouched for 10 minutes after you finish the procedure.

Both SPs that were configured to use Google Voice should now be working.
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement