Obi202 won't stay registered with Phonepower

Started by EdWilliams, June 08, 2018, 02:42:28 PM

Previous topic - Next topic

EdWilliams

I swapped my (working perfectly) Obi101 for an Obi202.  I configured it for use with GV and Phonepower via Obitalk.  It worked for a few  days.  Since then I have been getting failures to register with 403 codes.

Phonepower support gave the following instructions - which I executed.  However, will no occasionally register, but will not stay registered.

.......
Obhai has changed their Re-sync process due to problems with the configuration they
were pushing to the devices.

1) What you'll need to do now is  Enable your Sip credentials in the Phone power account portal
Under MODIFY SERVICES -->SIP CREDENTIALS.   Just enable them to display the information that
needs to be entered on the obihai portal (Make sure to NOT disable them)

Ive attached screenshots in a zip file to guide you where to go and what to enter.

2) FIRST In Obihai where there was the icon for Phonepower,  You now click on the link at the
bottom of that page for "OTHER PROVIDERS" and you'll see a link for phonepower.  (STEPS 1-3 SCREENSHOTS)

3) Click on that link and then manually enter the Sip credential info from the
phonepower account portal into the fields in the obihai page.  (STEP 4 SCREENSHOT)
Then press submit

4), STEP #5  Go back to the dashboard and click on the 9-digit Obihai device number at the top

a) Click on  EXPERT CONFIGURATION and then click on ENTER EXPERT CONFIGURATION  

b) Goto  SYSTEM ADMINISTRATION--->AUTO PROVISIONING

c) Locate ITSP PROVISIONING

d) You need to edit the first two parameters.. to make them editable, uncheck the box to the left of the
parameter and you will see the check move to the box to the left of it.. Uncheck that box as well and you'll
be able to make changes.

e) Edit as follows:  (See STEP 5 SCREENSHOT )

f) METHOD: Change to "PERIODICALLY"

g) INTERVAL: Set to 30   (this will allow you to make changes and Update to the device without restarting it)

h) Press submit at the bottom and your device will update..


The last two screenshots are for setting the ports and Protocols(STEPS 7 & 8).  Once youve set those ..
reboot the obihai to refresh the changes in the device and it should show "REGISTERED" in the Dashboard status window.

FOR STEP 8

COPY THE ENTIRE STRING BELOW FROM THE FIRST TO THE LAST PAREN

(**|[3469]11|0|00|1xxxxxxxxxx|<1>[2-9]xxxxxxxxxS0|*21|*50xxxx|*51xxxx|*52xxxx|*53xxxx|*54|*6[013569]|*6[27]xx.|*77|*[789]2xx.|*73|*74[0-1][0-9]*xxxxxxxxxx|*75[0-1][0-9]|*8[137]|90xxxx|*93|*96|011xx.|xx.|(Mipd)|[^*#]@@.)  

Paste string into the DigitMap field as shown on STEP 8 Screenshot...  Press Submit and restart the Obihai device.
.......


EdWilliams

Here are the rest of Phonepower's screenshots.

The problem is the Obi will register for a period then disconnect and give 403 messages.  Phonepower suggests that I configure the device entirely via the web interface and that they suspect a firmware problem. I have yet to try this. However it seems there's no way to go to an earlier firmware version!



EdWilliams

  I think this could be the problem.  However, since I'd already set the registration period to 3600, per
http://www.obitalk.com/forum/index.php?topic=12843.0
I'm going increase to 14400 and see if I can stay connected once I get back in.  Perhaps I should put the Obi on the UPS?

EdWilliams

  Well, further increasing the registration period was not a magic fix - I stayed registered for a while (less than 45 minutes), and I'm now back to "Register Failed: 403 forbidden."

EdWilliams

Quote from: ferrarifire on December 10, 2017, 03:22:05 PM

Just want to post this in case someone still has issues with configuring PhonePower service.

Some background: I have started working on replacing my Obi100 with Obi200 and ran into issues to make SP1 PhonePower able to make/receive calls. Using the Obitalk's named service provider (PhonePower) in the configuration did not work (Google voice for SP2 worked).

Either I could get PhonePower to work outside of Obitalk.com (by following the configuration in above messages) or only get Google Voice through Obitalk.com configuration and not PhonePower.

Below is what finally what I did to make it work.

--> Reset the Obi200 to Factory Default (Obi200 device access >> System Management >> Device Update >> Restore Configuration)

--> Login to Obitalk.com and add the device (Keep the network and phone connected to Obi200, and enter the **5 xxxx code when asked)

--> (Optional) Configure the SP2 first for Google Voice (this is my preference to have Google as secondary line). This may take couple of minutes. Check the status in Obi Dashboard on Obitalk.com and ensure the status as 'Connected' for SP2

--> Click SP1 and proceed to configure a Generic Service Provider using the following details:



  I tried ferrarifire's method this AM - with one addition, setting the registration period to 3600 in the expert settings of Obitalk.  There was a few minutes of confusing results where inbound calls would sometimes route to the voice mailbox.  However since then the Obi202 has remained registered and as far as I can tell functional. Yeah!
  I also checked AccessFromWAN under System Management|Device Admin in the Obitalk Expert settings.  This allowed me to log into the Obi and save the configuration.
  PhonePower had me port forward a bunch of ports to the Obi202:
4200 TCP
• 5000 - 5080 UDP
• 10000 - 11000 UDP
• 12060 - 12080 UDP
• 16384 - 16472 UDP
• 16600 - 16700 UDP
The only one I have so far seen in use is 10000 UDP when Obitalk updates the Obi202's configuration.  I have not yet turned any of these off.


EdWilliams

  It's been several weeks and the Obi202 has been working perfectly using ferrarifire's technique.  It's much simpler than what Phonepower tech support is suggesting and it works - at least for me.

NickyG

Quote from: EdWilliams on June 08, 2018, 02:42:28 PM
... Phonepower support gave the following instructions - which I executed.  However, will no occasionally register, but will not stay registered...

@EdWilliams: THANK YOU!! I followed your detailed instructions tonight, thanks so much for those and the screenshots -- and VOILA! My Obi202 shows registered with Phonepower on SP2 and seems stable. Tried multiple times with the auto-config and with ferrarefire's solution with no success but yours worked. In the midst of my frustrations I opened an account with Anveo and requested a (free) port of my Phonepower number. That hasn't come through yet but it doesn't matter as this line is only for calling out. The Anveo registration was a beautiful thing - in minutes I had a new phone number assigned and set up on my Obi (SP1); so I would recommend a switch from Phonepower to anyone who is fed up with this config issue. Basic plan is $40/year for 333 minutes and texts per month.