Connecting Panasonic IP phone KX-TGP600 with Obi202- in Proxy

Started by Krish-VA, June 19, 2018, 03:37:30 AM

Previous topic - Next topic

lrosenman

I used an ID I was given by Panasonic support a long time ago and keep in 1Password.  Access to MUCH more info.

userid: instoperatorid
pass:   r4jr9XHG

I'm NOT sure if that password is for ALL KX-TGP600's or generated based on MAC/SN/Something else.  Let me know.

I used the export operational values from the attached screen.

jholme004

Oh wow...that did open up alot!

I'll compare this to your tonight and let you know what I find and any success.

Thanks again!
-Jason

jholme004

So I used word to do a "Compare Document" and accepted most of your changes...For example, I'm setting this up on Line 8, so I used your line 1 settings for line 8 and kept my line 1-4 as they were.  Any config changes, I applied yours with the thinking I can use my Operational settings to revert back if something went sideways.

I still have the same issue - Connects to the Obi, places the call on SP1, the other side rings (and I hear ringing), but when the other side answers it disconnects. I'm pretty sure it's not a NAT or ALG issue, as the TGP and the Obi are on the same subnet, and the Obi can place calls through a POTS handset. My FreePBX can also place calls via a SIP account and through the Obi (via SP4).

I set the Obi  to "Log Level 7", Sp1 (GV) and Sp3(TGP600) to "Log All Messages", and the TGP to the SIP Debug level 6. I've attached the log for the disconnected call. Unfortunately, I cannot see what is causing the disconnect, although I see where the TGP and the Obi both disconnect. 

I've attached my operational values as well as the failed call logs.

I welcome any and all thoughts...
-Jason

lrosenman

I'm at a loss.  

Here are my ITSP profile settings for my 1st GV Line.  ICE and the Name are the 2 non default

The digit map is set for my GV911.com setup

Maybe the ICE parameters?

And the SP3 parameters for the TGP -> Obi.

Does that help?
192.168.200.94 is the KX-TGP600

My setup:
SP1 - My GV line
SP2 - My Wife's GV line
SP3 - Panasonic for GV1
SP4 - Panasonic for GV2

May not be the most efficient, but it's working
           

jholme004

GOT IT!

The ONLY thing I changed was X_KeepAliveServerPort from the default 5060 to 5062 (I too am using SP3).

Thank you for all of your help!!
-Jason

jholme004

Well, Almost....I can not receive calls now.

In SP1 (My set up is similar to yours), I have:
X_InboundCallRoute=sp3

That should do it, no?
-Jason

lrosenman

needs to be sp3(xxxxx) where  xxxxx is the phone number assigned in the TGP.  (I use 1001 for me and 1002 for my wife)

EG:
ph,ph2,SP3(1001),SP3(1877xxxxx@switch.starcompartners.com;ui=$1)

I send it to the phone ports since my Dish Hopper displays CallerID on my tv's
and the 1877 number is  NoMoRoBo.

jholme004

I tried that as well as sp3(2023@10.16.3.103),sp3(2023@10.16.3.103:5060), and sp3(2023@10.16.3.103:5062)
(AuthID in TGP=2023; TGP IP=10.16.3.103; TGP Local SIP Port=5062)

I've even tried changing the local SIP port in ITSPC > SIP from 5062 to 5060, incase the TGP only receives on 5060. Still no incoming.

I can receive the call on the analog port of the Obi or via FreePBX via the Obi, so I know the call is making it out of the OBi using other output methods.

I've attached my SP1 settings...VG1 is currently what I use for my FreePBX box, but I've tried the above with that removed.
-Jason

lrosenman

I'm at a loss, that was the only thing that jumped out at me.  

I'd go over the diff's again on the TGP, as well as the logs from it if you can get them out.

I've sent a PM with contact info, feel free to contact me.