[SOLVED]I have a problem where I can't hear the other side when calling non-VOIP

Started by jupiterstation, July 02, 2018, 01:08:47 PM

Previous topic - Next topic

jupiterstation

Hi,

I have a problem where I can't hear the other side when calling non-VOIP lines - both cell phones and landlines. However, all is good when anyone, including non-VOIP lines calls me. Also, there is no problem when I call other Google Voice or VOIP lines, like MagicJack, for instance.

So, to recap:

- making calls to non-VOIP lines (landlines, cell phones) - ISSUE - they can hear me, I can't hear them
- making calls to VOIP lines - ALL IS GOOD
- receiving calls from ANY LINE -  ALL IS GOOD

Using the OBI200 adapter.

I know about the SIP-ALG setting. I have to find my router password (I know, I am pretty bad with writing these things down, but, hey, it's the safest thing out there, even I can't find it lol) before I can check the setting but I didn't have this problem before and I haven't changed routers or providers, so I can't imagine this being a problem and I wanted to see if anyone has any suggestions.

I don't believe I had that problem before, but then, I started using this adapter and phone a few weeks ago.

Does anyone know if Google Voice or Polycom changed anything, if there is a problem with a gateway on of their ends or any other known issue that's not on my side?

I would appreciate any suggestions.

Thanks!

harmankardon

Quote from: jupiterstation on July 02, 2018, 01:08:47 PM
Hi,

I have a problem where I can't hear the other side when calling non-VOIP lines - both cell phones and landlines. However, all is good when anyone, including non-VOIP lines calls me. Also, there is no problem when I call other Google Voice or VOIP lines, like MagicJack, for instance.

So, to recap:

- making calls to non-VOIP lines (landlines, cell phones) - ISSUE - they can hear me, I can't hear them
- making calls to VOIP lines - ALL IS GOOD
- receiving calls from ANY LINE -  ALL IS GOOD

Using the OBI200 adapter.

I know about the SIP-ALG setting. I have to find my router password (I know, I am pretty bad with writing these things down, but, hey, it's the safest thing out there, even I can't find it lol) before I can check the setting but I didn't have this problem before and I haven't changed routers or providers, so I can't imagine this being a problem and I wanted to see if anyone has any suggestions.

I don't believe I had that problem before, but then, I started using this adapter and phone a few weeks ago.

Does anyone know if Google Voice or Polycom changed anything, if there is a problem with a gateway on of their ends or any other known issue that's not on my side?

I would appreciate any suggestions.

Thanks!

Same here. Have tried resetting the device and re-configuring my GV account. But it persists. I thought it was just international calls, but now that you mention VOIP vs landline, I think that is it.

azrobert

Quote from: jupiterstation on July 02, 2018, 01:08:47 PM
I know about the SIP-ALG setting. I have to find my router password (I know, I am pretty bad with writing these things down, but, hey, it's the safest thing out there, even I can't find it lol) before I can check the setting but I didn't have this problem before and I haven't changed routers or providers, so I can't imagine this being a problem and I wanted to see if anyone has any suggestions.

Did this problem start after you converted to the new GV? The old GV used the XMPP protocol and wouldn't be affected by SIP-ALG. The new GV uses the SIP protocol and can be affected by SIP-ALG.

The OBi2xx has a setting to detect ALG. I have no idea what this setting is used for, but it can't hurt to enable it and see if it fixes your problem.

Use OBi Expert to make this change:

Service Providers -> ITSP Profile X SIP -> X_DetectALG: Checked

harmankardon

Tried  X_DetectALG: Checked

Still no sound. Has worked fine for years. I am on the latest firmware.

harmankardon

I registered a completely different GV number on SP4 and experienced the exact same problem. No sound to outgoing landlines, but VoIP is fine. Tried Callcentric on SP3 and it worked fine for outgoing calls. So this is a specific issue with GV using the default configuration.

AZrealtor

I have the same problem which started 2 days ago, I can't hear the other party on any outbound calls, they hear me but I can't hear them.  Inbound calls are fine. I reset the OBi202 and deleted re-setup accounts as suggested in this forum. I am running SoftwareVersion 3.2.2 (Build: 5859EX) So I don't know what else to do. There are lots of folks with the issue from posts,  so looking for help or advice please.

harmankardon

Quote from: AZrealtor on July 02, 2018, 08:03:38 PM
I have the same problem which started 2 days ago, I can't hear the other party on any outbound calls, they hear me but I can't hear them.  Inbound calls are fine. I reset the OBi202 and deleted re-setup accounts as suggested in this forum. I am running SoftwareVersion 3.2.2 (Build: 5859EX) So I don't know what else to do. There are lots of folks with the issue from posts,  so looking for help or advice please.

Not a solution, but a workaround. Dial your VM number (GV number), then select 2 to place an outgoing call. Wait for the prompt and dial the number. Not elegant, but works.

Is there a way to program the Obihai to automate this process?

Mike111

This works with the Obi110 too.

Quote from: harmankardon on July 03, 2018, 06:01:37 AM
Not a solution, but a workaround. Dial your VM number (GV number), then select 2 to place an outgoing call. Wait for the prompt and dial the number. Not elegant, but works.


vipersinu2

I have the same problem with my ob110, and my dads obi110. we are running firmware OBi1-1-3-0-2886-naf7.fw
tried factory reset, disabled obitalk services, provision. ect. The other party can hear us talking, but we can not hear inbound audio.


not_obi_happy

Quote from: Mike111 on July 03, 2018, 08:27:10 AM
This works with the Obi110 too.

Quote from: harmankardon on July 03, 2018, 06:01:37 AM
Not a solution, but a workaround. Dial your VM number (GV number), then select 2 to place an outgoing call. Wait for the prompt and dial the number. Not elegant, but works.


Has nothing to do with OBIxxx. This is actually GV service. You can use it from anywhere.

As for the audio issue it is true and long standing issue which needs to be addressed.

jupiterstation

Interesting workaround. Thanks. But how do you dial your own VM? When I dial my number after a bit of silence it just resets to a dial tone. Or when I do 2# which is the speed dial for my device it gives a busy signal. Can anyone help?

As for the audio issue - yes, this hopefully will be fixed soon. It did work before so what the sudden change, I don't know.


fedup

I have this same problem on Obi202 running 3.2.2.
My GV account setup on SP1
My wife's GV account setup on SP2.

I went through the reset procedure and this fixed the problem for my Google Voice account on SP1 after the first try. But no matter how many times I reset the device and remove App access on my wife's google account we cannot hear the other party when making outbound calls on SP2. My Google Voice legacy settings shows an obitalk device but hers does not... Is this perhaps a problem with Google having not converted her account yet?

Oh I should mention I've been running this config for 3 years without a problem. The calling issue started sometime in the last week.

not_obi_happy

Same problem here with OBI212 and GV.
Seems Obihai/Polycom support does not care.

jupiterstation

OK. Here's something else I just noticed.

Even though this is a brand new Google and GV account created in June it appears that when I did set it up with OBI it created a Google Chat link in Google Voice and not the SIP login. I thought all new accounts would be created already converted.

After reading other threads I thought this whole problem might be because I have the latest firmware but the old Google Chat link? I don't want to jinx it but my other OBI adapter with a very old number is working well. Fingers crossed.

I will try to create a brand new account a little later today and register it on the device and see what it does.

Has anyone else experienced this - a new GV account still creating Google Chat and not the SIP link?

harmankardon

I found how to solve the problem.

You need to log into your device directly. Then download the previous firmware:
http://fw.obihai.com/OBi202-3-2-2-5859EX-198839.fw

Then upload the firmware to your device.

Turn off autoprovisioning until this issue is fixed.

You will need to delete GV from the portal then add it again.

jupiterstation

Thanks. I haven't tried that because the problem was just fixed.

Here's a recap of the latest developments.

So, I noticed that the GV account had the Google Chat link. After I deleted it, I couldn't re-add it when trying to set it up through OBI. I did create a new GV account and it did link it but with Google Chat link, and not the SIP login link again. So, I wanted to revert back to the old account, deleted the Google link on the new one and tried to relink it to the original account again. A big mess. Because now a new link wouldn't even be created. I tried even factory resetting the device, but nothing.

Long story short, since I think something got stuck with this device I did send a service request with OBI and just a few hours later the SIP link appeared on the account and now all calls appear to be OK - both voip and non-voip. Thanks, OBI team for fixing this!

So it seems, at least in my case, that the SIP link was what was needed with the latest firmware. I guess the latest firmware doesn't work very well with the old Google Chat set up? That's purely speculative and just a suggestion when diagnosing the problem.

Cheers.

Niniss

Before i revert to the older firmware, i noticed the problem was fixed itself yesterday, that is, i could call out again.  However, today i noticed different issues, both call out and receiving calls google voice asks for callers name and receivers permission to accept the call before it connects any call.  Very frustrating!

jupiterstation

This might be your "screen calls" switch on Google Voice. Go to Google Voice>Settings>Calls. Find Screen Calls - Hear a caller's name when you pick up - and turn it off. This should fix this.