800 calling through SipBroker (via CallCentric)

Started by tome, September 04, 2011, 08:28:21 AM

Previous topic - Next topic

mo832

#20
Phone port digitmap:

([1-9]x?*(Mpli)|[1-9]S9|[1-9][0-9]S9|911|**0|***|#|**1(Msp1)|**2(Msp2)|**9(Mpp)|(Mpli))


Update: speed dial works as stated above. From keypad, just tried **1**275*18005551212, and it worked also. But without the **1, it gives me the 404 error. (the voice tells me I dialed * * 2 7 5 * 1 8 0 0 5 5 5 1 2 1 2) . As far as I know, sp1 is my primary line. Where do I need to check this? Are there multiple places it needs to be entered?

azrobert

Physical Interfaces -> Phone Port
On my OBi110 Primary Line is the 5th parm from top.

Error code 404 means NOT FOUND.
I think Callcentric or SIPBroker rejected the call.

Did you dial a valid 800 number?

You can check the call history to see if the call was routed out SP1.

Log into the OBi via the Web interface
Click Status
Click Call History

InetUser


mo832

@azrobert,

So I checked my call history. It sent the **275 calls to SP2 google voice, even though I have the digitmap set as noted. Something isn't right. As long as I FORCE sp1, either via **1 or SP1 in speed dial, it now works correctly, where it wouldn't even dial before. I guess the digit map helped there, but it still won't do right without dialing **1. And my primary line is confirmed to be SP1.

giqcass

Quote from: mo832 on April 07, 2014, 06:38:35 PM
@azrobert,

So I checked my call history. It sent the **275 calls to SP2 google voice, even though I have the digitmap set as noted. Something isn't right. As long as I FORCE sp1, either via **1 or SP1 in speed dial, it now works correctly, where it wouldn't even dial before. I guess the digit map helped there, but it still won't do right without dialing **1. And my primary line is confirmed to be SP1.

**2 is to force SP2 that is why SP2 makes the call.
Long live our new ObiLords!

giqcass

I think you would need to put something like this in the digitmap.
**275*xxxxxxxxxxx(Msp1)

Do you want to send all 800 numbers via that route?  There are better ways to do this.
Long live our new ObiLords!

mo832

I am open to any other methods that would be easier. I switched sp1 to callcentric from localphone as I was having problems with the localphone/ipkall service and I'm trying to pinpoint the problems. But at least with localphone, I could just pick up the phone and dial 1-800-xxx-xxxx with no special codes, and the call would go through with no calling credit. To do the same on CC, you must dial **275. So I would like to at least dial these without changing ITSPs and without needing credit. If I can also do a direct dial, that would be great.

giqcass

#27
I see no reason to reinvent the wheel here so let's go with old faithful.  This thread will show you how to set things up so you can dial 1800 numbers the old way for free.
https://www.obitalk.com/forum/index.php?topic=2357.0

Quote from: RonR on January 22, 2012, 03:44:03 PM
This appears to be another 800 number that uses 'Early Media' that's not supported by Google Voice nor a number of VoIP providers.

A not so elegant solution is to call one of the Sip Broker PSTN Access Numbers and then dial *18004683510#.

A more elegant solution is to offload all of your toll free calling to a provider that supports 'Early Media'.  This requires that you have SP2 configured for SIP:


Physical Interfaces -> PHONE Port -> DigitMap: (...|(Mvg8)|(Mpli))

Physical Interfaces -> PHONE Port -> OutboundCallRoute : ...,{(Mvg8):vg8},{(Mpli):pli}


Voice Gateway8

Name : Toll Free

AccessNumber : SP2(proxy.ideasip.com)

DigitMap : (18(00|88|77|66|55)xxxxxxx|<1>8(00|88|77|66|55)xxxxxxx)


If you don't already have a SIP provider configured on SP2, use the following:


Service Providers -> ITSP Profile B -> SIP -> ProxyServer : 127.0.0.1

Voice Services -> SP2 Service -> AuthUserName : (put anything here)

Voice Services -> SP2 Service -> X_RegisterEnable : (unchecked)

Voice Services -> SP2 Service -> X_ServProvProfile : B


One change to the above we have 1 new 800 area code 1844 that I am aware of.

DigitMap : (18(00|88|77|66|55|44)xxxxxxx|<1>8(00|88|77|66|55|44)xxxxxxx)
Long live our new ObiLords!

giqcass

For reference according to Wikipedia these are all toll free in the US or reserved for toll free.

822: reserved for future toll-free expansion (see also 800, 833, 844, 855, 866, 877, 888, 880–882, 883-887, and 889 in this list)
Long live our new ObiLords!

azrobert

#29
**275*18005551212 should not be forced out SP2 because of the **2.

75*18005551212 must match a rule in the ITSP B DigitMap to be forced out SP2.

(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.) is the default DigitMap for an OBi110.

Even xx. will not match the above string because of the "*"

What ever the reason it's being forced out SP2, you can fix it by placing the following at the beginning of the Phone Port OutboundCallRoute:
{(Msp1):sp1},

Anyway, giqcass' post of RonR's solution is better.
I use tf.callwithus.com
If your SP2 is not defined you can do the following instead of defining a dummy SIP definition:
sp1(tf.callwithus.com)

giqcass

#30
Now that you mention it if I remember correctly x should only match a number.  I forgot that.  There is obviously some information about his setup we are missing.

Do you find tf.callwithus.com superior in any way?  I have never had issues with ideasip services but I can't confirm whether they support the new 844 code.  I can confirm Sipbroker does support it.  There are a lot of options out there for 800 termination and with the few 800 calls I make it's difficult to declare one better then the others.
Long live our new ObiLords!

mo832

#31
I checked my profile B, and it is the default and it matches the digitmap posted by azrobert above. I have posted my Profile A strings (and tried the modifications given) and my Phone port string.

I am using sp1 with CC (as stated) and currently using sp2 with GV, so I cannot use any free slots on 2 , correct?

I don't really want to do the global solution just yet, but I would like to be able to just dial an 800 number without the **1. Can you guys help me find what is causing the **2(75) to go to sp2 even though I have a pattern to catch it?



EDIT:

If I do the change that is given above
"What ever the reason it's being forced out SP2, you can fix it by placing the following at the beginning of the Phone Port OutboundCallRoute:
{(Msp1):sp1},"

What will this do to other numbers that I may dial? Would everything be forced to sp1 even when I don't expect it?



azrobert

#32
If you are using the default Phone Port OutboundCallRoute it won't cause any problems.
With the default you must dial **n prefix to route a call to somewhere other than SP1 (the Primary route).

The following is a better solution and won't affect anything else even if you don't have the default Phone Port OutboundCallRoute.

Remove **275*18(00|88|77|66|55|44)xxxxxxx| from the ITSP A DigitMap.
Do not use {(Msp1):sp1}, in the OutboundCallRoute

Add following at the beginning of the Phone Port OutboundCallRoute:
{(<**275*>18(00|88|77|66|55|44)xxxxxxx):sp1},

Dial 18005551212 and it will be routed out SP1 as **275*18005551212

azrobert

Quote from: giqcass on April 07, 2014, 11:23:15 PM
Do you find tf.callwithus.com superior in any way?

I use tollfree.future-nine.com and tf.callwithus.com. With Future9 you must prefix the number with "**".
Both of these providers will use the UserID as the outbound CallerID.

proxy.ideasip.com does not send a CallerID.

proxy.tollfreenation.com, tollfreegateway.com, sip.denetron.com and sipbroker.com also send CallerID. I haven't use these recently, so I don't know if they still work.

I need CallerID when calling a few 800 numbers.

mo832

so I tried the recent changes to the outbound call route, and dialed 18005551212, and I got the "number is invalid" message, which is from callcentric meaning I don't have credit.

I had already gone back to the original sp1 digitmap as instructed.

This is not going too easy for me :(

azrobert

Sorry, I think I got up too early this morning.

I fixed the error in my Reply #32

mo832

Thanks for the revision. The site was down for a stretch today. It even affected the Obitalk expert page which made changes slow and unreliable. In the meantime, I pretty much removed all the special code and tried the RonR global ideasip solution. It seems to be working, but one weird thing is it filters numbers itself. When you dial 18005551212 it takes you to "Free 411" which is a commercial service, but if you dial the same 800# via sipbroker or GV (and I imagine a POTS company) it answers at ATT toll free information. As long as it does what I want, I will wait on re-trying the Outbound call route solution.

Now, disregarding all of the special alternatives we have tried, can you help me figure out why my setup was still requiring the **1 even though the codes seemed to take care of it automatically via Primary Line? If I have a logic error somewhere, I would like to find it now before it becomes an issue, if ever.

azrobert

Using a VG is the better method.
When you use CC the call goes thru CC and then to SIPBroker.
When you use a VG the call goes directly to the 800 service provider, eliminating 1 hop.
You will get faster response, but probably only a couple milliseconds.

CallWithUs sends you to the AT&T version.
If you want them change the VG AccessNumber to:
sp1(tf.callwithus.com) or sp2(tf.callwithus.com)

If you want to shorten the dialing do the following.
Add to the Phone Port DigitMap:
411|

Change the Voice Gateway DigitMap to:
(<411:18005551212>|18(00|88|77|66|55|44)xxxxxxx)

Now dial 411 or an 800 number.
I changed my config to the above and it works.

To diagnose the previous routing problem, please post the ITSP B DigitMap and the Phone Port OutboundCallRoute.


mo832

Quote from: azrobert on April 08, 2014, 03:04:40 PM

To diagnose the previous routing problem, please post the ITSP B DigitMap and the Phone Port OutboundCallRoute.



Those are posted earlier in this thread. The ITSP B is the default given as in the Obi110 (mine is a 100 but same map). The Outbound call route has had Mvg8 added, but before that it was the default. Current copy is:

{([1-9]x?*(Mpli)):pp},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**9:>(Mpp)):pp},{(Mvg8):vg8},{(Mpli):pli}

giqcass

#39
Quote from: azrobert on April 08, 2014, 10:26:05 AM
Quote from: giqcass on April 07, 2014, 11:23:15 PM
Do you find tf.callwithus.com superior in any way?

I use tollfree.future-nine.com and tf.callwithus.com. With Future9 you must prefix the number with "**".
Both of these providers will use the UserID as the outbound CallerID.

proxy.ideasip.com does not send a CallerID.

proxy.tollfreenation.com, tollfreegateway.com, sip.denetron.com and sipbroker.com also send CallerID. I haven't use these recently, so I don't know if they still work.

I need CallerID when calling a few 800 numbers.


Caller ID when calling a toll free number can be a time saver.  Some of the places I call use my CID to pull up my account so for me that is definitely a plus.  

I also do not send my true caller ID to companies I am not familiar with.  Since you can't block CID to toll free numbers I currently use a Google account with no GV number attached to it. Then they see that generic Google number in CID that just goes to an answering machine.  

I had Pitney Bowes collect my CID without my permission when I called them from work. They started calling me at work and claimed I gave them the number. Their telemarketing tactics border on harassment.  The whole thing ended with legal threats and me reporting them to the FCC. I was never a customer. I simply inquired one time about their services.  I would like to hope they cleaned up their act.

I think I'll use the info you gave here to create a star code to block my CID to 1800 numbers since my current Google Voice trick will cease to function soon.
Long live our new ObiLords!