Google Voicemail not working as the active voicemail. How can I fix?

Started by ilovepancakes95, August 14, 2018, 09:12:24 AM

Previous topic - Next topic

SteveInWA

Well, come to think of it, let's really dive in and clean things up.



  • Go to your OBiTALK dashboard, https://www.obitalk.com/obinet/pg/obhdev. Click the OBiTALK device you want to use.  On the next page, click the blue "Delete Device" icon to remove it completely off of the dashboard.  Wait a few minutes while it resets and removes the device, and the LEDs have stopped blinking (except for the middle LED flickering).
  • Then, unplug the Ethernet and power cables from the device, leaving just the phone cable.  Plug back in only the power cable, and wait for it to boot up.
  • Pick up the phone and key in ***8 then 1 to confirm restore to factory defaults.  Wait for it to go through the blinking lights thing for several minutes.
  • On your browser, go here:  https://myaccount.google.com/.  In the "Apps with account access section", click the "MANAGE APPS" link, and then delete any telephony apps that have permission to use your account, including Simonics GVGW and/or Asterisk.
  • Now, plug in the Ethernet cable and go to the OBiTALK dashboard, and click the button to add a device.  Follow the instructions to press **5 xxxx to add your device.

Stop at the step above.  Do NOT add back Google Voice to the OBi yet.  Go to Google Voice settings and delete the SIP address, if it is still there.  Make sure that you have one working US phone number linked and enabled to ring on inbound calls.  You now have a plain vanilla Google Voice account with no OBi stuff involved.

Test calling.  What happens?

ilovepancakes95

OK, followed that procedure and tested. Everything works normally. Unrelated number calling GV number rings my cell phone (linked phone) and if I don't answer on cell, caller gets voicemail prompt and leaves message normally.

SteveInWA

OK, great.  There is nothing wrong with your OBi nor with your Google Voice setup.

Now:  open a desktop/laptop web browser.  If you're using Google Chrome Browser or Safari, press Ctrl-Shift-N to open an incognito browsing window, or, if you're using Firefox, press Ctrl-Shift-P to open a private browsing window.  In THAT window, sign into the one and only Google/Gmail account (Gmail address and password) that holds your Google Voice number.  Go here to confirm that you see the Google Voice phone number:

https://voice.google.com/settings

Now, leave that browser tab open.  Press Ctrl-T to open another tab in that same browser window.  Sign into your OBiTALK dashboard.  Click SP1, and follow the instructions to set up Google Voice.  When it pops up the window showing your Gmail account address, make sure it is the correct address and proceed. 

It should now work properly.  Do not make any other changes.

ilovepancakes95

OK, Google Voice setup goes fine. Obi device shows up again in legacy GV settings page but I am getting same result. Have not touched any other settings, am following your guide exactly. Unrelated landline calls GV number, Obi phone rings but my linked phone does not ring (even though it is still checked in settings on GV). Call rings for about 40 seconds, Obi stops ringing, caller gets busy signal for 20 seconds then sounds drop and call stays counting on the timer on their end but no sounds or further changes.

ilovepancakes95

#24
And in case it matters, outgoing calls from Obi device are working fine, and incoming calls connect and work if I answer. So this is all related to unanswered/rejected calls and voicemail.

SteveInWA

Sorry, but I am out of ideas.  There has never been a case where Google Voice forwards a call to a phone number, and rings that number for 40 seconds.  It should give up after 25 seconds and take the message.  There is something fishy about your forwarding phone number; I just can't figure out what it is via a forum conversation.

ilovepancakes95

I can tell it is something bizarre. What I just noticed is, if I checked the call screening option to "On" where I would have to hit 1 when picking up to connect, everything works perfectly! Callers get through to voicemail if I don't pickup and if I do pickup, I hit 1 and it connects to them. My cell phone also rings in addition to my Obi device.

Also, if I turn call screen off, back to original issue right.... but if I uncheck the Obi device, everything works fine, of course Obi device doesn't ring then but linked phone and voicemail on GV number go back to normal. So it seems something about the Obi device being active on the account is messing it up.


ilovepancakes95

Yeah I was afraid it would come to that, as I would rather not have to hit 1 each time especially since when I pickup the prompt doesn't even play half the time so can't tell if call is connected... BUT it is better than nothing. Thanks for all your help here....

dboling

It's probably an issue with GV as GV groups and circles doesn't seem to work correctly either.

-Diane