Can't call out using Google Voice - dead air

Started by PeterG, October 18, 2018, 10:39:04 PM

Previous topic - Next topic

PeterG

I just set up my Obi200 with 2 GV accounts and 1 SIP VoIP number.
Both GV accounts are both set up to forward to the VoIP number with one of the GV SPs set up as the primary outgoing line.  Dashboard status shows all SPs connected/registered.

Incoming calls ring the handset, but when I attempt outgoing calls through either line, nothing but dead air.  The call status shows the correct information but remains trying/calling forever.

I never get any audio response on the calls, it hangs in the trying/calling state.

Note that the echo back test works fine and incoming calls as well.
Any ideas?
Thanks!

SteveInWA

Hi Peter:

It's likely that you have some sort of configuration error on the OBiTALK device.  But first, a simple test should prove whether or not there's a problem with your Google Voice numbers.

Sign into one of the Google accounts and go to the settings page:  https://voice.google.com/settings

Confirm that you do, in fact, see a Google Voice phone number at the top of the page.  If so, then press Ctrl-T to open another browser tab and go to:  https://hangouts.google.com/.  Try to make an outbound call to some other phone number, NOT another Google Voice number and NOT the linked/forwarding phone number.  The expected behavior is that the called party's phone rings, and your Google Voice phone number appears on that phone's caller ID display.  Does that work?

PeterG

I have had Google Voice set up for years and use it exclusively.  I can call out via hangouts successfully and do so frequently.
One other test I tried despite not having an IP phone, I imported my Google contacts successfully (ObiExtras -> Settings).  Not sure where that data goes! :D

I have not yet enabled logging in my router to confirm that something is indeed attempted beyond the Obi.  I will do that tonight, though.
Are there any useful logging tools within the Obi that I can investigate with as well?

drgeoff


PeterG

Thanks!
I found the syslog setup under System Management -> Device Admin.
Being non-windows, the download doesn't help me, but my Synology NAS has a syslog server on it.

Setting that up tonight as well.  Another fun night of network debugging for me ::)

PeterG

No good info from logs.  :(
For some other reason I can't upload a screen capture of the log window, but it shows GTT outgoing call to the correct number, GTALK init session and then GTALK sess state changed from 0 to 2 and nothing relevant beyond that.

I see nothing interesting in my router logs either, noting only that there is an established connection from the Obi's IP to a Google IP.

I ***8 reset and will try a full reset reinstall tomorrow. :'(

PeterG

To close out my problem:
As I originally posted, I connected my OBI200, updated the firmware and connected to Google Voice, received incoming calls but was not able to place outgoing calls.
As a last resort, I finally decided to delete the device from my account, do a full hard factory reset, and re-configure from scratch.
This, in fact, fixed the problem and I'm able to dial out via either of my connected Google Voice accounts!

rsyslogdfan2020

I may not have found this post had I not gone through the pain of enabling syslog. (It was exacerbated by the fact I am not on windows.) Your solution worked for me as well. Thank you!

It appears whatever was done to the auto update pathway, didn't allow for an Obi that sat in a drawer for a spell. :'( I wonder how many people just assumed theirs was trash?

After deleting the device from obitalk.com and using the reset in the `Device Update` menu, I was greeted with a new firmware with different branding.

For the curious, getting syslogs for me looked like:
sudo rsyslogd -f /usr/local/etc/rsyslog.conf -i /usr/local/var/run/rsyslogd.pid
/usr/local/etc/rsyslog.conf:

module(load="imudp") # udp logs
input(type="imudp" port="514")
*.* /tmp/syslog.log

then:
tail -f /tmp/syslog.log