Connect Failed: No Response on multiple Google Voice / Obi 508 Devices

Started by NTICloud, November 19, 2018, 10:58:47 AM

Previous topic - Next topic

akxxxxxx

I suddenly have the same issue as well. Tried deleting device, reseting obi to factory and reconnecting. Still get the connect failed: no response.

torchredraider

Stable since Obihai 202 reconnected at 1:15pm CT 12/8/2018 on my 2 GV numbers assigned to the device. ISP is AT&T Uverse in Dallas.  Down since 8:45pm CT 12/7/2018.
Agree it is a DNS issue, I just looked into the logs on my pihole\unbound setup

Previous dig for obihai.telephony.goog
was

  • 64.9.241.172
now

S_in_Forum

Switching DNS1 from 8.8.8.8 to 1.1.1.1  resolved the issue for me as well.

Thanks for posting a work around.   :)

wseltzer

Quote from: wuench on December 08, 2018, 11:00:06 AM
For those of  you that are working, what IP address is it connected to?

My failed IP was also the 64.9.241.172, which is what googles 8.8.8.8 and 8.8.4.4 DNS are resolving to.    Doing a dig via the internet a new IP comes up 216.239.36.144.    It looks like this outage is the result of some DNS changes on the obihai.telephone.goog DNS name.  

For those of you that are still having issues switching your DNS away from google's DNS may fix it.  I switched  my DNS server to cloudfare's 1.1.1.1  and it is now connected.   Or you can wait for DNS to converge and it should correct on it's own....eventually.

Thanks for figuring this out! My phones are working again.

Note that the domain name is obihai.telephony.goog

Ping this to see if you are getting the new IP address. Your router might have a diagnostic command to do this.
On your computer, flush your DNS cache first.
(For example: ipconfig /flushdns)
ping obihai.telephony.goog

keithobri

Quote from: S_in_Forum on December 08, 2018, 12:05:16 PM
Switching DNS1 from 8.8.8.8 to 1.1.1.1  resolved the issue for me as well.

Thanks for posting a work around.   :)

Where do I switch the DNS?  On the computer, the router, or the Obi200?

wseltzer

I changed the DNS setting on my router.
But, I suppose you can change the DNS settings on the OBi device instead.

fastoy

Quote from: wuench on December 08, 2018, 11:00:06 AM
For those of  you that are working, what IP address is it connected to?

My failed IP was also the 64.9.241.172, which is what googles 8.8.8.8 and 8.8.4.4 DNS are resolving to.    Doing a dig via the internet a new IP comes up 216.239.36.144.    It looks like this outage is the result of some DNS changes on the obihai.telephone.goog DNS name.  

For those of you that are still having issues switching your DNS away from google's DNS may fix it.  I switched  my DNS server to cloudfare's 1.1.1.1  and it is now connected.   Or you can wait for DNS to converge and it should correct on it's own....eventually.

Thanks. I am using 8.8.8.8 as my DNS server in my router.

It fixed itself with time. Odd that Google's DNS didn't get updated when Google's Goovle Voice server was changed.

UPDATE: I got an e-mail from OBiTALK that SAID it was working but when I tested it I still can't make calls.

UPDATE 2: I changed the DNS on the OBi200 to 1.1.1.1 and 1.0.0.1 and rebooted. Working now. Fingers crossed.

BenE

Quote from: wseltzer on December 08, 2018, 01:07:42 PM
I changed the DNS setting on my router.
But, I suppose you can change the DNS settings on the OBi device instead.

I have an ATT Gateway, which doesn't allow me to change the DNS.  If anyone knows how to make the change on the OBI200, I'd appreciate it.

Chronoblast

Changing the DNS server to 1.1.1.1 doesn't help in Dallas, Tx with Spectrum.

ping obihai.telephony.goog yields 64.9.241.172 no matter which DNS provider I go with

(Google - 8.8.8.8, Cloudflare - 1.1.1.1, Cisco/OpenDNS - 208.67.222.222).

curtisghall


wuench

If  you are using ping you will need  to flush the dns cache between tests.   ipconfig /flushdns.    An easier  way to test is to use nslookup, it will ignore the cache. 

nslookup obihai.telephony.goog 1.1.1.1

Also if you are just changing this on your router, you may need to reboot your obihai and/or router to clear the caches there.

I changed the dns entry on the obihai and had to reboot for it to take.

Chronoblast

$ nslookup obihai.telephony.goog 1.1.1.1
Server:      1.1.1.1
Address:   1.1.1.1#53

Non-authoritative answer:
Name:   obihai.telephony.goog
Address: 64.9.241.172

wseltzer

Looks like the DNS updates aren't quite working yet.

I just purged the cache on 1.1.1.1 for obihai.telephony.goog
https://1.1.1.1/purge-cache/
and now their DNS server is returning the new address again, 216.239.36.144

josephstern

I changed my Obi's DNS to 1.1.1.1 and 1.0.0.1 and I'm back in action.

Not sure if it just flushed the cache.

If you can't find where to do this, go to the IP address of your device in a web browser (something like http://192.168.1.54 ) and use admin/admin to login.

Go to System Management -> WAN Settings.

Uncheck DNSServer1 and DNSServer2 at Default on the right.

Enter: 1.1.1.1 in one and 1.0.0.1 in the other.

Save at the bottom.

Reboot at the top right.

That's what did the trick for me.

PilotKnob

Quote from: josephstern on December 08, 2018, 03:11:26 PM
I changed my Obi's DNS to 1.1.1.1 and 1.0.0.1 and I'm back in action.

Not sure if it just flushed the cache.

If you can't find where to do this, go to the IP address of your device in a web browser (something like http://192.168.1.54 ) and use admin/admin to login.

Go to System Management -> WAN Settings.

Uncheck DNSServer1 and DNSServer2 at Default on the right.

Enter: 1.1.1.1 in one and 1.0.0.1 in the other.

Save at the bottom.

Reboot at the top right.

That's what did the trick for me.

I tried this, and it didn't work. What did work, however, was a similar action. I unchecked the DNSserver1 box and entered 1.1.1.1. I left the DNSserver2 box checked. Now it's working. Thanks guys!

Chronoblast

For me setting the DNS to 1.1.1.1 and flushing the DNS cache worked only intermittently - the proxy IP address kept going bad.

I fixed it on my 1022 phone by going to the local (built in to the phone) web interface (in my case typing 192.168.1.16 into my browser address field), then:

1. On the menu on the left select System Management, then WAN Settings
2. Scroll down to Local DNS Records
3. Uncheck the Default box on record 1
4. Put:
    obihai.telephony.goog=216.239.36.144
5. Select Submit at the bottom of the page
6. Select Reboot at the top of the page

SteveInWA

Quote from: Chronoblast on December 08, 2018, 04:00:52 PM
For me setting the DNS to 1.1.1.1 and flushing the DNS cache worked only intermittently - the proxy IP address kept going bad.

I fixed it on my 1022 phone by going to the local (built in to the phone) web interface (in my case typing 192.168.1.16 into my browser address field), then:

1. On the menu on the left select System Management, then WAN Settings
2. Scroll down to Local DNS Records
3. Uncheck the Default box on record 1
4. Put:
    obihai.telephony.goog=216.239.36.144
5. Select Submit at the bottom of the page
6. Select Reboot at the top of the page


Do not follow this advice.  Never hard-code server IP addresses; they can change in the future, and then you will have a difficult-to-diagnose problem that nobody can help you figure out, because nobody does this.

It is entirely unnecessary.  When IP addresses change, it can take some time for the new IP address to propagate to all DNS servers.  After that happens, there's no need to reference a server's IP address.

BenE

It's a work-around, and it worked for me on both OBI200s.  After someone reports that the DNS change has been propogated (at least to the ATT DNS server), without making a change, I'll change it back!

SteveInWA

It works just fine on the Google DNS (8.8.8.8 ) and on the Quad9 high security DNS (9.9.9.9)

doctor34

Quote from: josephstern on December 08, 2018, 03:11:26 PM
I changed my Obi's DNS to 1.1.1.1 and 1.0.0.1 and I'm back in action.

Not sure if it just flushed the cache.

If you can't find where to do this, go to the IP address of your device in a web browser (something like http://192.168.1.54 ) and use admin/admin to login.

Go to System Management -> WAN Settings.

Uncheck DNSServer1 and DNSServer2 at Default on the right.

Enter: 1.1.1.1 in one and 1.0.0.1 in the other.

Save at the bottom.

Reboot at the top right.

That's what did the trick for me.

You can also access the "Expert Settings" from the ObiTalk.com pannel, but the steps are nearly the same, and oddly, doing it there does not require a reboot - mine found the new DNS service immediately on saving!

BTW, if you want to use the IP address as Joseph shows doing, dial ***1 from any phone on your Obihai box to see what the IP address is.

(I have mine reserved as a specific address by the router, but oddly at times it wants to use something else anyway.)