OBi + GV: Neighbor Spoofing Robocall Blocking

Started by slow_quick, January 14, 2019, 10:07:48 PM

Previous topic - Next topic

slow_quick

I found a way to block "Neighbor Spoofing Robocall" using OBi device + GV.

Hypothetically assuming:
1. my GV number is 402-346-1400 and this is my SP1;
2. I have 3 friends in the neigbor area, 402-346-1401, 402-346-1402 and 402-346-1403

I would like to block 402-346-xxxx except for 3 friends' numbers.

First I set up 2  user defined digitmaps:
wlist = ( (+1|1)? 402 346 (1401 | 1402 | 1403) )
blist = ( (+1|1)? 402 346 xxxx )

I then set up SP1's InboundCallRoute:
X_InboundCallRoute = {(Mwlist):ph},{(Mblist):sp1(14025551212; ui=$1)},{ph}

The first rule is white list, let friends phone to come to my phone.  The second rule is black list, all other neighbor phone numbers are captured here, and forwarded to the directory assistant number 402-555-1212.  Google Voice tells the caller "We can not complete your call.  Please try again.", click, disconnected.  If the incoming call does not match the first two rules, it passes to the last one, the phone.

My land-line phone (GV+OBi200) is so much quiter now.

This method is good if you've moved around and kept the old number so you have only a few old "neighbor" friends, making it easy to come up the white list.


slow_quick

Quote from: drgeoff on January 15, 2019, 03:28:22 PM
http://www.obitalk.com/forum/index.php?topic=13055.msg83657#msg83657


Aha, I'm re-inventing the wheel.

Tried your way: {(Mblist):}, it works by simply ignoring the call, so my GV voice mail answers it.  Using my method: {(Mblist):sp1(14025551212)}, the GV picks up, tells the caller "can not complete the call" and hangs up.  Nothing left in my GV voice mail.

kgjulie

Thank you to the OP. I just set this up on my Obi202. I have been getting these fake "neighbor" robocalls for years. I have already blocked many in my dialer app on my mobile phone, but then they just get diverted to voice mail (blocking in the dialer app just suppresses the ring). I would rather have them dead-end. I also have been blocking these calls on-by-one in GV, but every time the last 4 digits change, a call gets through. I would love a way to do similar in GV for the robocalls that dial my mobile number directly, and then GV answers for voice mail. Thank you again.

Sheffield_Steve

Do you have the "Global Spam Filtering" option enabled in GV?

I do and very rarely do I get a spam/spoofed call.

kgjulie

I do have it enabled, and periodically I go through my call log in GV and mark those calls as spam and block them. It's tedious.

Mike1111111

At some point in the past year, the trick of sending spam callers to the 14025551212 directory assistance number stopped working. My main phone does still does not ring, but my cell phone, where my Google Voice calls are forwarded, continues to ring and if I don't answer the spam callers go to my Google Voice mail. Does anyone know what happened or what the fix is?

Maybe I need to direct the calls to Nomorobo instead of directory assistance?

Taoman

Quote from: Mike1111111 on December 06, 2020, 05:40:22 PM
Maybe I need to direct the calls to Nomorobo instead of directory assistance?

You can always send them to Lenny. He'd love to chat with them.
347-514-7296

owatson

Quote from: slow_quick on January 14, 2019, 10:07:48 PM
I found a way to block "Neighbor Spoofing Robocall" using OBi device + GV.

Hypothetically assuming:
1. my GV number is 402-346-1400 and this is my SP1;
2. I have 3 friends in the neigbor area, 402-346-1401, 402-346-1402 and 402-346-1403

I would like to block 402-346-xxxx except for 3 friends' numbers.

First I set up 2  user defined digitmaps:
wlist = ( (+1|1)? 402 346 (1401 | 1402 | 1403) )
blist = ( (+1|1)? 402 346 xxxx )

I then set up SP1's InboundCallRoute:
X_InboundCallRoute = {(Mwlist):ph},{(Mblist):sp1(14025551212; ui=$1)},{ph}

The first rule is white list, let friends phone to come to my phone.  The second rule is black list, all other neighbor phone numbers are captured here, and forwarded to the directory assistant number 402-555-1212.  Google Voice tells the caller "We can not complete your call.  Please try again.", click, disconnected.  If the incoming call does not match the first two rules, it passes to the last one, the phone.

My land-line phone (GV+OBi200) is so much quiter now.

This method is good if you've moved around and kept the old number so you have only a few old "neighbor" friends, making it easy to come up the white list.

Thanks for sharing this. I think I will try to set up this. Until now, I only ignore any calls if I'm not familiar with the numbers. Sometimes I will also Google them or check them up on complain boards like http://phonebook.ai to see if people have reported those numbers, so I can manually block them.

Malachi123

Thank you for sharing this simple solution. I'm going to implement it as well.. and see if this helps against my "stalker" (calling every day!).

Mike1111111

The problem might be with the 14025551212 number. I get an error message when I call that number from my Google Voice phone. I get directory assistance when I call from my AT&T cell phone. If I put my own cell phone number in there I get the call on my cell phone, so the concept works. I need a number that will answer the call immediately so the spam caller does not get my voicemail. I tried 11111@in.callcentric.com, which was posted in another thread, but that does not work either.

azrobert

Send the call to NoMoRobo like this:
spx(18667326184@tollfree.alcazarnetworks.com;ui=12126628642)

Change spx to a non-GV SP number.
12126628642 is a known spammer and in NoMoRobo's database.

Mike1111111

Thank you so much. Your suggestion of using Nomorobo works to terminate the calls from my block list instead of sending them to my voice mail.

Mike1111111

#13
If it helps others, this is my setup. My main phone number area code is 814 in Pennsylvania. All calls I get from that area code are spam, since I no longer live there. The spoofed "local" calls evade Nomorobo and the Google Voice spam blocker. My prior broken setup was stopping these calls from ringing my Obitalk phone, but they were still leaving me voice mails and ringing my cell phone.

I have an Obi202 with phones connected to ph1 and ph2. Ph2/sp2 is my 814 Google Voice number. The below setting disconnects anything on my ban list. The other calls ring my Obitalk phone and simultaneously ring Nomorobo to enable that spam filter. I have my Google Voice set to ring both the Obitalk phone and my cell phone.

Calls from the ban list are now immediately answered and they hear a message "your call has been intercepted by Nomorobo." For callers on my ban list, my Obitalk phone does not ring, my cell phone does not ring, and I do not get any voice mails.

/*Set up the unused SP4 service*/
Service Providers > ITSP Profile D > SIP > ProxyServer: 127.0.0.1
Service Providers > ITSP Profile D > SIP > X_SpoofCallerID: checked
Voice Services > SP4 Service > Enable: checked
Voice Services > SP4 Service > AuthUserName: anything
Voice Services > SP4 Service > X_RegisterEnable: unchecked
Voice Services > SP4 Service > X_ServProvProfile: D
/*Block all calls with an 814 area code*/
User Setting > User Defined Digit Map 2 > Label: ban
User Setting > User Defined Digit Map 2 > DigitMap: ((+1|1)?814xxxxxxx)
/*Mban is the list of banned phone numbers defined by the digit map. 1877659xxxx is my Nomorobo number. 12126628642 is a known spammer in the Nomorobo system. ui=$1 passes the caller's phone number to Nomorobo.*/
Voice Services > SP2 Service > X_InboundCallRoute
{(Mban):sp4(1877659xxxx@switch.starcompartners.com;ui=12126628642)},{ph2,sp4(1877659xxxx@switch.starcompartners.com;ui=$1)}