Google Voice not sending calls to my obi

Started by ymcp, February 20, 2019, 10:16:32 AM

Previous topic - Next topic

ymcp

Hi
i have an obi200 with google voice and set the auto attendant to answer the calls and have no issues (this is connected to the internet thru verizon fios)
at another location i have obi202 with the aa set to answer all incoming calls and two other google voice numbers that stop sending the calls to my obi after a while (sometimes a day or two)
it works at first and after a reboot
i followed all steve's instructions to delete device and start over. also i set dns to 8.8.8.8 and 8.8.4.4. on my router (internet with optimum online)
outbound seems to work fine
any help is appreciated

frankb

I had the same issue, and I solved it by going to the google voice app on my phone.
Then go into settings, and go to incoming calls.
Uncheck the Web option (I only have the obitalk device checked).
Try to see if incoming calls works again?

ymcp

i have it unchecked but still doesn't forward. also it wouldn't make sense to work at first and then stop working for no reason
thanks

SteveInWA

Quote from: frankb on February 20, 2019, 11:12:02 AM
I had the same issue, and I solved it by going to the google voice app on my phone.
Then go into settings, and go to incoming calls.
Uncheck the Web option (I only have the obitalk device checked).
Try to see if incoming calls works again?

NO.  That's wrong.  Don't do it.  The "Web" entry in the "My Devices" section is there on purpose.  It is the VoIP client for the new capability to make and receive calls on the Google Voice website.  It has nothing at all to do with OBi function.  Leave it alone.

To solve this problem, go to the OBiTALK dashboard, click on your OBiTALK device, then click on the SP1-SP4 slot you used to set up Google Voice.  On the next page, click the link to replace your Google account credentials and follow the instructions.

It will pop up a window asking you to confirm that you are authorizing OBiTALK to use your Google account's Google Voice service.  Make damn sure that the Gmail address it shows is the correct Google account that holds your inbound Google Voice phone number.  If not, you're signed into the wrong Google account.  Complete the process and wait for the device to reboot.

ymcp

thank you steve. it works now. but i'm not sure if it works only because of the reboot. i will let you know in a couple of days if it still is working

ymcp

well once again it stopped working
at 02/24/2019 01:54:01 it was still working (aa answers) and as of now 02/24/2019  09:30 it isn't.
outgoing still works fine
i made no changes to obi or google voice acct since the last reconfirming of the google acct (as per steve)
i'm at a loss and any help is appreciated
thanks

SteveInWA

I don't understand what you are trying to accomplish.  Don't use the OBi auto-attendant in conjunction with Google Voice.  Why would you do that?

ymcp

i am trying to avoid spam calls by having the caller press 1. also i am trying to avoid google voicemail from answering the call.
i am not even sure if the auto attendant is the issue because it does work perfectly at first. and also at another location i have it set up the same way (a single other google voice account) and it never stops working
thanks so much for your time

SteveInWA

Don't use the OBi auto-attendant for this.

You cannot disable Google Voice's voicemail.  You can, however turn on Google Voice's call screening feature.  But, all it will do is ask you to press 1 when you pick up the phone.  It will not prevent Spam.

ymcp

thank you. i realize that i can use call screener. i was just hoping there would be way to actually fix this. because like i said it does work elsewhere and it does work at first. what can possibly cause the obi/gv to stop working as it does when first starting up after reboot.
thanks again