New OBi2182 added to OBiTALK connected GV not listed in GV

Started by sentry02, July 04, 2019, 05:56:15 AM

Previous topic - Next topic


I have spent a full day searching the forums trying to find anything to help.

I have followed Steve's directions to reset everything and start over multiple times.

I had an OBi200 working, but want to replace it with my OBi2182.  So I followed Steve's steps to remove everything and start over.

I get the OBi2182 added to my OBiTALK Dashboard and SP1 connected to the correct Google Voice Account, and the dashboard shows it is connected.  But the OBi Device does not appear as a device on the Google Voice Settings page.

**9 222 222 222 works successfully.

When I dial from the OBi2182, I do not get any ring tone, it just sits there silently "Trying"

I have to assume the problem is that the OBi Device is not appearing in the Google Voice settings.  But I cannot find a solution.  I thought I remembered a step for the OBi200 that all I had to do was place an outgoing call from the handset on the OBi200 and it would get added to the Google Voice devices under GV settings.  But I must have been imagining that.

Any help from anyone would be greatly appreciated.  Even if it is to send an email to OBiHAI Support, but of course I still have to find that address.

Thank you


There is no email address. There is a "open a ticket" web page linked from one of the troubleshooting pages.


Hi:  sorry to hear that my previous posts didn't get this working.  Is this a brand new out-of-the-box phone, or was it previously used with a business-class service provider?  Did you try restoring it to factory defaults and then setting it up again?

Are you using a consumer account, or a G Suite account (the 2182 will only work with consumer Gmail accounts)?

If you were able to add it to your dashboard, and I assume you meant that SP1 says "Connected", not just the device in general, then it should at least be able to make calls.

You may have accidentally authorized SP1 to the wrong Google/Gmail account, if you don't see it on the Google Voice settings page as an "OBiTALK Device".

Google allows multiple accounts to be signed into a web browser at the same time.  Some Googly things can keep this straight, but others, like Google Voice, have problems.  To solve this...

Open a laptop/desktop computer's web browser.  If you're using Google Chrome Browser or Safari, press Ctrl-Shift-N to open an incognito window, or, if you're using Firefox, press Ctrl-Shift-P to open a private window.  In that window, sign into the correct Gmail account that holds your Google Voice number, and go here:  Do you see your Google Voice number at the top of the page?  If not, this is the wrong Gmail account--find the right one.

If you found it, then press Ctrl-T to open another tab in that private/incognito window, and go here:

Go to the Security section.  Scroll down to the section:  "Third-party apps with account access", then "Manage third-party access".  Do you see an "OBiTALK Google Voice" permission?  If not, then the OBiTALK setup didn't complete, or you set it up on a different Google account.  If you do see it, then delete it.

After deleting the permission, while still on the private/incognito browser, press Ctrl-T to open another tab.  In that tab, go here:  Delete SP1 and then add it again, making darn sure that, when it pops up the window asking your permission to access your Google account, it's asking for the correct account.

Did that solve the problem?


Thank you both for replying on a holiday.  Happy 4th of July to everyone.

This is a new out of the box OBi2182.  I bought it on Amazon and am pretty certain it is brand new and not used at any service provider previously.

I have performed 2 factory resets on it already.  I will try the entire process again using an Incognito browser.

Yes, I did mean that SP1 was showing connected to Google Voice.  I did follow your directions twice, at least, doing a factory reset both times.  The first time I followed your directions I removed both the OBi200 I am replacing and the OBi2182 I am trying to setup.  I removed them from all locations they appeared.  Both were on my OBiTalk dashboard, so I deleted them there.  There were multiple entries in my account's third party access, so I removed them all.  And the OBi200 did appear as a OBiTalk device in my GV settings, so I removed it. 

When I setup the OBi2182 again, while adding it to my OBiTalk Dashboard, the GV agreement from failed to display, but I hope that is not relevant, so I clicked accept each time.  It did configure for the correct consumer gmail account and related consumer Google Voice account. 

I am using Google Chrome with multiple accounts logged in, so I will certainly use Incognito mode and will do it on Firefox private window instead of Chrome.  I did check the Google Voice for my other gmail accounts and there are no OBiTalk devices listed on them.

Each time I setup the OBi2182 it appears on my OBiTalk dashboard with no issues.  SP1 is connected and details show it is connected to the correct Google account.  In my Google account settings, third party access, I do get 1 OBiTalk entry showing it has access to Google Voice.  But in the actual Google Voice settings, there is no OBiTalk device.  Every time I add it to the dashboard and setup Google Voice, there is the Google Account confirmation to allow OBiTalk to have access and then a following window that asks me to double check and be extra certain that it is showing the Google account that I am trying to setup.

I will report back after I try doing it all again from a Firefox private window.

Thank you again for taking time to reply today.


Just repeated the process using a Firefox private window.  Same results.

Added to the OBiTalk Dashboard fine

Configured SP1 for Google Voice using the correct and confirmed consumer Google account and it shows connected on the OBiTalk dashboard

In my consumer Google Account, under Security >> Manage third party access, it shows OBiTalk has access to Google Hangouts, basic account information, and access to make and receive phone calls.  It also shows OBiTalk as Sign In access to Google Voice and OBiTalk Quick Sign Up.

In my consumer Google Voice settings, for devices, it shows Web and my iOS device, but no OBiTalk device

I can make and receive calls from my Google Voice number using the web browser, and it was working on the OBi200 for almost a year before I decided to upgrade to the OBi2182.

I have configured the OBi2182, under Expert configuration to send to my syslog server, but it doesn't appear to send anything at all.  So maybe I'm missing a setting on getting it to actually send anything to the syslog.  I thought that would give me some clues if it did send to the syslog server.  I configured that setting from the OBiTalk dashboard, not the local web GUI on the phone.

* edit * I did also enable X_SipDebugOption to Log all messages for SP1 *edit*

and **9 222 222 222 is still working fine.

Thoughts?  Is there anything else I can try?  Any other logs I can look at?  Anything at all.  


Does it matter that I only have Web and iOS devices setup in my Google Voice account?  I assume not, since my OBi200 was working.

Today I am going to run through the process to setup my OBi200 on this Google account again and see if it shows up as an OBiTalk device on the Google account.


I setup my OBi200 again.  And it worked perfectly, and immediately.  It shows up on my Google Voice settings as an OBiTalk device with the 9 digit OBi number.  The one difference I noted while it was configuring SP1, before showing connected it had reported a status of Registration not required, and then went to Connected.

This OBi200 was previously setup on this Google Voice account, but I had deleted it and removed it while I have been trying to setup my new OBi2182.

Is there anything else I can try to get my OBi2182 to show up as a device on my Google Voice account?  Or to even just figure out if it is getting any error messages or blocked for some reason?  Maybe this OBi2182 was as new as it looked coming out of the box?  Maybe its 9 digit number was already registered to some other Google Voice account, is there any way to check the 9 digit number in the OBi backend systems to confirm that?


Thank you, I did submit a support request using that link and included the link to this thread.

I used my primary email address for that support request, not the gmail address that I am using for my OBi2182 setup.  In case the support team tries to lookup the email address on my support request.

I'm looking forward to hearing from them.

Thank you.


Yeah, it should simply work, exactly as it did/does with the OBi 200.  There's no need to delete the 200; you can have any combination of 200 series 1000 series and 2000 series products on your dashboard, all configured to use the same Google account.

Hopefully your ticket will get some attention.  By the way, what is the firmware level of the phone?


I worked on getting my syslog events working.  I see that my OBi2182 is referencing XMPP, which is no longer supported for Google Voice.  The OBi200 does not have any references to XMPP, which obviously makes sense.

The OBi2182 LCD status and OBi Expert shows:

HardwareVersion 1.0
SoftwareVersion   6.2.2 (Build: 4788.1311)

Under System Management >> Auto Provisioning it shows that Auto Firmware Update is disabled

And syslog events show:
Jul  8 11:05:17 obi2182  PROV processing event(s): 1
Jul  8 11:05:17 obi2182  PROV: Start to download files ...
Jul  8 11:05:17 obi2182  BASE:resolving
Jul  8 11:05:17 obi2182  TCP:Connect OK(HTTP GET)50
Jul  8 11:05:17 obi2182  HTTPC: Server response: 404
Jul  8 11:05:17 obi2182  PROV: Failed to get file (-404)
Jul  8 11:05:17 obi2182  PROV: reschedule next auto firmware update process
Jul  8 11:05:17 obi2182  We will check new firmware in 86400 s
Jul  8 11:05:17 obi2182  PROV event(s): 1 processed
Jul  8 11:05:18 obi2182  PARAM Cache Write Back(256 bytes)
Jul  8 11:05:18 obi2182  PROV processing event(s): 2
Jul  8 11:05:18 obi2182  PROV: Start to download files ...
Jul  8 11:05:18 obi2182  BASE:resolving
Jul  8 11:05:18 obi2182  PROV: Invalid server name, Skipped


Your phone needs a firmware upgrade.  OBi support should be able to push it to your phone manually.


I was beginning to think that I needed a firmware update, so I've been looking everywhere.  It looks like it is not publicly available for manual updating.  The OBi2182 OBi IVR says there is no update available.  It would be great to be able to update my firmware when there are updates.  And auto updating the firmware would be fine with me.

And since the OBi2000 Series IP Phones are available on Amazon, I had hoped that the firmware files and support documentation would be more readily available.  I guess I was wrong there. 

I'll wait for someone to respond to my ticket. 

It makes me wonder if I should have gone with the VVX 450 OBi Edition and a G Suite account, assuming that paid support would get faster turn around time on responses.  Or maybe I should have gone with a refurbished 1062.

Thank you SteveInWA and drgeoff for being so responsive and, from what I can tell, all of your support on this forum.


As you can see from your syslog, the firmware update URL built into the OBiTALK configuration doesn't work.  The only way at this time, to get an update, is via a ticket to support.  If they don't get back to you in the next day or so, please reply again, and I will rattle some cages.


Sorry Steve, that was my bad.  I didn't choose my words clearly.  I knew that the server name that the phone was trying to use was not valid, as you said, based on my own syslog.  I was just hoping that there was a documented step that an average user could do to trigger the phone to use a different and valid server name for that update, or for the average user to manually download the firmware and update the phone. 

It is no longer an issue at this point.  As someone magically updated my OBi2182 recently.  It now has:

SoftwareVersion   6.2.3 (Build: 4907.1311)

UpTime   0 Days 17:17:04 (3)

I have to assume it was done about 17 hours ago and I didn't realize it until it just now, when it received an inbound phone call from the Google Voice number.

While I appreciate that the problem is resolved, I don't know who to thank or what they actually did to resolve it.  I have to assume that they were able to update the device profile on the OBiTALK dashboard to have it push out the firmware.

I don't have any emails related to the ticket that I opened, and I'm not sure that I have any way to go view my ticket to see if there are any comments. 

So, I guess, for anyone else reading this post that had the same issue with a new OBi2000 IP Phone, if your firmware is older than my current SoftwareVersion posted here, simply open a ticket using the link posted earlier in this thread and give it a couple of business days to be resolved.

Thank you to whomever pushed the update to my phone, and again, thank you SteveInWA and drgeoff for all your help and all you do on this forum.


Great; thanks for circling back with the resolution.  Yes, that's the latest firmware, so they must have pushed it to your phone after you opened a ticket.


I have the exact same problem...I filled out the support ticket.  Is there any way you can post your Obi expert config parms?  I think they pushed an update to that so it knows where to look for the firmware.  I want that URL.  It's the System Management -> Auto Provisioning section....thanks!


I have the same problem as well.  Opened a ticket, but no word back.  Is there anywhere to get the firmware file to manually update?



Quote from: ScubaZ on July 30, 2019, 09:04:42 AM
I have the same problem as well.  Opened a ticket, but no word back.  Is there anywhere to get the firmware file to manually update?


I reached out to them on FaceBook messenger.  They asked for the number on the back of my unit and it was working in two minutes.  I messaged them at 11:30pm eastern and they responded the next morning.  It just needs a firmware push.

What I'm not clear on is if it will continue to update itself properly.  They told me it would but I cannot see evidence of that in the settings.



I sent a message in facebook messenger and in two minutes the phone was downloading an update.  Works fine now.