Any More Firmware Updates for Obi2xx Devices Planned???

Started by chilirock, February 18, 2020, 10:50:28 AM

Previous topic - Next topic

chilirock

It's been almost 12 months since v5921 was released. Firmware updates for these devices used to come out fairly regularly, every couple of months. With the lack of firmware activity in the past 12 months, it makes me question the importance of the device to Polycom/Plantronics. It's not like there is a lack of issues to be resolved or security risks to be mitigated.

nsne

I've had the same question. Periodic firmware releases to refine/augment the existing code are a sign of the health of a product and the manufacturer's commitment to it. No official firmware releases for more than a year does not inspire confidence.

And it's not like there's nothing to fix or improve. When calling with Google Voice, I'm still getting occasional blasts of static that cause the line to go dead for the other party. The device GUI and the link with OBiTalk could also use some serious housecleaning.

Andy_Shiekh

#2
There are new firmware updates for the Obi3xx (Nov 1 2019, Jun 19 2020)
https://support.polycom.com/content/support/north-america/usa/en/support/voice/voip-adapters/obi300.html
so I am hopeful as the Obi2xx and Obi3xx used to share the same firmware.

Some people have even loaded these into an Obi200
http://www.obitalk.com/forum/index.php?topic=17220.msg104496#msg104496

And before I am asked again, yes, I am obsessed with new firmware.

SteveInWA

How many times does it need to be said?  That build will NOT work with Google Voice.

Andy_Shiekh

While you are almost surely right, I was still wondering if someone has confirmed this for sure; i.e. actually tried it.


SteveInWA

Quote from: Andy_Shiekh on July 20, 2020, 07:15:51 AM
While you are almost surely right, I was still wondering if someone has confirmed this for sure; i.e. actually tried it.

Just to humor you, yes; I did, and no, it does not work.  The SP will appear to be "connected", but it will not create the necessary SIP client link on Google Voice.

There is no reason to need an upgrade at this time.


chilirock

It's been almost 18 months without an update to the firmware. I guess that means that support is officially out to lunch... and dinner. Anyone else concerned about security issues related to out of date libraries built into the firmware? 

Andy_Shiekh

#9
When I asked I got

Quote from: SteveInWA on July 12, 2020, 01:02:16 PM
Why are you so obsessed with new firmware?  It's all you've posted about since 2017.  I already stated that this build does not work with Google Voice.  There is no reason to keep upgrading just for the heck of it.

so I have stopped asking.

But Steve is right; what we have now works, and for that I am grateful.

I'm just a little nervous as at one point I didn't keep up and Google Voice stopped working, so I saw that as my bad and have since tried to keep up.

Tech-God

Quote from: Andy_Shiekh on August 29, 2020, 07:14:05 AM
When I asked I got

Quote from: SteveInWA on July 12, 2020, 01:02:16 PM
Why are you so obsessed with new firmware?  It's all you've posted about since 2017.  I already stated that this build does not work with Google Voice.  There is no reason to keep upgrading just for the heck of it.

so I have stopped asking.

But Steve is right; what we have now works, and for that I am grateful.

I'm just a little nervous as at one point I didn't keep up and Google Voice stopped working, so I saw that as my bad and have since tried to keep up.

Have you asked support formally?

If you have specific problems that you feel need to be addressed simply send a note to software listing the issues and ask them to fix them and to confirm receipt of the request.

Andy_Shiekh

#11
As Steve correctly points out; it works. So I am happy.

dandu3

3.2.3 (Build: 7628)   is installed and works great on my OBi. with voip.ms

SteveInWA

Quote from: dandu3 on November 02, 2020, 09:43:08 PM
3.2.3 (Build: 7628)   is installed and works great on my OBi. with voip.ms

Do NOT install this firmware if you plan to use Google Voice.  It will NOT work.