Blocking UNKNOWN NAME callers

Started by FritzG, October 02, 2020, 11:22:04 AM

Previous topic - Next topic

FritzG

Hi,

Searched the forum and did not see a specific answer for this. 

I did see and read many posts/links on how to set up anonymous call blocking features in the Obi management interface

- AnonymousCallBlockEnable
- X_BlockedCallers (with case sensitive entries for all the usual suspects - i.e. withheld, WITHHELD)
- dialing *77 from a connected handset

but nothing has stopped that particular type of call.

I also read about the Digit Maps feature and how to set that up (which I have not yet done).  I have also looked at its' limitations.  Before I go that route, I was wondering if I was doing something wrong or missing something simple.  I am not looking forward to sitting down and figuring out a good digit map to block those calls.  From the call history, it looks like every area code and exchange in America is being used. 

I am using Google Voice with my Obihai and it is not a main number or anything.  It is the number I use to avoid getting cold calls on my cell phone and also to be able to do this - block unwanted callers.  Any help would be appreciated.  Thanks.

Taoman

Quote from: FritzG on October 02, 2020, 11:22:04 AM

- AnonymousCallBlockEnable
- X_BlockedCallers (with case sensitive entries for all the usual suspects - i.e. withheld, WITHHELD)
but nothing has stopped that particular type of call.
From the call history, it looks like every area code and exchange in America is being used.
You're not going to block any calls based on CNAM with your OBi device.

Next to the X_BlockedCallers field you will see a question mark icon. Hover your mouse over it and you should see that field is only for numbers, not names/words. The fact you can even enter alpha characters in that field shows poor error checking on Obihai's part.

The OBi can block incoming calls based on phone numbers, not Caller ID name.


drgeoff

In addition to what Taoman wrote, GV forwards to the OBi only the caller's number, not the name.

SteveInWA

It's already been stated that you can't block calls based on the Caller ID Name (CNAM).  But, understand that the CNAM field is irrelevant with regard to call blocking.  Given that Google Voice doesn't use carrier-based CNAM at all, whatever characters are in the name field of a linked phone number's caller ID display are not provided by Google Voice or its carrier partners.

The phrase "UNKNOWN" or "ANONYMOUS" or "PRIVATE CALLER" or some other wording are substituted by the carrier receiving the forwarded call (e.g. your mobile or land line phone company), or are added by your telephone itself.

The calls you actually would want to block are calls that contain no caller ID number.  Google Voice itself can usually recognize these calls and send them directly to your voicemail greeting, if you configure it to do so, via the old, "Legacy" website.  This happens before the call would otherwise be sent to your devices or numbers.  Spammers/robocallers rarely leave voicemail, since their predictive dialers typically ignore calls not answered by a live person.

Sign into the correct Google/Gmail account that holds your Google Voice number.  Go here:  https://www.google.com/voice#groups

Edit the "Anonymous callers" row, and disable (un-check) all of your linked devices and numbers.  Save the setting.  See the screenshot below.

FritzG

Thank you all very, very much.  GREAT feedback and answers.  So not used to seeing that on internet forums.  :-)

FritzG

Quote from: SteveInWA on October 02, 2020, 05:12:47 PM

Sign into the correct Google/Gmail account that holds your Google Voice number.  Go here:  https://www.google.com/voice#groups


Is there a trick to getting to that URL?  I tried using different browsers, incognito and even old browsers but I always get redirected to the current dashboard. 

Note:  I am mostly likely just going to cycle the phone number tied to my Obi since it is not imperative I keep it.  This was an exercise in learning the capabilities of the Obi.

Thanks again.

Taoman


FritzG

Quote from: Taoman on October 15, 2020, 04:29:48 PM
Quote from: FritzG on October 15, 2020, 04:06:32 PM
Quote from: SteveInWA on October 02, 2020, 05:12:47 PM

Sign into the correct Google/Gmail account that holds your Google Voice number.  Go here:  https://www.google.com/voice#groups


Is there a trick to getting to that URL?
Try this:

https://www.google.com/voice/b/0/redirection/voice/#groups

No joy.  Its probably something I did with my account that won't allow me to load up the old interface.  Thanks for trying. 


SteveInWA

The screenshot you posted is from a Google account that doesn't have a Google Voice phone number, so, of course, there are no settings to control that number.

Use a laptop/desktop computer's web browser, not a tablet or smartphone.  If you're using Google Chrome Browser, Edge or Safari, press Ctrl-Shift-N to open an Incognito browsing window.  If you're using Firefox, press Ctrl-Shift-P to open a Private browsing window.

In that window, sign into the one, and only one Google/Gmail account that you are using to submit the port request.  Go here:  https://voice.google.com/settings

Do you see your inbound Google Voice phone number at the top of the page?  If not, you are either signed into the wrong Google account, or you don't actually have a Google Voice phone number.  If you do see the number, then "X" out of settings and return to the main Google Voice page.  Click the three horizontal bar "hamburger" menu icon in the upper left corner, then click "Legacy Google Voice".

FritzG

The issue was the USER, not the advice.

I got into it after logging into the correct account.   ??? :o :D

This has improved the quality of my life.  Thank you so much Steve.  It is immensely appreciated. 

Fritz

SteveInWA

I'm glad that your mystery has been solved.