On Tuesday September 6th the forum will be down for maintenance from 9:30 PM to 11:59 PM PDT

Main Menu

token error

Started by chiptape, June 09, 2021, 12:50:17 PM

Previous topic - Next topic



fw 3.2.2 (Build: 5921EX)
google voice on SP1 connected to my home phone wiring.
Home phone wiring is disconnected from the outside phone wires.

When calling out, it says, "The number you dialed, xxx xxxx has not received a response from, the service provider.".
This has been an intermittent problem over the last year or so.

Incoming calls go to my voicemail.

I received an email saying "Service Offline Alert -- OBi Device (xxxxxxxxx) is Not Registered".
I think I took care of that.
I use two google accounts on my PC.

The Self-Troubleshooting Guide instructed me to router > DMZ > enable.
I did that.

Now SP1 at says "Connecting to;Token Error".

SP2 says "Registered".
SP2 is Anveo E911.
933 test works.

Can you fix it?


What did you do that makes you think you took care of the "service offline" email?

It is almost never necessary to put an OBi in the router's DMZ.

Please delete the other copy of your post and refrain from posting the same thing more than once.


"Service offline" email:

I did the following at...
OBi Dashboard >
SP1 >

Replace Google Account Credentials
to the correct account, and then,
Click Here to connect the OBi with your active Google Account



Unfortunately, I get the same error all of a sudden, was working for a several weeks, then today the token error.

I rebooted the device, removed and re-added the SP1 Google Voice service.
Replaced credentials.
No help.

933 test still works.

Outgoing calls say "Has not received a response from the service provider"

All the settings at are fine.
I can see incoming calls at, but the Obi200 never rings.


I received two more emails saying "Service Offline Alert -- OBi Device (xxxxxxxxx) is Not Registered".
Both were for the same device number.
They said exactly the same thing.
One is dated 3:30am, and the other was 6:45am.

I did the following again at...
OBi Dashboard >
SP1 >

Replace Google Account Credentials
to the correct account, and then,
Click Here to connect the OBi with your active Google Account

SP1 says "Registration Not Required".
SP2 says "Registered".


AIUI the emails mean that the Obihai server(s)* has lost contact with your OBi.  That does not necessarily mean that there is a problem between your OBi and any of your ITSPs.

(* The OBihai server is what powers your dashboard at and also enables calls between OBis made by dialling **9 followed by an 8 digit OBi number.  The server plays no part in call set-up nor voice data transmission for any other calls to or from your OBi.)


Now SP1 says "Connecting to;Token Error"
Obi device status = Online


Just on forum with same issues and questions.
Keeps logging off for token error.
Then may come back after time as registration not required.
I have two google voice numbers on a 202. Has been working well.
I logged in my credentials again, when it gave token error again. Will see how long it lasts this time before going off line. Started in
lasf couple of days with several errors and system off,


This is not isolated as I am having the same issue. My config has been working fine with no changes since December.
Obi200 with 3 Google Voice lines all having the same issue: Connecting to;Token Error
The Anveo E911 is not reporting issues.


Me too, my primary GV line is showing a token error and I had many emails about OBI Device Offline then back Online today.


I am also having the same problem. mine started yesterday around mid day. I have done all of the same steps and thought it could be a router problem.

I am using a Netgear Orbi router. I attempted to DMZ it with the same problems.

Hope we can find a solution. If not does anyone have a good alternative?


I am getting the same token error and message on outgoing calls that cannot connect to service provider. Please help!!!!


So did the sign in with GV credentials and reconnected. Again notices last night system went off at 10pm and notice connected again at around 7 am.
Showing connected now, but patterns of token errors continue.


I have the same issue - sometime last night both of my Google Voice lines went down and now I have the Token issue.  I have been running fine for YEARS.  

Going to the configuration and updating my Google credentials does not make any difference.

Has anyone found a solution, or at least a work-around?


1.  If you have GV and at least one other different ITSP configured and they all go down it is almost certainly a network problem or a faulty OBi.  That multiple people are reporting the same issue tends to rule out faulty OBis.

2.  If you have GV and at least one other different ITSP configured and only GV goes down it is almost certainly a problem at Google's end.  Once you have successfully configured an OBi with GV, the Obihai servers play no further part in maintaining the connection between GV's infrastructure and the OBi, nor in call set-up nor voice data transmission for GV calls to or from the OBi device.


Started a few days ago, same issue as everyone else.

Perhaps Google once again has  made a change that require some reconfiguration of the Obi devices?

Like previous poster I have been an Obi user since day 1, never had this issue.


GV worked fine with Obihai 200 last night.

Today I cannot make or receive calls. I just received my first covid dose and due to my age and living alone, have several people calling to check on me but my phone doesn't ring and in case I am not well I cannot call out.

In dashboard, I also see Connecting to (my IP address);Token Error

I tried reregistering, and unplugging and reconnecting the obihai, it doesn't fix the issue.

My GV calls forwarding to my cell works, the cell rings but not my landline phones connected via Obihai 200.

Anyone have any way to report this to Obihai or GV to be fixed?



Today, I just noticed that I'm getting a "Token error", and sometimes "Registration Not Required".


I also had the same problem with that "token error". It is not a problem on one of my Obi devices, which is linked to one Google Voice account, but there exists that problem with another Obi device, which is linked to another Google Voice account.


Isn't there one moderator here who has a contact to report to Google and Obihai?

Obihai support has been unresponsive for years, so I didn't even try.

Did anyone here try Obihai or Google support?