re: Route Google Voice calls through a Callcentric phone number (updated 5/202

Started by pv08, August 20, 2021, 09:21:02 AM

Previous topic - Next topic

pv08

In http://www.obitalk.com/forum/index.php?topic=17024.0, it contains these notes:

QuoteScroll down to Calls-->Inbound calls. There are green or gray toggle switches to the right of each device.  Toggle OFF your OBiTALK device, and toggle ON your CC phone number below that, in the Linked numbers section.

I was wondering if this was a typo because my phone doesn't ring with those settings. It DOES ring with these settings:

...Toggle ON your OBiTALK device, and toggle OFF your CC phone number...

If this was not a typo, then I guess this means my setup is messed up somewhere else.... Any thoughts? (FYI, I reached this point after performing a factory reset with my OBI200 and reconfigured everything. The reason I went through that is b/c I realized that I could not complete a call to 17771234567. The reason I attempted that was because I noticed I'm getting 603 error messages when trying to call some local phone numbers.)

Thanks in advance. BTW, this forum is currently throwing strange errors when saving new posts. It gives the impression that the posts are not getting saved successfully.

pv08

My SP1 is google voice, and SP2 is callcentric. I can't seem to make calls successfully unless I have SP2 (callcentric) set as the Primary Line for Outgoing Calls. However, the recipient's caller ID shows my callentric phone number instead of my google voice number. Is this a known issue, or is there a way to fix this?

drgeoff

Quote from: pv08 on August 20, 2021, 09:21:02 AM
In http://www.obitalk.com/forum/index.php?topic=17024.0, it contains these notes:

QuoteScroll down to Calls-->Inbound calls. There are green or gray toggle switches to the right of each device.  Toggle OFF your OBiTALK device, and toggle ON your CC phone number below that, in the Linked numbers section.

I was wondering if this was a typo because my phone doesn't ring with those settings. It DOES ring with these settings:

...Toggle ON your OBiTALK device, and toggle OFF your CC phone number...

If this was not a typo, then I guess this means my setup is messed up somewhere else.... Any thoughts? (FYI, I reached this point after performing a factory reset with my OBI200 and reconfigured everything. The reason I went through that is b/c I realized that I could not complete a call to 17771234567. The reason I attempted that was because I noticed I'm getting 603 error messages when trying to call some local phone numbers.)

Thanks in advance. BTW, this forum is currently throwing strange errors when saving new posts. It gives the impression that the posts are not getting saved successfully.

Not a typo. If routing incoming GV calls via Callcentric then you should NOT have GV forward them to your OBi. Only to your Callcentric number.

drgeoff

Quote from: pv08 on August 20, 2021, 11:00:43 AM
My SP1 is google voice, and SP2 is callcentric. I can't seem to make calls successfully unless I have SP2 (callcentric) set as the Primary Line for Outgoing Calls. However, the recipient's caller ID shows my callentric phone number instead of my google voice number. Is this a known issue, or is there a way to fix this?
If you have set SP2 (configured for Callcentric) as the Primary Line then your outgoing calls are using Callcentric. GV is not involved at all and callees will see your Callcentric number.

Taoman

Quote from: drgeoff on August 20, 2021, 12:33:19 PM
GV is not involved at all and callees will see your Callcentric number.

While that is the default setting it is a simple matter to get your outgoing caller id be your GV number by opening a Trouble Ticket thru Support.

https://www.callcentric.com/faq/31/218

drgeoff

Quote from: Taoman on August 20, 2021, 12:45:37 PM
Quote from: drgeoff on August 20, 2021, 12:33:19 PM
GV is not involved at all and callees will see your Callcentric number.

While that is the default setting it is a simple matter to get your outgoing caller id be your GV number by opening a Trouble Ticket thru Support.

https://www.callcentric.com/faq/31/218
True but AIUI the OP's actual problem is that the OBi<>GV is FUBAR. That is what needs fixing.

SteveInWA

Gee, I forgot about that post.  I just read through it again, and it is still accurate as-is.

Note that the very first thing I have on the bullet list is an assumption that your Google Voice service is already working correctly with your OBiTALK device.  You must confirm that this works, without any added complexity of forwarding through Callcentric.  It sounds like you didn't do that, or whatever you did isn't working.  Go back and fix that.

pv08

Thanks for the responses. I've just removed SP2 (callcentric), and validated incoming/outgoing calls both work as expected with just the OBI/Google Voice setup. I'll re-add SP2 (callcentric) and try again now.

pv08

Quote from: pv08 on August 20, 2021, 03:02:04 PM
Thanks for the responses. I've just removed SP2 (callcentric), and validated incoming/outgoing calls both work as expected with just the OBI/Google Voice setup. I'll re-add SP2 (callcentric) and try again now.

Actually, before re-adding SP2 (callcentric), I noticed this test number results in "could not complete your call.... Please try again": 777-1234567

Are any of you who use Google Voice currently able to complete a call to that number? Maybe this is a clue regarding what I have wrong with my setup.

Taoman

Quote from: pv08 on August 20, 2021, 03:05:31 PM

Actually, before re-adding SP2 (callcentric), I noticed this test number results in "could not complete your call.... Please try again": 777-1234567

Well that explains it. That is NOT a phone number. It is your Callcentric SIP username. You can only call that SIP username via a SIP URI call.

Go to your Callcentric Dashboard. In the middle of the screen should be something that says PRODUCTS. There should be a real (1+10-digit) phone number under that heading. That is the number you should be using when adding Callcentric to your GV account.

You use the Callcentric SIP username when adding SP2 to your OBi device.


SteveInWA

Quote from: Taoman on August 20, 2021, 04:12:06 PM
Quote from: pv08 on August 20, 2021, 03:05:31 PM

Actually, before re-adding SP2 (callcentric), I noticed this test number results in "could not complete your call.... Please try again": 777-1234567

Well that explains it. That is NOT a phone number. It is your Callcentric SIP username. You can only call that SIP username via a SIP URI call.

Go to your Callcentric Dashboard. In the middle of the screen should be something that says PRODUCTS. There should be a real (1+10-digit) phone number under that heading. That is the number you should be using when adding Callcentric to your GV account.

You use the Callcentric SIP username when adding SP2 to your OBi device.



...which is exactly what I said in my instructions.  As the saying goes, "reading is fundamental".

Quote
Sign into your Gmail account and go to the Google Voice settings page:  (https://voice.google.com/settings).  Go to the "Linked numbers" section, and click "+New linked number".  Add your new CC DID number (the actual telephone number, which typically begins with a New York State Area Code, NOT the 1777 number).  Complete the verification phone call.  Scroll down to Calls-->Inbound calls. There are green or gray toggle switches to the right of each device.  Toggle OFF your OBiTALK device, and toggle ON your CC phone number below that, in the Linked numbers section.

Taoman

Quote from: SteveInWA on August 20, 2021, 04:19:03 PM

...which is exactly what I said in my instructions.  As the saying goes, "reading is fundamental".

And as another saying goes, "reading is hard!"  ;)

drgeoff


pv08

Looks like I have it working now.

In case the following items help anyone else who might be as incompetent and/or illiterate as me, here are the 2 pieces of info that I learned through this:
1) When adding SP2 for callcentric, the Primary Line for Outgoing Calls was unchecked by default for me. You need to check it.
2) To get your outgoing caller id be your GV number, you need to submit a separate request for this: https://www.callcentric.com/faq/31/218

Thank you Taoman, SteveinWA, and drdork.

Taoman

Quote from: pv08 on August 21, 2021, 08:57:02 AM

1) When adding SP2 for callcentric, the Primary Line for Outgoing Calls was unchecked by default for me. You need to check it.


So you want your Primary Outgoing line to be Callcentric? Why? Wouldn't you want Google Voice to be your Primary Outgoing line so you're not paying anything?

Which Callcentric outbound plan do you have?

drgeoff

Quote from: Taoman on August 21, 2021, 09:09:39 AM
Quote from: pv08 on August 21, 2021, 08:57:02 AM

1) When adding SP2 for callcentric, the Primary Line for Outgoing Calls was unchecked by default for me. You need to check it.


So you want your Primary Outgoing line to be Callcentric? Why? Wouldn't you want Google Voice to be your Primary Outgoing line so you're not paying anything?

Which Callcentric outbound plan do you have?
Maybe the OP is under the mistaken impression that having incoming calls to his GV number routed through Callcentric (to get Caller Name?) means that outgoing calls must be made through Callcentric.