question about using SP2

Started by fred999, February 06, 2022, 12:39:20 PM

Previous topic - Next topic

fred999

Hi all,

I have an issue maybe someone can set me straight on.

Using an Obi202:
I have SP1 configured, using Tektalk as my primary provider.
I have SP2 configured, using voip.ms, status is "registered".
Incoming calls work fine.

My understanding is to dial out using SP2, I need to use **2 - for example **2 1 705 123 1234 (no spaces)

When I try that, it comes back with "rejected by service provider, code 503"

Googling code 503 says the server is down.  Does that make sense?  How can a server be down for such a long time?
Should I try changing to a different server?  Apparently there are 8 servers available in Toronto.  Is it ok to change servers any time?

Thanks.

drgeoff

SIP error code 503 does not mean "the server is down".

It means that service is unavailable.  That could be caused by an inappropriate service request.

First check if your 202 is configured to permit admin access from its WAN port. (The one labelled INTERNET.)  IFfnot enable it.  Then point a browser at the 202's IP address on your LAN.  Log in using admin as the name and admin is the default password.  Click on Status and then on Call History. Examine what number the 202 has sent to the ITSP.

fred999

#2
Checking the call history indicates the correct number is being sent:

   From PH1  To SP2(1416320xxxx)     Call Ended (503 Service Unavailable)

Doesn't seem to matter if I use the leading "1" or not - I thought it might because SP2 is an area code which is LD to me  ie SP1 is 416 area code, and SP2 is 705 area code

Should I be thinking of changing the server?  Currently it's Toronto7.

Thanks.

On edit, I notice there's a yellow triangle, reboot required symbol.  I'll try rebooting and see what happens.

edit 2: I rebooted and now the triangle is replaced by "config current", but the problem persists.

drgeoff

#3
Any logs or other info available at voip.ms?  I don't use voip.ms so don't know what is there.  I assume you have some credit at voip.ms which should permit you to make calls.

voip.ms has a page about configuring OBi devices. https://wiki.voip.ms/article/OBi_100/110 Are you using that info or using the obitalk portal 'wizard'?

Lavarock7

With Voip.Ms make sure that you enabled Canada as an acceptable foreign country. I would guess it is enabled by default, but who knows.

An oddity I found: From the U.S. I had to enable Hawaii and an acceptable International destination even though it is one of the 50 states.
My websites: Kona Coffee: http://itskona.com and Web Hosting: http://planetaloha.info
A simplified Voip explanation: http://voip.planet-aloha.com

fred999

#5
Quote from: drgeoff on February 07, 2022, 08:49:13 AM
Any logs or other info available at voip.ms?  I don't use voip.ms so don't know what is there.  I assume you have some credit at voip.ms which should permit you to make calls.

voip.ms has a page about configuring OBi devices. https://wiki.voip.ms/article/OBi_100/110 Are you using that info or using the obitalk portal 'wizard'?

There is a call detail log at voip.ms.  The details look correct, but the disposition only says "failed".  Except for inbound, they say "answered".

I did look at that config page, but I used the portal wizard.... it looked so much simpler.

There is one item on that config page that catches my eye:

" An additional note regarding outgoing calls

In at least one instance it was necessary to specify a non-default outbound calling route in the OBi110 to be able to place calls using the voip.ms service. The default setting had the OBi110 attempting to place calls using the PSTN port on the device. The relevant setting is:
PrimaryLine: (Select from drop-down) "

I checked my two ports, and for SP1 the primary line is "SP1 service", and for SP2 it's also "SP1 service".
This SP2 should maybe be "SP2 service", but isn't the purpose of using the " **2 " to force it to use SP2?

Thanks.

fred999

#6
Quote from: Lavarock7 on February 07, 2022, 01:08:00 PM
With Voip.Ms make sure that you enabled Canada as an acceptable foreign country. I would guess it is enabled by default, but who knows.

An oddity I found: From the U.S. I had to enable Hawaii and an acceptable International destination even though it is one of the 50 states.

On the main portal page, there's a setting "Allow International Calls" which is disabled, but the help text says:
"when disabled, calls placed to destinations outside USA48/Canada will be rejected".

I tried changing it to allow, but same error.

It seems odd to me, when I try the " **21416xxxxxxx" the recording which tells me the call is rejected, it repeats the whole number, including the " **2", as if the **2 is part of the number.  But when I look at the call history on the 202, it has dropped the **2.

So it seems the **2 is going out to the server, and it doesn't know what it means.

Does that make sense?

Thanks.

On edit, I checked the call records at voip.ms, and the number is correct, without the **2, so it is dropping the **2 properly.
But then why does the recording quote the whole number, which includes the **2 ?

drgeoff

#7
The message you hear quoting the number with **2 at the beginning is generated within your OBi. It is normal that it speaks what you dialled on the phone, not what gets sent to the service provider.

If the correct number is shown in the voip.ms log then there is no problem with your OBi and you should ask voip.ms why the calls are not proceeding.

Your understanding of Primary Line is incorrect.  Primary Line is a parameter of a Phone Port not of a SP.  If you have only one phone and it is plugged into the PHONE1 jack then the Primary Line setting for Phone 1 is the only one that has any relevance to you.

Taoman

Quote from: drgeoff on February 08, 2022, 09:47:19 AM

If the correct number is shown in the voip.ms log then there is no problem with your OBi and you should ask voip.ms why the calls are not proceeding.

^^This^^

If your OBi registers successfully and inbound calls work and outbound calls fail but do show up in the Voip.ms call log then the problem is on the Voip.ms side, not your OBi. Are you sure you don't have any kind of account restrictions in your Voip.ms settings? This has happened to me before.

Voip.ms recently implemented live chat. You might give that a try.

fred999

Quote from: Taoman on February 08, 2022, 10:05:19 AM
Quote from: drgeoff on February 08, 2022, 09:47:19 AM

If the correct number is shown in the voip.ms log then there is no problem with your OBi and you should ask voip.ms why the calls are not proceeding.

^^This^^

If your OBi registers successfully and inbound calls work and outbound calls fail but do show up in the Voip.ms call log then the problem is on the Voip.ms side, not your OBi. Are you sure you don't have any kind of account restrictions in your Voip.ms settings? This has happened to me before.

Voip.ms recently implemented live chat. You might give that a try.

Wow, I went through all the menu options, and under Account settings, General, there's an option called CallerId number.
It was set at "use a custom caller id" (which I never set), and the field was blank.
I changed it to "use one of my DID's" and now everything works!

Thanks a lot guys, I appreciate your help.

TrustySnowman

Awesome and interesting article. Great things you've always shared with us. Thanks. Just continue composing this kind of post.



kroger express hr

drgeoff