On Tuesday September 6th the forum will be down for maintenance from 9:30 PM to 11:59 PM PDT

Main Menu

Help Config don't want to hear initial ringing

Started by briankelly, August 25, 2011, 08:17:22 AM

Previous topic - Next topic


I recently bought the OBI110 and I'm experimenting with it on my Asterisk setup. I've used it for GV without issue.

In testing I set things to go to the PSTN line instead of GV to test the functionality of the unit and how it deals with echo.

The only drawback I see is that as soon as I finish dialing Asterisk connects to the OBI and ringing is heard immediately. After about a ring and a half (after OBI dials) the connection is bridged and then I then hear the actual ringing from the PSTN call (at a lower volume). I'd like to eliminate that first ring and a half by either having silence or by just hearing the OBI seize the line and start dialing DTMF.

Is there a way to do that with one of the dial strings?


Hi Briankelly,

By default, OBi110 assumes call is connected as soon as you finish dialing on LINE port, that is why you hear the ringback instantly, while the actually PSTN ringback comes a little bit late. OBi110 also provides advance setting on PSTN dialing, please go to

Physical Interface -> LINE port -> DetectOutboundConnectMethod

From there, you can choose OutboundConnectMethod to be "Detect Speech", the ringback will be ended as soon as the actual comes through LINE port. Please have a try, and see if you get better experience,

Thank you,


Hi, I did come across that setting when I was experimenting with the GV connection. I can see how that might be helpful in some circumstances.

I was looking for some setting that would switch over immediately or would suppress any ringing.

I suppose the other option would be to change the ringing tone to something that couldn't be heard. Do the tonal ranges allow for something like that?


Quote from: briankelly on August 25, 2011, 11:37:26 AM
I was looking for some setting that would switch over immediately or would suppress any ringing.

This is the exact issue I'm dealing with right now as well. I'm finding that:

Physical Interface -> LINE port -> DetectOutboundConnectMethod

Doesn't always detect speech. As such you get what I assume is the "SIP Ringing" being generated, then a few moments later you get the "Ringing" from the PSTN. What I'd like to do is disable the "SIP Ringing" or even a period of silence until the PSTN "Ringing" starts.

Any suggestions much appreciated.