OBI200 to OBI200 calls don't go through (error message 404)

Started by RedakNY, May 08, 2022, 01:31:52 PM

Previous topic - Next topic

RedakNY

Hello OBi enthusiasts,

It seems I'm experiencing EoL phase prematurely (or else?). Beginning April 1st 2022 my weekly free phone calls to my mom's obi200 located in Serbia (mind you, this is not Siberia) are no more. OBi to OBi calls (**9 obi number) in either direction are not connecting (error sound followed by the message: Rejected by service provider, reason 404).

The status for both units on OBitalk Dashboard is Online (US OBi is with GVoice as SP1= connected); **9 222 222 222 tests passed;  IP addresses obtained by dialing ***1; OBis rebooted as well as corresponding routers; Serbia's OBi Phone LED is off (don't know whether this was always the case); US OBi (with GVoice) works normally: receiving and placing local and international calls.

Note: On 04/01/22 when the problems started there was OBiTALK maintenance scheduled for that day (related?).

Update 1: Tested my OBi with friend's OBi here in US by successfully placing and receiving calls to each other's OBi numbers.

Update 2: Going to OBiTALK Dashboard, accessing OBi Expert and then System Status there's a field at the bottom titled OBiTALK Service Status. Pinging the addr number shown here for OBi in Serbia: 62.240.24.171:2176(10000), results in request timed out and 100% packets loss unlike the US OBi unit. Am I onto something here? Some IP blocking taking place due to eastern conflict?

Any insight/advice is much appreciated. Thank you.

Redak

drgeoff

Can the Serbia OBi successfully reach the **9 222 222 222 echo test number?

RedakNY

Affirmative. One of the first things I asked my brother to check for me. All the settings are OBiTALK default (including Auto Provisioning). Firmware on Serbia OBi did not get automatically updated (was on the version 3.2.2 5898EX) so we did manual update to the latest (8680EX).

drgeoff

The Obitalk Service Status should be showing "Normal (User Mode)".

Where are you seeing that 62.240.24.171:2176(10000) ?

RedakNY

Yes, you're right it does say "Normal (User Mode)" but it also list (now I got it) the users' public IP.

obitalk.JPG

azrobert

You can try a different service provider. Callcentric has a free IP Freedom account.
https://www.callcentric.com/products/

Define 2 extensions in your IP Freedom account. The main account, 1777xxxxxxx defaults to extension 100 then define a 2nd extension, 1777xxxxxxx101.

In OBiTalk select Callcentric as your service provider then enter the extension account number and password. You register as extension 100 and the Serbia OBi as extension 101. Dial the extension number to call the other person. The easiest way is to setup a speed dial.

Assuming Callcentric is defined on SP1:
sp1(100)
and
sp1(101)

RedakNY

It rings! It works! It communicates!

Thank you for such an elegant solution/alternative and 123 guide. I admit I was a bit skeptical, thinking it couldn't be so simple. But it was: registering with CallCentric, adding 2nd extension; back to OBiTalk selecting CallCentric as SP2 and afterwards Serbia OBi as SP1. Both OBies got registered in a matter of seconds and ready to go. Placed a call by dialing **2101 (this is going to be my speed dial for mom). This concludes Mom 101 course :). And you, azrobert, got an A+.

azrobert

Do you notice a long delay after you dial **2101?
This is caused by the default digit map not having a rule that explicitly matches "101".

This 10 second delay can be eliminated by one of the following:
Dial **2101#
Define a speed dial as I suggested in my last post
Dial 101 (This requires an OBi Expert config change)

RedakNY

Indeed, noticed the delay but didn't mind as  long as it works. I was thinking i have to first tell OBi what SP I'm calling from and then dial the #. Hello oh, just put SP2(101) in Speed dial settings and OBi will take care of it you ignorant (telling it to myself).
Capture.JPG
Did that, called my mom by pressing 5#, got immediate ringing and spent over an hour talking with her. The first thing she asked me was did I thank the person who helped me with this. So thanks again... from my mom.