set outgoing caller id Obi2182

Started by shadow1967, June 10, 2022, 06:52:02 PM

Previous topic - Next topic

shadow1967

I have just acquired an OBI 2182 ip phone. I have several providers set up and working with no problem. However, I have a problem with BulkVS on this device. For my other providers, I can set outgoing caller id on their web page and then complete calls with no problem. While BulkVS registers, I can make almost no outgoing calls. This is because my account number user name is being sent as the calling number which causes calls to be rejected. On the extremely few calls that complete, the incoming caller id shows my 6 digit account number. I can not find any setting on the 2182 (or my obi200 either for that matter) that will let me set the outgoing caller number so that calls will not be rejected. I contacted BulkVS and they said they have no way for me to set it with them. They simply pass what the device sends as the calling number. They say it is up to the user to set the calling number to be sent on a call. Has anyone successfully set up BulkVS as a provider on an Obi device and have calls complete? Searches have failed me thus far. Thanks for your time.

drgeoff

#1
I have neither a BulkVS account nor an OBi2182.  I do have several ITSP accounts and OBi100, OBi110, OBi200, OBi202 and OBi1032.

None of those OBis has the facility to set the Calling Number which will be used on outbound calls.

None of my ITSP accounts has the facility to set the Calling Number on a call by call basis.  All of those ITSPs control the Calling Number.  For the accounts which have a standard number for incoming calls from the worldwide public phone networks that number is automatically used as the calling number.  For the one account which I use for outgoing calls only, there is no inbound number.  In that case I asked the ITSP to set the calling number to one of the other phone numbers I have.  After a verification that I do indeed "own" that number the calls on that outbound-only ITSP show it.

I would not expect an ITSP to allow the caller to unilaterally determine the calling number as that makes it far to easy to spoof the calling number.

Perhaps there is some confusion between you and BulkVS.  Standard SIP and OBis have the facility to include Caller Name in the call setup messages.  You can set CallerIDName in the Calling Features section of the relevant Voice Services/SPx Service page.  However that Caller Name typically only reaches the callee when the call is entirely SIP end to end.  Caller Name is not conveyed across most of the public phone networks.

shadow1967

Thank you for your reply. As you correctly indicated, MOST service providers do not allow you to arbitrarily set the number for outgoing ANI or caller id purposes. Indeed, I have accounts set up with many providers, including Callcentric, VoIPms, Callwithus, and Vitelity, and those accounts all work flawlessly from the Obi2182. For those providers, the settings for the account determine outgoing calling number. I made an account with BulkVS because their rates are extremely low compared to the others and I wanted to try them out. I have set up the service on my asterisk pbx and it works great. On asterisk, I am able to set outgoing caller id for each trunk I have. I had a problem getting BulkVS to work with a grandstream ATA because it did not have a setting for setting the outgoing caller number. My outgoing calls would fail because my account user id was being sent as the calling number. I researched and realized that if you put a telephone number in the user id field and put your account user id in the Auth user id field that the calls would complete ok. I tried this methodology on the Obi but it does not work for me.

BulkVS seems to be geared for resellers, and there is no outgoing caller number associated with your account. In fact, you can have outbound calling with them without having any telephone numbers at all associated with the account. When you make an outgoing call on BulkVS, whatever outgoing caller id is sent by the equipment is passed through by BulkVS. In their explanation to me, "Whatever number you send to us we pass on as the calling number". So, there is no confusion between me and BulkVS, I just need to figure out a way to make the Obi send a valid telephone number as the calling number instead of my account number. If anyone knows a way I would appreciate it. Thanks all so much for your time.

Taoman

#3
Quote from: shadow1967 on June 12, 2022, 07:44:09 AMIf anyone knows a way I would appreciate it. Thanks all so much for your time.

I was messing around with the OutboundCallRoute and was able to send an outbound callerid number from my OBi to voip.ms after I edited my subaccount and selected "I use a system capable of passing its own CallerID" for CallerID Number. So I know it works and should work with BulkVS.

The following syntax at the beginning of the OutboundCallRoute worked for my test case.

{4443:sp2(XXXXXXXXXX>$2)}
XXXXXXXXXX is the CID you want to send with the outbound call
4443 is just a test number I used which is an echo test voip.ms supports
$2 is an internal variable the desired cid has been redirected to

Let's say you want every number you dial that is prefaced with an 8 to use your BulkVS trunk and also send your outgoing cid number.

Beginning of Phone Port DigitMap after first paren
8xxxxxxx|8xxxxxxxxxx|81xxxxxxxxxx|
Beginning of Phone Port OutboundCallRoute
{(<8:>(xxxxxxx|xxxxxxxxxx|1xxxxxxxxxx)):spX(5552226666>$2)},

shadow1967

ok thank you for looking at this. I found under phone settings outbound call route that looks like this:

{([1-9]x?*(Mpli)):pp},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**3:>(Msp3)):sp3},{(<**4:>(Msp4)):sp4},{(<**6:>(Msp6)):sp6},{(<##:>):li},{(<**70:>(Mli)):li},{(<**8:>(Mbt)):bt},{(<**9:>(Mpp)):pp},{(Mpli):pli}

I have 6 providers set up on this phone, so I do not want to mess anything up for the rest of them. I have BulkVS set up as SP3. Please forgive my ignorance, but what exactly do I need to change in the string above that only will affect SP3 so that I can dial out any number and use a set outgoing calling number? I am guessing it would be in the part:

{(<**3:>(Msp3)):sp3}

would I just need to make it

{(<**3:>(Msp3)):sp3(5552226666>$2} ?

I do not want to dial an 8 or anything first. Just hit the line for SP3 and dial a number.

Thanks again for your time looking at this.

shadow1967

Since I am using SP3 should the variable be $3? What is the significance of the variable?

thanks

Taoman

Quote from: shadow1967 on June 12, 2022, 05:42:02 PMwould I just need to make it

{(<**3:>(Msp3)):sp3(5552226666>$2} ?


Yes, that works also. Forgot you were using an OBi2182.

No, you would still use $2 since that's the second number being processed.
The number you are dialing is the first number processed. It has nothing to do with the SP number/slot you are using.

drgeoff

Quote from: shadow1967 on June 12, 2022, 05:42:02 PMwould I just need to make it

{(<**3:>(Msp3)):sp3(5552226666>$2} ?
There is a missing ) in that.  It should be

{(<**3:>(Msp3)):sp3(5552226666>$2)}

Taoman

Quote from: shadow1967 on June 15, 2022, 10:11:26 AM{(<**3:>(Msp3)):sp3(5552226666>$2} ?
Quote from: drgeoffThere is a missing ) in that.  It should be

{(<**3:>(Msp3)):sp3(5552226666>$2)}
Indeed. I missed that. OP hasn't returned so I assume he got it working.

shadow1967

thank you for your help...sorry I have not been back for an update. Before I tried this solution in the expert settings, I tried one more change in the "basic" settings. It turns out if you place a telephone number in the URI field it will send that out as the calling number. I had originally tried placing it in the username field and the account username in the URI field, but I had it backwards. It works flawlessly without having to adjust strings in expert settings. I am by no means any type of expert on this stuff, so not sure why it works, but it does...at least for BulkVS. Thanks again very much for looking into this issue  :)